aboutsummaryrefslogtreecommitdiff
path: root/devel/py-pop-config/Makefile
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2020-10-12 10:44:13 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2020-10-12 10:44:13 +0000
commit9009b9691f51d498ee8ee661fa74259ce01a6595 (patch)
treeb64e03b6bccd441f8ee7eb41b3a43c884fcbad23 /devel/py-pop-config/Makefile
parent87c492b2f25fc9fe4b456f5965571b73ae270f82 (diff)
downloadports-9009b9691f51d498ee8ee661fa74259ce01a6595.tar.gz
ports-9009b9691f51d498ee8ee661fa74259ce01a6595.zip
Add devel/py-pop-config
Tool for creating configuration options for pop projects https://gitlab.com/saltstack/pop/pop-config
Notes
Notes: svn path=/head/; revision=552119
Diffstat (limited to 'devel/py-pop-config/Makefile')
-rw-r--r--devel/py-pop-config/Makefile23
1 files changed, 23 insertions, 0 deletions
diff --git a/devel/py-pop-config/Makefile b/devel/py-pop-config/Makefile
new file mode 100644
index 000000000000..2eba4ddf4a12
--- /dev/null
+++ b/devel/py-pop-config/Makefile
@@ -0,0 +1,23 @@
+# Created by: Kirill Ponomarev <krion@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= pop-config
+PORTVERSION= 6.10
+CATEGORIES= devel python
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= krion@FreeBSD.org
+COMMENT= Tool for creating configuration options for pop projects
+
+LICENSE= APACHE20
+
+USES= python:3.6+ shebangfix
+USE_PYTHON= autoplist distutils
+
+USE_GITLAB= yes
+GL_ACCOUNT= saltstack/pop
+GL_COMMIT= cad9566d80253d6a2b7a5b7e2b1e0a8e690ca00b
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>