aboutsummaryrefslogtreecommitdiff
path: root/devel/py-psyco
diff options
context:
space:
mode:
authorHye-Shik Chang <perky@FreeBSD.org>2002-09-11 07:12:41 +0000
committerHye-Shik Chang <perky@FreeBSD.org>2002-09-11 07:12:41 +0000
commit1220dc3df874778b892d1e5126a0b4d5b8a7f470 (patch)
tree90d58a33f8c92252483b059c0fafa0444acc97df /devel/py-psyco
parentac05d0f071c6680f2a63a143c7bdae61fcd7ed39 (diff)
downloadports-1220dc3df874778b892d1e5126a0b4d5b8a7f470.tar.gz
ports-1220dc3df874778b892d1e5126a0b4d5b8a7f470.zip
Notes
Diffstat (limited to 'devel/py-psyco')
-rw-r--r--devel/py-psyco/Makefile23
-rw-r--r--devel/py-psyco/distinfo1
-rw-r--r--devel/py-psyco/pkg-comment1
-rw-r--r--devel/py-psyco/pkg-descr8
-rw-r--r--devel/py-psyco/pkg-plist8
5 files changed, 41 insertions, 0 deletions
diff --git a/devel/py-psyco/Makefile b/devel/py-psyco/Makefile
new file mode 100644
index 000000000000..74209f333e7e
--- /dev/null
+++ b/devel/py-psyco/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: py-psyco
+# Date created: 5 September 2002
+# Whom: Alex Rodioukov <simuran@shaw.ca>
+#
+# $FreeBSD$
+#
+
+PORTNAME= psyco
+PORTVERSION= 0.4.1
+CATEGORIES= devel python
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= psyco
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= ${PORTNAME}-${PORTVERSION}-src
+
+MAINTAINER= simuran@shaw.ca
+
+USE_PYTHON= yes
+USE_PYDISTUTILS=yes
+
+WRKSRC= ${WRKDIR}/psyco-${PORTVERSION}
+
+.include <bsd.port.mk>
diff --git a/devel/py-psyco/distinfo b/devel/py-psyco/distinfo
new file mode 100644
index 000000000000..ebb7eeda882e
--- /dev/null
+++ b/devel/py-psyco/distinfo
@@ -0,0 +1 @@
+MD5 (psyco-0.4.1-src.tar.gz) = ed8f400898c4540cd87bf5270b126609
diff --git a/devel/py-psyco/pkg-comment b/devel/py-psyco/pkg-comment
new file mode 100644
index 000000000000..f6e886c9d5a1
--- /dev/null
+++ b/devel/py-psyco/pkg-comment
@@ -0,0 +1 @@
+Python Specializing Compiler
diff --git a/devel/py-psyco/pkg-descr b/devel/py-psyco/pkg-descr
new file mode 100644
index 000000000000..2b4a5afd8017
--- /dev/null
+++ b/devel/py-psyco/pkg-descr
@@ -0,0 +1,8 @@
+Psyco shows that it is possible to execute Python code at speeds
+approaching that of fully compiled languages, by "specialization". The
+current prototype operates on i386-compatible processors and shows 2
+to 100 times speed-ups, depending on code.
+
+WWW: http://psyco.sourceforge.net/
+
+- Alex Rodioukov <simuran@shaw.ca>
diff --git a/devel/py-psyco/pkg-plist b/devel/py-psyco/pkg-plist
new file mode 100644
index 000000000000..87c82143397a
--- /dev/null
+++ b/devel/py-psyco/pkg-plist
@@ -0,0 +1,8 @@
+%%PYTHON_SITELIBDIR%%/psyco/__init__.py
+%%PYTHON_SITELIBDIR%%/psyco/__init__.pyc
+%%PYTHON_SITELIBDIR%%/psyco/__init__.pyo
+%%PYTHON_SITELIBDIR%%/psyco/_psyco.so
+%%PYTHON_SITELIBDIR%%/psyco/classes.py
+%%PYTHON_SITELIBDIR%%/psyco/classes.pyc
+%%PYTHON_SITELIBDIR%%/psyco/classes.pyo
+@dirrm %%PYTHON_SITELIBDIR%%/psyco/