aboutsummaryrefslogtreecommitdiff
path: root/devel/py-qt4-script
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-09-13 17:45:07 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-09-13 17:45:07 +0000
commita2370e4764130db746cb8d8774e001a699eb4161 (patch)
treeafa84d82cb032dcd9074669b5fde3c8c628fca49 /devel/py-qt4-script
parent0504b2aaf114a4282b4d3f2b4a9541a818c597b4 (diff)
Notes
Diffstat (limited to 'devel/py-qt4-script')
-rw-r--r--devel/py-qt4-script/Makefile79
-rw-r--r--devel/py-qt4-script/distinfo3
-rw-r--r--devel/py-qt4-script/pkg-descr4
-rw-r--r--devel/py-qt4-script/pkg-plist11
4 files changed, 97 insertions, 0 deletions
diff --git a/devel/py-qt4-script/Makefile b/devel/py-qt4-script/Makefile
new file mode 100644
index 000000000000..ad97987c90d2
--- /dev/null
+++ b/devel/py-qt4-script/Makefile
@@ -0,0 +1,79 @@
+# New ports collection makefile for: py-qt4-script
+# Date created: 2007-08-06
+# Whom: Danny Pansters <danny@ricin.com>
+#
+# $FreeBSD$
+
+PORTNAME= script
+PORTVERSION= 4.3
+CATEGORIES= devel python
+MASTER_SITES= http://www.riverbankcomputing.com/Downloads/PyQt4/GPL/ \
+ http://freebsd.ricin.com/ports/distfiles/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}qt4-
+DISTNAME= PyQt-x11-gpl-${PORTVERSION}
+
+MAINTAINER= danny@ricin.com
+COMMENT= Python bindings for the Qt4 toolkit, QtScript module
+
+BUILD_DEPENDS= ${LOCALBASE}/bin/sip:${PORTSDIR}/devel/py-sip
+RUN_DEPENDS= ${PYTHON_SITELIBDIR}/PyQt4/QtCore.so:${PORTSDIR}/devel/py-qt4-core
+
+HAS_CONFIGURE= yes
+USE_PYTHON= 2.5+
+USE_QT_VER= 4
+QT_COMPONENTS= script qmake
+
+OPTIONS= API "Install QtScript API for QScintilla2" on \
+ DEBUG "Enable debugging in generated code" off \
+ SIPFILES "Install the QtScript SIP files" on \
+ TRACING "Enable tracing in generated code" off
+
+PATCHDIR= ${PORTSDIR}/devel/py-qt4-core/files
+OPTIONSFILE= ${PORT_DBDIR}/py-qt4-${PORTNAME}/options
+SIPDIR= ${PREFIX}/share/py-sip
+CONFIGURE_ENV+= PYQT4_COMPONENT="${PORTNAME}"
+ARGS= -b ${PREFIX}/bin\
+ -d ${PYTHON_SITELIBDIR}\
+ -q ${QT_PREFIX}/bin/qmake-qt4
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_DEBUG)
+ARGS+= --debug
+.endif
+.if defined(WITHOUT_API)
+ARGS+= --no-qsci-api
+PLIST_SUB+= API="@comment "
+PLIST_SUB+= APIFILE="@comment "
+.else
+LIB_DEPENDS+= qscintilla2.2:${PORTSDIR}/devel/qscintilla2
+ARGS+= --qsci-api
+PLIST_SUB+= API=""
+PLIST_SUB+= APIFILE="share/qt4/qsci/api/python/QtScript.api"
+.endif
+.if defined(WITHOUT_SIPFILES)
+ARGS+= --no-sip-files
+PLIST_SUB+= SIPFILES="@comment "
+PLIST_SUB+= SIPDIR="@comment "
+.else
+ARGS+= --sipdir ${SIPDIR}
+PLIST_SUB+= SIPFILES=""
+PLIST_SUB+= SIPDIR="share/py-sip"
+.endif
+.if defined(WITH_TRACING)
+ARGS+= --trace
+.endif
+ARGS+= --enable QtScript
+
+do-configure:
+ cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV}\
+ ${PYTHON_CMD} configure.py ${ARGS}
+
+post-configure:
+ ${REINPLACE_CMD} -e 's|mkspecs/freebsd-g++|share/qt4/mkspecs/freebsd-g++|'\
+ -e 's|CC = cc|CC = ${CC}|'\
+ -e 's|CXX = c++|CXX = ${CXX}|'\
+ -e 's|LINK = c++|LINK = ${CXX}|'\
+ ${WRKSRC}/QtScript/Makefile
+
+.include <bsd.port.post.mk>
diff --git a/devel/py-qt4-script/distinfo b/devel/py-qt4-script/distinfo
new file mode 100644
index 000000000000..504192030ea8
--- /dev/null
+++ b/devel/py-qt4-script/distinfo
@@ -0,0 +1,3 @@
+MD5 (PyQt-x11-gpl-4.3.tar.gz) = 3bb0c0064dc6b8b80413f87a14e5553c
+SHA256 (PyQt-x11-gpl-4.3.tar.gz) = c184c3df596c13e9ed610aa8fa0504881976c4d972ccab1b739738a95f4ab0e5
+SIZE (PyQt-x11-gpl-4.3.tar.gz) = 6036193
diff --git a/devel/py-qt4-script/pkg-descr b/devel/py-qt4-script/pkg-descr
new file mode 100644
index 000000000000..7746c223c3df
--- /dev/null
+++ b/devel/py-qt4-script/pkg-descr
@@ -0,0 +1,4 @@
+PyQt4 is a set of Python bindings for Trolltech's Qt4 application framework.
+This package provides the QtScript module.
+
+WWW: http://www.riverbankcomputing.co.uk/pyqt/
diff --git a/devel/py-qt4-script/pkg-plist b/devel/py-qt4-script/pkg-plist
new file mode 100644
index 000000000000..bda6cb63f5fd
--- /dev/null
+++ b/devel/py-qt4-script/pkg-plist
@@ -0,0 +1,11 @@
+%%PYTHON_SITELIBDIR%%/PyQt4/QtScript.so
+%%SIPFILES%%%%SIPDIR%%/QtScript/QtScriptmod.sip
+%%SIPFILES%%%%SIPDIR%%/QtScript/qscriptcontext.sip
+%%SIPFILES%%%%SIPDIR%%/QtScript/qscriptengine.sip
+%%SIPFILES%%%%SIPDIR%%/QtScript/qscriptvalue.sip
+%%SIPFILES%%%%SIPDIR%%/QtScript/qscriptvalueiterator.sip
+%%SIPFILES%%@dirrm %%SIPDIR%%/QtScript
+%%API%%%%APIFILE%%
+%%API%%@dirrmtry share/qt4/qsci/api/python
+%%API%%@dirrmtry share/qt4/qsci/api
+%%API%%@dirrmtry share/qt4/qsci