aboutsummaryrefslogtreecommitdiff
path: root/devel/qscintilla2
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-09-13 18:24:57 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-09-13 18:24:57 +0000
commitd5ac121b889d796d31335f6b2b72328d4cc56dd5 (patch)
treebab3e3e9562604fd3e29c4a504a544044400fa74 /devel/qscintilla2
parent71fee7a28f398a2397323d85043fe27f64592ff3 (diff)
downloadports-d5ac121b889d796d31335f6b2b72328d4cc56dd5.tar.gz
ports-d5ac121b889d796d31335f6b2b72328d4cc56dd5.zip
Notes
Diffstat (limited to 'devel/qscintilla2')
-rw-r--r--devel/qscintilla2/Makefile82
-rw-r--r--devel/qscintilla2/distinfo6
-rw-r--r--devel/qscintilla2/pkg-plist367
3 files changed, 221 insertions, 234 deletions
diff --git a/devel/qscintilla2/Makefile b/devel/qscintilla2/Makefile
index 680b7fde41e1..b41cd55e2ab6 100644
--- a/devel/qscintilla2/Makefile
+++ b/devel/qscintilla2/Makefile
@@ -5,39 +5,27 @@
# $FreeBSD$
PORTNAME= qscintilla2
-PORTVERSION= 20070410
-PORTREVISION= 1
+PORTVERSION= 2.1
+PORTEPOCH= 1
+PORTREVISION= # zero
CATEGORIES= devel
-MASTER_SITES= http://www.riverbankcomputing.com/Downloads/Snapshots/QScintilla2/ \
+
+MASTER_SITES= http://www.riverbankcomputing.com/Downloads/QScintilla2/ \
http://freebsd.ricin.com/ports/distfiles/
-DISTNAME= QScintilla-1.73-gpl-2-snapshot-${PORTVERSION}
+DISTNAME= QScintilla-1.73-gpl-${PORTVERSION}
MAINTAINER= danny@ricin.com
COMMENT= Qt4 port of the Scintilla C++ editor class
USE_QT_VER= 4
-QT_COMPONENTS= qmake moc gui
-USE_LDCONFIG= yes
+QT_COMPONENTS= qmake moc gui xml designer
HAS_CONFIGURE= yes
-NO_FILTER_SHLIBS= yes
-OPTIONS= DOCS "Install documentation" on \
- EXAMPLES "Install example" on \
- HEADERS "Install Qsci headers" on \
+OPTIONS= HEADERS "Install Qsci headers" on \
TRANSLATIONS "Install translations (de, fr, pt_br, ru)" off
.include <bsd.port.pre.mk>
-.if defined(NOPORTDOCS) || defined(WITHOUT_DOCS)
-PLIST_SUB+= DOCS="@comment "
-.else
-PLIST_SUB+= DOCS=""
-.endif
-.if defined(NOPORTDOCS) || defined(WITHOUT_EXAMPLES)
-PLIST_SUB+= EXAMPLES="@comment "
-.else
-PLIST_SUB+= EXAMPLES=""
-.endif
.if defined(WITHOUT_HEADERS)
PLIST_SUB+= HEADERS="@comment "
.else
@@ -50,43 +38,43 @@ PLIST_SUB+= TRANSLATIONS="@comment "
.endif
post-patch:
- ( cd ${WRKSRC}/Qt4 && ${REINPLACE_CMD} -e \
- 's|$$$$\[QT_INSTALL_LIBS\]|${WRKSRC}/lib|' qscintilla.pro )
+ cd ${WRKSRC}/Qt4 && ${REINPLACE_CMD} -e \
+ 's|$$$$\[QT_INSTALL_LIBS\]|${WRKSRC}/lib|' qscintilla.pro
.if defined(WITHOUT_HEADERS)
- ( cd ${WRKSRC}/Qt4 && ${REINPLACE_CMD} -e \
- 's|header trans qsci|trans qsci|' qscintilla.pro )
+ cd ${WRKSRC}/Qt4 && ${REINPLACE_CMD} -e \
+ 's|header trans qsci|trans qsci|' qscintilla.pro
.endif
.if !defined(WITH_TRANSLATIONS)
- ( cd ${WRKSRC}/Qt4 && ${REINPLACE_CMD} -e \
- 's|trans qsci|qsci|' qscintilla.pro )
+ cd ${WRKSRC}/Qt4 && ${REINPLACE_CMD} -e \
+ 's|trans qsci|qsci|' qscintilla.pro
.endif
do-configure:
- ( cd ${WRKSRC}/Qt4 && ${SETENV} ${CONFIGURE_ENV} \
- ${QMAKE} -unix PREFIX=${PREFIX} qscintilla.pro )
+ cd ${WRKSRC}/Qt4 && ${SETENV} ${CONFIGURE_ENV} \
+ ${QMAKE} -unix PREFIX=${PREFIX} qscintilla.pro
do-build:
- ( cd ${WRKSRC}/Qt4 && ${MAKE} )
+ cd ${WRKSRC}/Qt4 && ${MAKE}
do-install:
- ( cd ${WRKSRC}/Qt4 && ${MAKE} install )
- ( cd ${WRKSRC}/lib && \
- ${MV} libqscintilla2.so.1.0.0 libqscintilla2.so.1 && \
- ${INSTALL_DATA} libqscintilla2.so.1 ${PREFIX}/lib && \
- cd ${PREFIX}/lib && \
- ${LN} -sf libqscintilla2.so.1 libqscintilla2.so )
-.if !defined(NOPORTDOCS) && !defined(WITHOUT_DOCS)
- ( cd ${WRKSRC} && \
- ${MKDIR} -m 0755 ${DOCSDIR}/html ${DOCSDIR}/Scintilla && \
- ${INSTALL_DATA} ChangeLog NEWS README ${DOCSDIR} && \
- ${INSTALL_DATA} doc/html-Qt4/* ${DOCSDIR}/html && \
- ${INSTALL_DATA} doc/Scintilla/* ${DOCSDIR}/Scintilla )
+ cd ${WRKSRC}/Qt4 && ${MAKE} install
+ cd ${WRKSRC}/lib &&\
+ ${MV} libqscintilla2.so.2.0.0 libqscintilla2.so.2 &&\
+ ${INSTALL_DATA} libqscintilla2.so.2 ${PREFIX}/lib &&\
+ cd ${PREFIX}/lib &&\
+ ${LN} -sf libqscintilla2.so.2 libqscintilla2.so &&\
+ cd ../share/qt4/qsci/api/python/ && ${RM} Python-2.4.api
+.if !defined(NOPORTDOCS)
+ cd ${WRKSRC} &&\
+ ${MKDIR} -m 0755 ${DOCSDIR}/html ${DOCSDIR}/Scintilla &&\
+ ${INSTALL_DATA} ChangeLog NEWS README ${DOCSDIR} &&\
+ ${INSTALL_DATA} doc/html-Qt4/* ${DOCSDIR}/html &&\
+ ${INSTALL_DATA} doc/Scintilla/* ${DOCSDIR}/Scintilla
.endif
-.if !defined(NOPORTDOCS) && !defined(WITHOUT_EXAMPLES)
- ( cd ${WRKSRC}/example-Qt4 && \
- ${MKDIR} -m 0755 ${EXAMPLESDIR}/images && \
- ${INSTALL_DATA} *.* ${EXAMPLESDIR} && \
- ${INSTALL_DATA} images/* ${EXAMPLESDIR}/images )
+.if !defined(NOPORTEXAMPLES)
+ cd ${WRKSRC}/example-Qt4 &&\
+ ${MKDIR} -m 0755 ${EXAMPLESDIR}/images &&\
+ ${INSTALL_DATA} *.* ${EXAMPLESDIR} &&\
+ ${INSTALL_DATA} images/* ${EXAMPLESDIR}/images
.endif
-
.include <bsd.port.post.mk>
diff --git a/devel/qscintilla2/distinfo b/devel/qscintilla2/distinfo
index be826cf7ae67..5c34b20dfe46 100644
--- a/devel/qscintilla2/distinfo
+++ b/devel/qscintilla2/distinfo
@@ -1,3 +1,3 @@
-MD5 (QScintilla-1.73-gpl-2-snapshot-20070410.tar.gz) = 634f82b26dc39f95891066264ca33afc
-SHA256 (QScintilla-1.73-gpl-2-snapshot-20070410.tar.gz) = 492287e0f3d333a698c91a5b09c227b51dc5ceb9b838e2e26c1b45cb390bd32c
-SIZE (QScintilla-1.73-gpl-2-snapshot-20070410.tar.gz) = 1715178
+MD5 (QScintilla-1.73-gpl-2.1.tar.gz) = 13049717628391ca4db43f7ede0eeeb4
+SHA256 (QScintilla-1.73-gpl-2.1.tar.gz) = 545fcefb75fe159b48e2a17485c12ba8ca548f387f594923664258b10831bf86
+SIZE (QScintilla-1.73-gpl-2.1.tar.gz) = 1866929
diff --git a/devel/qscintilla2/pkg-plist b/devel/qscintilla2/pkg-plist
index ef93f589bdd8..cf24f36d733e 100644
--- a/devel/qscintilla2/pkg-plist
+++ b/devel/qscintilla2/pkg-plist
@@ -1,173 +1,172 @@
lib/libqscintilla2.so
-lib/libqscintilla2.so.1
-share/qt4/qsci/api/python/Python-2.4.api
+lib/libqscintilla2.so.2
share/qt4/qsci/api/python/Python-2.5.api
-%%DOCS%%%%DOCSDIR%%/ChangeLog
-%%DOCS%%%%DOCSDIR%%/NEWS
-%%DOCS%%%%DOCSDIR%%/README
-%%DOCS%%%%DOCSDIR%%/Scintilla/Design.html
-%%DOCS%%%%DOCSDIR%%/Scintilla/Icons.html
-%%DOCS%%%%DOCSDIR%%/Scintilla/Lexer.txt
-%%DOCS%%%%DOCSDIR%%/Scintilla/SciBreak.jpg
-%%DOCS%%%%DOCSDIR%%/Scintilla/SciCoding.html
-%%DOCS%%%%DOCSDIR%%/Scintilla/SciRest.jpg
-%%DOCS%%%%DOCSDIR%%/Scintilla/SciTEIco.png
-%%DOCS%%%%DOCSDIR%%/Scintilla/SciWord.jpg
-%%DOCS%%%%DOCSDIR%%/Scintilla/ScintillaDoc.html
-%%DOCS%%%%DOCSDIR%%/Scintilla/ScintillaDownload.html
-%%DOCS%%%%DOCSDIR%%/Scintilla/ScintillaHistory.html
-%%DOCS%%%%DOCSDIR%%/Scintilla/ScintillaRelated.html
-%%DOCS%%%%DOCSDIR%%/Scintilla/ScintillaToDo.html
-%%DOCS%%%%DOCSDIR%%/Scintilla/ScintillaUsage.html
-%%DOCS%%%%DOCSDIR%%/Scintilla/Steps.html
-%%DOCS%%%%DOCSDIR%%/Scintilla/index.html
-%%DOCS%%%%DOCSDIR%%/html/annotated.html
-%%DOCS%%%%DOCSDIR%%/html/classQsciAPIs-members.html
-%%DOCS%%%%DOCSDIR%%/html/classQsciAPIs.html
-%%DOCS%%%%DOCSDIR%%/html/classQsciCommand-members.html
-%%DOCS%%%%DOCSDIR%%/html/classQsciCommand.html
-%%DOCS%%%%DOCSDIR%%/html/classQsciCommandSet-members.html
-%%DOCS%%%%DOCSDIR%%/html/classQsciCommandSet.html
-%%DOCS%%%%DOCSDIR%%/html/classQsciDocument-members.html
-%%DOCS%%%%DOCSDIR%%/html/classQsciDocument.html
-%%DOCS%%%%DOCSDIR%%/html/classQsciLexer-members.html
-%%DOCS%%%%DOCSDIR%%/html/classQsciLexer.html
-%%DOCS%%%%DOCSDIR%%/html/classQsciLexerBash-members.html
-%%DOCS%%%%DOCSDIR%%/html/classQsciLexerBash.html
-%%DOCS%%%%DOCSDIR%%/html/classQsciLexerBatch-members.html
-%%DOCS%%%%DOCSDIR%%/html/classQsciLexerBatch.html
-%%DOCS%%%%DOCSDIR%%/html/classQsciLexerCMake.html
-%%DOCS%%%%DOCSDIR%%/html/classQsciLexerCMake-members.html
-%%DOCS%%%%DOCSDIR%%/html/classQsciLexerVHDL.html
-%%DOCS%%%%DOCSDIR%%/html/classQsciLexerVHDL-members.html
-%%DOCS%%%%DOCSDIR%%/html/classQsciLexerCPP-members.html
-%%DOCS%%%%DOCSDIR%%/html/classQsciLexerCPP.html
-%%DOCS%%%%DOCSDIR%%/html/classQsciLexerCSS-members.html
-%%DOCS%%%%DOCSDIR%%/html/classQsciLexerCSS.html
-%%DOCS%%%%DOCSDIR%%/html/classQsciLexerCSharp-members.html
-%%DOCS%%%%DOCSDIR%%/html/classQsciLexerCSharp.html
-%%DOCS%%%%DOCSDIR%%/html/classQsciLexerD.html
-%%DOCS%%%%DOCSDIR%%/html/classQsciLexerD-members.html
-%%DOCS%%%%DOCSDIR%%/html/classQsciLexerDiff-members.html
-%%DOCS%%%%DOCSDIR%%/html/classQsciLexerDiff.html
-%%DOCS%%%%DOCSDIR%%/html/classQsciLexerHTML-members.html
-%%DOCS%%%%DOCSDIR%%/html/classQsciLexerHTML.html
-%%DOCS%%%%DOCSDIR%%/html/classQsciLexerIDL-members.html
-%%DOCS%%%%DOCSDIR%%/html/classQsciLexerIDL.html
-%%DOCS%%%%DOCSDIR%%/html/classQsciLexerJava-members.html
-%%DOCS%%%%DOCSDIR%%/html/classQsciLexerJava.html
-%%DOCS%%%%DOCSDIR%%/html/classQsciLexerJavaScript-members.html
-%%DOCS%%%%DOCSDIR%%/html/classQsciLexerJavaScript.html
-%%DOCS%%%%DOCSDIR%%/html/classQsciLexerLua-members.html
-%%DOCS%%%%DOCSDIR%%/html/classQsciLexerLua.html
-%%DOCS%%%%DOCSDIR%%/html/classQsciLexerMakefile-members.html
-%%DOCS%%%%DOCSDIR%%/html/classQsciLexerMakefile.html
-%%DOCS%%%%DOCSDIR%%/html/classQsciLexerPOV-members.html
-%%DOCS%%%%DOCSDIR%%/html/classQsciLexerPOV.html
-%%DOCS%%%%DOCSDIR%%/html/classQsciLexerPerl-members.html
-%%DOCS%%%%DOCSDIR%%/html/classQsciLexerPerl.html
-%%DOCS%%%%DOCSDIR%%/html/classQsciLexerProperties-members.html
-%%DOCS%%%%DOCSDIR%%/html/classQsciLexerProperties.html
-%%DOCS%%%%DOCSDIR%%/html/classQsciLexerPython-members.html
-%%DOCS%%%%DOCSDIR%%/html/classQsciLexerPython.html
-%%DOCS%%%%DOCSDIR%%/html/classQsciLexerRuby-members.html
-%%DOCS%%%%DOCSDIR%%/html/classQsciLexerRuby.html
-%%DOCS%%%%DOCSDIR%%/html/classQsciLexerSQL-members.html
-%%DOCS%%%%DOCSDIR%%/html/classQsciLexerSQL.html
-%%DOCS%%%%DOCSDIR%%/html/classQsciLexerTeX-members.html
-%%DOCS%%%%DOCSDIR%%/html/classQsciLexerTeX.html
-%%DOCS%%%%DOCSDIR%%/html/classQsciMacro-members.html
-%%DOCS%%%%DOCSDIR%%/html/classQsciMacro.html
-%%DOCS%%%%DOCSDIR%%/html/classQsciPrinter-members.html
-%%DOCS%%%%DOCSDIR%%/html/classQsciPrinter.html
-%%DOCS%%%%DOCSDIR%%/html/classQsciScintilla-members.html
-%%DOCS%%%%DOCSDIR%%/html/classQsciScintilla.html
-%%DOCS%%%%DOCSDIR%%/html/classQsciScintillaBase-members.html
-%%DOCS%%%%DOCSDIR%%/html/classQsciScintillaBase.html
-%%DOCS%%%%DOCSDIR%%/html/dir_b5bf78a35e8d093335c78f35e76af406.html
-%%DOCS%%%%DOCSDIR%%/html/dir_c998c31d8b2389e3c98da8b1324de8f7.html
-%%DOCS%%%%DOCSDIR%%/html/dirs.html
-%%DOCS%%%%DOCSDIR%%/html/doxygen.css
-%%DOCS%%%%DOCSDIR%%/html/doxygen.png
-%%DOCS%%%%DOCSDIR%%/html/functions.html
-%%DOCS%%%%DOCSDIR%%/html/functions_0x62.html
-%%DOCS%%%%DOCSDIR%%/html/functions_0x63.html
-%%DOCS%%%%DOCSDIR%%/html/functions_0x64.html
-%%DOCS%%%%DOCSDIR%%/html/functions_0x65.html
-%%DOCS%%%%DOCSDIR%%/html/functions_0x66.html
-%%DOCS%%%%DOCSDIR%%/html/functions_0x67.html
-%%DOCS%%%%DOCSDIR%%/html/functions_0x68.html
-%%DOCS%%%%DOCSDIR%%/html/functions_0x69.html
-%%DOCS%%%%DOCSDIR%%/html/functions_0x6a.html
-%%DOCS%%%%DOCSDIR%%/html/functions_0x6b.html
-%%DOCS%%%%DOCSDIR%%/html/functions_0x6c.html
-%%DOCS%%%%DOCSDIR%%/html/functions_0x6d.html
-%%DOCS%%%%DOCSDIR%%/html/functions_0x6e.html
-%%DOCS%%%%DOCSDIR%%/html/functions_0x6f.html
-%%DOCS%%%%DOCSDIR%%/html/functions_0x70.html
-%%DOCS%%%%DOCSDIR%%/html/functions_0x71.html
-%%DOCS%%%%DOCSDIR%%/html/functions_0x72.html
-%%DOCS%%%%DOCSDIR%%/html/functions_0x73.html
-%%DOCS%%%%DOCSDIR%%/html/functions_0x74.html
-%%DOCS%%%%DOCSDIR%%/html/functions_0x75.html
-%%DOCS%%%%DOCSDIR%%/html/functions_0x76.html
-%%DOCS%%%%DOCSDIR%%/html/functions_0x77.html
-%%DOCS%%%%DOCSDIR%%/html/functions_0x78.html
-%%DOCS%%%%DOCSDIR%%/html/functions_0x7a.html
-%%DOCS%%%%DOCSDIR%%/html/functions_0x7e.html
-%%DOCS%%%%DOCSDIR%%/html/functions_enum.html
-%%DOCS%%%%DOCSDIR%%/html/functions_eval.html
-%%DOCS%%%%DOCSDIR%%/html/functions_eval_0x62.html
-%%DOCS%%%%DOCSDIR%%/html/functions_eval_0x63.html
-%%DOCS%%%%DOCSDIR%%/html/functions_eval_0x64.html
-%%DOCS%%%%DOCSDIR%%/html/functions_eval_0x65.html
-%%DOCS%%%%DOCSDIR%%/html/functions_eval_0x66.html
-%%DOCS%%%%DOCSDIR%%/html/functions_eval_0x67.html
-%%DOCS%%%%DOCSDIR%%/html/functions_eval_0x68.html
-%%DOCS%%%%DOCSDIR%%/html/functions_eval_0x69.html
-%%DOCS%%%%DOCSDIR%%/html/functions_eval_0x6a.html
-%%DOCS%%%%DOCSDIR%%/html/functions_eval_0x6b.html
-%%DOCS%%%%DOCSDIR%%/html/functions_eval_0x6c.html
-%%DOCS%%%%DOCSDIR%%/html/functions_eval_0x6d.html
-%%DOCS%%%%DOCSDIR%%/html/functions_eval_0x6e.html
-%%DOCS%%%%DOCSDIR%%/html/functions_eval_0x6f.html
-%%DOCS%%%%DOCSDIR%%/html/functions_eval_0x70.html
-%%DOCS%%%%DOCSDIR%%/html/functions_eval_0x71.html
-%%DOCS%%%%DOCSDIR%%/html/functions_eval_0x72.html
-%%DOCS%%%%DOCSDIR%%/html/functions_eval_0x73.html
-%%DOCS%%%%DOCSDIR%%/html/functions_eval_0x74.html
-%%DOCS%%%%DOCSDIR%%/html/functions_eval_0x75.html
-%%DOCS%%%%DOCSDIR%%/html/functions_eval_0x76.html
-%%DOCS%%%%DOCSDIR%%/html/functions_eval_0x77.html
-%%DOCS%%%%DOCSDIR%%/html/functions_eval_0x78.html
-%%DOCS%%%%DOCSDIR%%/html/functions_func.html
-%%DOCS%%%%DOCSDIR%%/html/functions_func_0x62.html
-%%DOCS%%%%DOCSDIR%%/html/functions_func_0x63.html
-%%DOCS%%%%DOCSDIR%%/html/functions_func_0x64.html
-%%DOCS%%%%DOCSDIR%%/html/functions_func_0x65.html
-%%DOCS%%%%DOCSDIR%%/html/functions_func_0x66.html
-%%DOCS%%%%DOCSDIR%%/html/functions_func_0x67.html
-%%DOCS%%%%DOCSDIR%%/html/functions_func_0x68.html
-%%DOCS%%%%DOCSDIR%%/html/functions_func_0x69.html
-%%DOCS%%%%DOCSDIR%%/html/functions_func_0x6b.html
-%%DOCS%%%%DOCSDIR%%/html/functions_func_0x6c.html
-%%DOCS%%%%DOCSDIR%%/html/functions_func_0x6d.html
-%%DOCS%%%%DOCSDIR%%/html/functions_func_0x70.html
-%%DOCS%%%%DOCSDIR%%/html/functions_func_0x71.html
-%%DOCS%%%%DOCSDIR%%/html/functions_func_0x72.html
-%%DOCS%%%%DOCSDIR%%/html/functions_func_0x73.html
-%%DOCS%%%%DOCSDIR%%/html/functions_func_0x74.html
-%%DOCS%%%%DOCSDIR%%/html/functions_func_0x75.html
-%%DOCS%%%%DOCSDIR%%/html/functions_func_0x76.html
-%%DOCS%%%%DOCSDIR%%/html/functions_func_0x77.html
-%%DOCS%%%%DOCSDIR%%/html/functions_func_0x7a.html
-%%DOCS%%%%DOCSDIR%%/html/functions_func_0x7e.html
-%%DOCS%%%%DOCSDIR%%/html/hierarchy.html
-%%DOCS%%%%DOCSDIR%%/html/index.html
-%%DOCS%%%%DOCSDIR%%/html/tab_b.gif
-%%DOCS%%%%DOCSDIR%%/html/tab_l.gif
-%%DOCS%%%%DOCSDIR%%/html/tab_r.gif
-%%DOCS%%%%DOCSDIR%%/html/tabs.css
+%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
+%%PORTDOCS%%%%DOCSDIR%%/NEWS
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/Scintilla/Design.html
+%%PORTDOCS%%%%DOCSDIR%%/Scintilla/Icons.html
+%%PORTDOCS%%%%DOCSDIR%%/Scintilla/Lexer.txt
+%%PORTDOCS%%%%DOCSDIR%%/Scintilla/SciBreak.jpg
+%%PORTDOCS%%%%DOCSDIR%%/Scintilla/SciCoding.html
+%%PORTDOCS%%%%DOCSDIR%%/Scintilla/SciRest.jpg
+%%PORTDOCS%%%%DOCSDIR%%/Scintilla/SciTEIco.png
+%%PORTDOCS%%%%DOCSDIR%%/Scintilla/SciWord.jpg
+%%PORTDOCS%%%%DOCSDIR%%/Scintilla/ScintillaDoc.html
+%%PORTDOCS%%%%DOCSDIR%%/Scintilla/ScintillaDownload.html
+%%PORTDOCS%%%%DOCSDIR%%/Scintilla/ScintillaHistory.html
+%%PORTDOCS%%%%DOCSDIR%%/Scintilla/ScintillaRelated.html
+%%PORTDOCS%%%%DOCSDIR%%/Scintilla/ScintillaToDo.html
+%%PORTDOCS%%%%DOCSDIR%%/Scintilla/ScintillaUsage.html
+%%PORTDOCS%%%%DOCSDIR%%/Scintilla/Steps.html
+%%PORTDOCS%%%%DOCSDIR%%/Scintilla/index.html
+%%PORTDOCS%%%%DOCSDIR%%/html/annotated.html
+%%PORTDOCS%%%%DOCSDIR%%/html/classQsciAPIs-members.html
+%%PORTDOCS%%%%DOCSDIR%%/html/classQsciAPIs.html
+%%PORTDOCS%%%%DOCSDIR%%/html/classQsciCommand-members.html
+%%PORTDOCS%%%%DOCSDIR%%/html/classQsciCommand.html
+%%PORTDOCS%%%%DOCSDIR%%/html/classQsciCommandSet-members.html
+%%PORTDOCS%%%%DOCSDIR%%/html/classQsciCommandSet.html
+%%PORTDOCS%%%%DOCSDIR%%/html/classQsciDocument-members.html
+%%PORTDOCS%%%%DOCSDIR%%/html/classQsciDocument.html
+%%PORTDOCS%%%%DOCSDIR%%/html/classQsciLexer-members.html
+%%PORTDOCS%%%%DOCSDIR%%/html/classQsciLexer.html
+%%PORTDOCS%%%%DOCSDIR%%/html/classQsciLexerBash-members.html
+%%PORTDOCS%%%%DOCSDIR%%/html/classQsciLexerBash.html
+%%PORTDOCS%%%%DOCSDIR%%/html/classQsciLexerBatch-members.html
+%%PORTDOCS%%%%DOCSDIR%%/html/classQsciLexerBatch.html
+%%PORTDOCS%%%%DOCSDIR%%/html/classQsciLexerCMake.html
+%%PORTDOCS%%%%DOCSDIR%%/html/classQsciLexerCMake-members.html
+%%PORTDOCS%%%%DOCSDIR%%/html/classQsciLexerVHDL.html
+%%PORTDOCS%%%%DOCSDIR%%/html/classQsciLexerVHDL-members.html
+%%PORTDOCS%%%%DOCSDIR%%/html/classQsciLexerCPP-members.html
+%%PORTDOCS%%%%DOCSDIR%%/html/classQsciLexerCPP.html
+%%PORTDOCS%%%%DOCSDIR%%/html/classQsciLexerCSS-members.html
+%%PORTDOCS%%%%DOCSDIR%%/html/classQsciLexerCSS.html
+%%PORTDOCS%%%%DOCSDIR%%/html/classQsciLexerCSharp-members.html
+%%PORTDOCS%%%%DOCSDIR%%/html/classQsciLexerCSharp.html
+%%PORTDOCS%%%%DOCSDIR%%/html/classQsciLexerD.html
+%%PORTDOCS%%%%DOCSDIR%%/html/classQsciLexerD-members.html
+%%PORTDOCS%%%%DOCSDIR%%/html/classQsciLexerDiff-members.html
+%%PORTDOCS%%%%DOCSDIR%%/html/classQsciLexerDiff.html
+%%PORTDOCS%%%%DOCSDIR%%/html/classQsciLexerHTML-members.html
+%%PORTDOCS%%%%DOCSDIR%%/html/classQsciLexerHTML.html
+%%PORTDOCS%%%%DOCSDIR%%/html/classQsciLexerIDL-members.html
+%%PORTDOCS%%%%DOCSDIR%%/html/classQsciLexerIDL.html
+%%PORTDOCS%%%%DOCSDIR%%/html/classQsciLexerJava-members.html
+%%PORTDOCS%%%%DOCSDIR%%/html/classQsciLexerJava.html
+%%PORTDOCS%%%%DOCSDIR%%/html/classQsciLexerJavaScript-members.html
+%%PORTDOCS%%%%DOCSDIR%%/html/classQsciLexerJavaScript.html
+%%PORTDOCS%%%%DOCSDIR%%/html/classQsciLexerLua-members.html
+%%PORTDOCS%%%%DOCSDIR%%/html/classQsciLexerLua.html
+%%PORTDOCS%%%%DOCSDIR%%/html/classQsciLexerMakefile-members.html
+%%PORTDOCS%%%%DOCSDIR%%/html/classQsciLexerMakefile.html
+%%PORTDOCS%%%%DOCSDIR%%/html/classQsciLexerPOV-members.html
+%%PORTDOCS%%%%DOCSDIR%%/html/classQsciLexerPOV.html
+%%PORTDOCS%%%%DOCSDIR%%/html/classQsciLexerPerl-members.html
+%%PORTDOCS%%%%DOCSDIR%%/html/classQsciLexerPerl.html
+%%PORTDOCS%%%%DOCSDIR%%/html/classQsciLexerProperties-members.html
+%%PORTDOCS%%%%DOCSDIR%%/html/classQsciLexerProperties.html
+%%PORTDOCS%%%%DOCSDIR%%/html/classQsciLexerPython-members.html
+%%PORTDOCS%%%%DOCSDIR%%/html/classQsciLexerPython.html
+%%PORTDOCS%%%%DOCSDIR%%/html/classQsciLexerRuby-members.html
+%%PORTDOCS%%%%DOCSDIR%%/html/classQsciLexerRuby.html
+%%PORTDOCS%%%%DOCSDIR%%/html/classQsciLexerSQL-members.html
+%%PORTDOCS%%%%DOCSDIR%%/html/classQsciLexerSQL.html
+%%PORTDOCS%%%%DOCSDIR%%/html/classQsciLexerTeX-members.html
+%%PORTDOCS%%%%DOCSDIR%%/html/classQsciLexerTeX.html
+%%PORTDOCS%%%%DOCSDIR%%/html/classQsciMacro-members.html
+%%PORTDOCS%%%%DOCSDIR%%/html/classQsciMacro.html
+%%PORTDOCS%%%%DOCSDIR%%/html/classQsciPrinter-members.html
+%%PORTDOCS%%%%DOCSDIR%%/html/classQsciPrinter.html
+%%PORTDOCS%%%%DOCSDIR%%/html/classQsciScintilla-members.html
+%%PORTDOCS%%%%DOCSDIR%%/html/classQsciScintilla.html
+%%PORTDOCS%%%%DOCSDIR%%/html/classQsciScintillaBase-members.html
+%%PORTDOCS%%%%DOCSDIR%%/html/classQsciScintillaBase.html
+%%PORTDOCS%%%%DOCSDIR%%/html/dir_2a8c2605e4aa7d1a48d8f1a3cb79b19c.html
+%%PORTDOCS%%%%DOCSDIR%%/html/dir_70b9a417937df88b16247a3b9fa4913c.html
+%%PORTDOCS%%%%DOCSDIR%%/html/dirs.html
+%%PORTDOCS%%%%DOCSDIR%%/html/doxygen.css
+%%PORTDOCS%%%%DOCSDIR%%/html/doxygen.png
+%%PORTDOCS%%%%DOCSDIR%%/html/functions.html
+%%PORTDOCS%%%%DOCSDIR%%/html/functions_0x62.html
+%%PORTDOCS%%%%DOCSDIR%%/html/functions_0x63.html
+%%PORTDOCS%%%%DOCSDIR%%/html/functions_0x64.html
+%%PORTDOCS%%%%DOCSDIR%%/html/functions_0x65.html
+%%PORTDOCS%%%%DOCSDIR%%/html/functions_0x66.html
+%%PORTDOCS%%%%DOCSDIR%%/html/functions_0x67.html
+%%PORTDOCS%%%%DOCSDIR%%/html/functions_0x68.html
+%%PORTDOCS%%%%DOCSDIR%%/html/functions_0x69.html
+%%PORTDOCS%%%%DOCSDIR%%/html/functions_0x6a.html
+%%PORTDOCS%%%%DOCSDIR%%/html/functions_0x6b.html
+%%PORTDOCS%%%%DOCSDIR%%/html/functions_0x6c.html
+%%PORTDOCS%%%%DOCSDIR%%/html/functions_0x6d.html
+%%PORTDOCS%%%%DOCSDIR%%/html/functions_0x6e.html
+%%PORTDOCS%%%%DOCSDIR%%/html/functions_0x6f.html
+%%PORTDOCS%%%%DOCSDIR%%/html/functions_0x70.html
+%%PORTDOCS%%%%DOCSDIR%%/html/functions_0x71.html
+%%PORTDOCS%%%%DOCSDIR%%/html/functions_0x72.html
+%%PORTDOCS%%%%DOCSDIR%%/html/functions_0x73.html
+%%PORTDOCS%%%%DOCSDIR%%/html/functions_0x74.html
+%%PORTDOCS%%%%DOCSDIR%%/html/functions_0x75.html
+%%PORTDOCS%%%%DOCSDIR%%/html/functions_0x76.html
+%%PORTDOCS%%%%DOCSDIR%%/html/functions_0x77.html
+%%PORTDOCS%%%%DOCSDIR%%/html/functions_0x78.html
+%%PORTDOCS%%%%DOCSDIR%%/html/functions_0x7a.html
+%%PORTDOCS%%%%DOCSDIR%%/html/functions_0x7e.html
+%%PORTDOCS%%%%DOCSDIR%%/html/functions_enum.html
+%%PORTDOCS%%%%DOCSDIR%%/html/functions_eval.html
+%%PORTDOCS%%%%DOCSDIR%%/html/functions_eval_0x62.html
+%%PORTDOCS%%%%DOCSDIR%%/html/functions_eval_0x63.html
+%%PORTDOCS%%%%DOCSDIR%%/html/functions_eval_0x64.html
+%%PORTDOCS%%%%DOCSDIR%%/html/functions_eval_0x65.html
+%%PORTDOCS%%%%DOCSDIR%%/html/functions_eval_0x66.html
+%%PORTDOCS%%%%DOCSDIR%%/html/functions_eval_0x67.html
+%%PORTDOCS%%%%DOCSDIR%%/html/functions_eval_0x68.html
+%%PORTDOCS%%%%DOCSDIR%%/html/functions_eval_0x69.html
+%%PORTDOCS%%%%DOCSDIR%%/html/functions_eval_0x6a.html
+%%PORTDOCS%%%%DOCSDIR%%/html/functions_eval_0x6b.html
+%%PORTDOCS%%%%DOCSDIR%%/html/functions_eval_0x6c.html
+%%PORTDOCS%%%%DOCSDIR%%/html/functions_eval_0x6d.html
+%%PORTDOCS%%%%DOCSDIR%%/html/functions_eval_0x6e.html
+%%PORTDOCS%%%%DOCSDIR%%/html/functions_eval_0x6f.html
+%%PORTDOCS%%%%DOCSDIR%%/html/functions_eval_0x70.html
+%%PORTDOCS%%%%DOCSDIR%%/html/functions_eval_0x71.html
+%%PORTDOCS%%%%DOCSDIR%%/html/functions_eval_0x72.html
+%%PORTDOCS%%%%DOCSDIR%%/html/functions_eval_0x73.html
+%%PORTDOCS%%%%DOCSDIR%%/html/functions_eval_0x74.html
+%%PORTDOCS%%%%DOCSDIR%%/html/functions_eval_0x75.html
+%%PORTDOCS%%%%DOCSDIR%%/html/functions_eval_0x76.html
+%%PORTDOCS%%%%DOCSDIR%%/html/functions_eval_0x77.html
+%%PORTDOCS%%%%DOCSDIR%%/html/functions_eval_0x78.html
+%%PORTDOCS%%%%DOCSDIR%%/html/functions_func.html
+%%PORTDOCS%%%%DOCSDIR%%/html/functions_func_0x62.html
+%%PORTDOCS%%%%DOCSDIR%%/html/functions_func_0x63.html
+%%PORTDOCS%%%%DOCSDIR%%/html/functions_func_0x64.html
+%%PORTDOCS%%%%DOCSDIR%%/html/functions_func_0x65.html
+%%PORTDOCS%%%%DOCSDIR%%/html/functions_func_0x66.html
+%%PORTDOCS%%%%DOCSDIR%%/html/functions_func_0x67.html
+%%PORTDOCS%%%%DOCSDIR%%/html/functions_func_0x68.html
+%%PORTDOCS%%%%DOCSDIR%%/html/functions_func_0x69.html
+%%PORTDOCS%%%%DOCSDIR%%/html/functions_func_0x6b.html
+%%PORTDOCS%%%%DOCSDIR%%/html/functions_func_0x6c.html
+%%PORTDOCS%%%%DOCSDIR%%/html/functions_func_0x6d.html
+%%PORTDOCS%%%%DOCSDIR%%/html/functions_func_0x70.html
+%%PORTDOCS%%%%DOCSDIR%%/html/functions_func_0x71.html
+%%PORTDOCS%%%%DOCSDIR%%/html/functions_func_0x72.html
+%%PORTDOCS%%%%DOCSDIR%%/html/functions_func_0x73.html
+%%PORTDOCS%%%%DOCSDIR%%/html/functions_func_0x74.html
+%%PORTDOCS%%%%DOCSDIR%%/html/functions_func_0x75.html
+%%PORTDOCS%%%%DOCSDIR%%/html/functions_func_0x76.html
+%%PORTDOCS%%%%DOCSDIR%%/html/functions_func_0x77.html
+%%PORTDOCS%%%%DOCSDIR%%/html/functions_func_0x7a.html
+%%PORTDOCS%%%%DOCSDIR%%/html/functions_func_0x7e.html
+%%PORTDOCS%%%%DOCSDIR%%/html/hierarchy.html
+%%PORTDOCS%%%%DOCSDIR%%/html/index.html
+%%PORTDOCS%%%%DOCSDIR%%/html/tab_b.gif
+%%PORTDOCS%%%%DOCSDIR%%/html/tab_l.gif
+%%PORTDOCS%%%%DOCSDIR%%/html/tab_r.gif
+%%PORTDOCS%%%%DOCSDIR%%/html/tabs.css
%%HEADERS%%include/Qsci/qsciapis.h
%%HEADERS%%include/Qsci/qscicommand.h
%%HEADERS%%include/Qsci/qscicommandset.h
@@ -200,17 +199,17 @@ share/qt4/qsci/api/python/Python-2.5.api
%%HEADERS%%include/Qsci/qsciprinter.h
%%HEADERS%%include/Qsci/qsciscintilla.h
%%HEADERS%%include/Qsci/qsciscintillabase.h
-%%EXAMPLES%%%%EXAMPLESDIR%%/images/copy.png
-%%EXAMPLES%%%%EXAMPLESDIR%%/images/cut.png
-%%EXAMPLES%%%%EXAMPLESDIR%%/images/new.png
-%%EXAMPLES%%%%EXAMPLESDIR%%/images/open.png
-%%EXAMPLES%%%%EXAMPLESDIR%%/images/paste.png
-%%EXAMPLES%%%%EXAMPLESDIR%%/images/save.png
-%%EXAMPLES%%%%EXAMPLESDIR%%/application.pro
-%%EXAMPLES%%%%EXAMPLESDIR%%/application.qrc
-%%EXAMPLES%%%%EXAMPLESDIR%%/main.cpp
-%%EXAMPLES%%%%EXAMPLESDIR%%/mainwindow.cpp
-%%EXAMPLES%%%%EXAMPLESDIR%%/mainwindow.h
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/images/copy.png
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/images/cut.png
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/images/new.png
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/images/open.png
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/images/paste.png
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/images/save.png
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/application.pro
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/application.qrc
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/main.cpp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/mainwindow.cpp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/mainwindow.h
%%TRANSLATIONS%%share/qt4/translations/qscintilla_de.qm
%%TRANSLATIONS%%share/qt4/translations/qscintilla_fr.qm
%%TRANSLATIONS%%share/qt4/translations/qscintilla_pt_br.qm
@@ -218,10 +217,10 @@ share/qt4/qsci/api/python/Python-2.5.api
@dirrmtry share/qt4/qsci/api/python
@dirrmtry share/qt4/qsci/api
@dirrmtry share/qt4/qsci
-%%DOCS%%@dirrm %%DOCSDIR%%/Scintilla
-%%DOCS%%@dirrm %%DOCSDIR%%/html
-%%DOCS%%@dirrm %%DOCSDIR%%
-%%EXAMPLES%%@dirrm %%EXAMPLESDIR%%/images
-%%EXAMPLES%%@dirrm %%EXAMPLESDIR%%
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/Scintilla
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/html
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/images
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%
%%HEADERS%%@dirrm include/Qsci
%%TRANSLATIONS%%@dirrmtry share/qt4/translations