aboutsummaryrefslogtreecommitdiff
path: root/devel/ragel/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-04-03 08:52:45 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-04-03 08:52:45 +0000
commit8b07de59dcb060a2485fd0fdce33dac9351a0c9a (patch)
treee1ddb056835f340f0e4e5604275130c79347ab78 /devel/ragel/Makefile
parentbb4750e40fa11a830ed10e29cf8c1749d2f7fbc3 (diff)
Notes
Diffstat (limited to 'devel/ragel/Makefile')
-rw-r--r--devel/ragel/Makefile44
1 files changed, 20 insertions, 24 deletions
diff --git a/devel/ragel/Makefile b/devel/ragel/Makefile
index b00585d34a75..e84435315fb5 100644
--- a/devel/ragel/Makefile
+++ b/devel/ragel/Makefile
@@ -7,34 +7,29 @@
#
PORTNAME= ragel
-PORTVERSION= 6.3
+PORTVERSION= 6.4
CATEGORIES= devel
MASTER_SITES= http://www.complang.org/ragel/
+.if !defined(NOPORTDOCS)
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX} ${DISTFILES_DOC}
+EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
+.endif
MAINTAINER= ports@FreeBSD.org
COMMENT= Compile regular languages into executable C/C++ code
-BUILD_DEPENDS= ${LOCALBASE}/bin/gperf:${PORTSDIR}/devel/gperf
-
-USE_BISON= build
USE_GMAKE= yes
GNU_CONFIGURE= yes
-MAKE_ENV= GPERF="${LOCALBASE}/bin/gperf"
-
-MAN1= ragel.1 rlgen-cd.1 rlgen-dot.1 rlgen-java.1 rlgen-ruby.1
-PLIST_FILES= bin/ragel bin/rlgen-cd
-PORTDOCS= ${PORTNAME}-guide-${PORTVERSION}.pdf
+MAN1= ${PORTNAME}.1
+PORTDOCS= *
+PORTEXAMPLES= *
+PLIST_FILES= bin/${PORTNAME}
-.if !defined(NOPORTDOCS)
-DISTFILES= ${DISTNAME}${EXTRACT_SUFX} ${PORTDOCS}
-EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
-.endif
+DISTFILES_DOC= ${PORTNAME}-guide-${PORTVERSION}.pdf
post-patch:
- @${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${REINPLACE_CMD} -e \
- 's|$$(CFLAGS)|$$(CXXFLAGS)|g ; \
- s|gperf -L|$$(GPERF) -L|g'
+ @${REINPLACE_CMD} -e 's|= -g|=|g' ${WRKSRC}/ragel/Makefile.in
post-build:
@cd ${WRKSRC}/doc && ${SETENV} ${MAKE_ENV} \
@@ -42,16 +37,17 @@ post-build:
${MAN1}
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/ragel/ragel ${PREFIX}/bin
- ${INSTALL_PROGRAM} ${WRKSRC}/rlgen-cd/rlgen-cd ${PREFIX}/bin
-.for m in ${MAN1}
- ${INSTALL_MAN} ${WRKSRC}/doc/${m} ${MAN1PREFIX}/man/man1
-.endfor
-
-post-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/ragel/${PORTNAME} ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/doc/${PORTNAME}.1 ${MANPREFIX}/man/man1
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${DISTDIR}/${PORTDOCS} ${DOCSDIR}
+.for file in ${DISTFILES_DOC}
+ ${INSTALL_DATA} ${DISTDIR}/${file} ${DOCSDIR}
+.endfor
+.endif
+.if !defined(NOPORTEXAMPLES)
+ @${MKDIR} ${EXAMPLESDIR}
+ @(cd ${WRKSRC}/examples; ${COPYTREE_SHARE} . ${EXAMPLESDIR})
.endif
.include <bsd.port.mk>