aboutsummaryrefslogtreecommitdiff
path: root/devel/ruby-filemagic
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2003-10-14 20:41:23 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2003-10-14 20:41:23 +0000
commite89e225070ee6b8fadfd2365c564e1291b668f5c (patch)
tree0acd3e90bd65dd0e75a94db6b153b7995ef43465 /devel/ruby-filemagic
parent5ff389cda5a06e581cc7c2fd9be067eec392904c (diff)
downloadports-e89e225070ee6b8fadfd2365c564e1291b668f5c.tar.gz
ports-e89e225070ee6b8fadfd2365c564e1291b668f5c.zip
Notes
Diffstat (limited to 'devel/ruby-filemagic')
-rw-r--r--devel/ruby-filemagic/Makefile41
-rw-r--r--devel/ruby-filemagic/distinfo1
-rw-r--r--devel/ruby-filemagic/pkg-descr7
-rw-r--r--devel/ruby-filemagic/pkg-plist8
4 files changed, 57 insertions, 0 deletions
diff --git a/devel/ruby-filemagic/Makefile b/devel/ruby-filemagic/Makefile
new file mode 100644
index 000000000000..33640d802177
--- /dev/null
+++ b/devel/ruby-filemagic/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: Ruby/filemagic
+# Date created: 29 July 2003
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= filemagic
+PORTVERSION= 0.1.1
+CATEGORIES= devel ruby
+MASTER_SITES= http://grub.ath.cx/filemagic/
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
+DISTNAME= ruby-${PORTNAME}-${PORTVERSION}
+DIST_SUBDIR= ruby
+
+MAINTAINER= knu@FreeBSD.org
+COMMENT= A Ruby binding to libmagic(3)
+
+LIB_DEPENDS= magic.1:${PORTSDIR}/sysutils/file
+
+USE_RUBY= yes
+USE_RUBY_EXTCONF= yes
+
+INSTALL_TARGET= site-install
+
+RUBY_RD_FILES= filemagic.rd
+DOCS= AUTHORS CHANGELOG README TODO \
+ ${RUBY_RD_FILES} \
+ ${RUBY_RD_HTML_FILES}
+
+post-install: doc-install
+
+.include <bsd.port.mk>
+
+doc-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${RUBY_MODDOCDIR}
+.for f in ${DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_MODDOCDIR}/
+.endfor
+.endif
diff --git a/devel/ruby-filemagic/distinfo b/devel/ruby-filemagic/distinfo
new file mode 100644
index 000000000000..5bb56d0af567
--- /dev/null
+++ b/devel/ruby-filemagic/distinfo
@@ -0,0 +1 @@
+MD5 (ruby/ruby-filemagic-0.1.1.tar.gz) = 0bf72b94eec248c3db2155771c16f9a4
diff --git a/devel/ruby-filemagic/pkg-descr b/devel/ruby-filemagic/pkg-descr
new file mode 100644
index 000000000000..bd8a5a6f9222
--- /dev/null
+++ b/devel/ruby-filemagic/pkg-descr
@@ -0,0 +1,7 @@
+FileMagic is a Ruby binding to the magic(4) library, which you may
+know better as the file(1) command. The file(1) command identifies
+the type of a file using, among other tests, a test for whether the
+file begins with a certain magic number.
+
+Author: Travis Whitton <whitton@atlantic.net>
+WWW: http://grub.ath.cx/filemagic/
diff --git a/devel/ruby-filemagic/pkg-plist b/devel/ruby-filemagic/pkg-plist
new file mode 100644
index 000000000000..8cbf8d1baf56
--- /dev/null
+++ b/devel/ruby-filemagic/pkg-plist
@@ -0,0 +1,8 @@
+%%RUBY_SITEARCHLIBDIR%%/filemagic.so
+%%PORTDOCS%%%%RUBY_MODDOCDIR%%/AUTHORS
+%%PORTDOCS%%%%RUBY_MODDOCDIR%%/CHANGELOG
+%%PORTDOCS%%%%RUBY_MODDOCDIR%%/README
+%%PORTDOCS%%%%RUBY_MODDOCDIR%%/TODO
+%%PORTDOCS%%%%RUBY_MODDOCDIR%%/filemagic.rd
+%%PORTDOCS%%%%RUBY_RD_HTML_FILES%%%%RUBY_MODDOCDIR%%/filemagic.html
+%%PORTDOCS%%@dirrm %%RUBY_MODDOCDIR%%