aboutsummaryrefslogtreecommitdiff
path: root/devel/ruby-gconf2
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2001-10-20 11:51:26 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2001-10-20 11:51:26 +0000
commit52512d3ab6a91b75d3947bc30f62a31c606bc9db (patch)
tree0dea91c08048733a06dd7416c796b4e01af8cf40 /devel/ruby-gconf2
parent6092cf2d58aff3d1c5a1230ec5d29264027e3d67 (diff)
downloadports-52512d3ab6a91b75d3947bc30f62a31c606bc9db.tar.gz
ports-52512d3ab6a91b75d3947bc30f62a31c606bc9db.zip
Notes
Diffstat (limited to 'devel/ruby-gconf2')
-rw-r--r--devel/ruby-gconf2/Makefile44
-rw-r--r--devel/ruby-gconf2/distinfo1
-rw-r--r--devel/ruby-gconf2/files/patch-extconf.rb27
-rw-r--r--devel/ruby-gconf2/pkg-comment1
-rw-r--r--devel/ruby-gconf2/pkg-descr8
-rw-r--r--devel/ruby-gconf2/pkg-plist9
6 files changed, 90 insertions, 0 deletions
diff --git a/devel/ruby-gconf2/Makefile b/devel/ruby-gconf2/Makefile
new file mode 100644
index 000000000000..602d9e19c645
--- /dev/null
+++ b/devel/ruby-gconf2/Makefile
@@ -0,0 +1,44 @@
+# New ports collection makefile for: ruby-gconf
+# Date created: 20 October 2001
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gconf
+PORTVERSION= 0.1
+CATEGORIES= devel ruby
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ruby-gnome
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
+DISTNAME= ruby-${PORTNAME}-${PORTVERSION}
+DIST_SUBDIR= ruby
+
+MAINTAINER= knu@FreeBSD.org
+
+LIB_DEPENDS= gconf-gtk-1.1:${PORTSDIR}/devel/gconf
+
+USE_RUBY= yes
+USE_RUBY_EXTCONF= yes
+USE_GTK= yes
+
+CONFIGURE_ARGS= --with-gtk-config=${GTK_CONFIG}
+INSTALL_TARGET= site-install
+
+DOCS= CREDITS \
+ ChangeLog \
+ INSTALL \
+ Makefile \
+ README \
+ README.DEV \
+ TODO
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${RUBY_DOCDIR}/${PORTNAME}
+.for f in ${DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_DOCDIR}/${PORTNAME}/
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/ruby-gconf2/distinfo b/devel/ruby-gconf2/distinfo
new file mode 100644
index 000000000000..bf198af3608a
--- /dev/null
+++ b/devel/ruby-gconf2/distinfo
@@ -0,0 +1 @@
+MD5 (ruby/ruby-gconf-0.1.tar.gz) = 907243ed0255150434c1174f631b3bcf
diff --git a/devel/ruby-gconf2/files/patch-extconf.rb b/devel/ruby-gconf2/files/patch-extconf.rb
new file mode 100644
index 000000000000..9b882428ca2b
--- /dev/null
+++ b/devel/ruby-gconf2/files/patch-extconf.rb
@@ -0,0 +1,27 @@
+--- extconf.rb.orig Tue Oct 16 07:27:04 2001
++++ extconf.rb Sat Oct 20 20:28:04 2001
+@@ -1,13 +1,17 @@
+ #!/usr/bin/ruby -w
+ require 'mkmf'
+-puts "GTK+ version: #{`gtk-config --version`}"
+-puts "GConf version: #{`gconf-config --version`}"
+-$CFLAGS << ' -O3 -Wall '
+-$CFLAGS << `gconf-config --cflags`.chomp
++
++gconf_config = with_config('gconf-config', 'gconf-config')
++gtk_config = with_config('gtk-config', 'gtk-config')
++
++puts "GTK+ version: #{`#{gtk_config} --version`}"
++puts "GConf version: #{`#{gconf_config} --version`}"
++$CFLAGS << ' -Wall '
++$CFLAGS << `#{gconf_config} --cflags`.chomp
+ $CFLAGS << ' '
+-$CFLAGS << `gtk-config --cflags`
+-$LDFLAGS << `gconf-config --libs`.chomp
++$CFLAGS << `#{gtk_config} --cflags`
++$LDFLAGS << `#{gconf_config} --libs`.chomp
+ $LDFLAGS << ' -lgconf-gtk-1 '
+-$LDFLAGS << `gtk-config --libs`
++$LDFLAGS << `#{gtk_config} --libs`
+ Dir.chdir('src')
+ create_makefile('gconf')
diff --git a/devel/ruby-gconf2/pkg-comment b/devel/ruby-gconf2/pkg-comment
new file mode 100644
index 000000000000..64cf14b53596
--- /dev/null
+++ b/devel/ruby-gconf2/pkg-comment
@@ -0,0 +1 @@
+A Ruby interface to GConf (1.0.x)
diff --git a/devel/ruby-gconf2/pkg-descr b/devel/ruby-gconf2/pkg-descr
new file mode 100644
index 000000000000..d43b628789e8
--- /dev/null
+++ b/devel/ruby-gconf2/pkg-descr
@@ -0,0 +1,8 @@
+This package allows Ruby developers to write applications that store
+their configuration data using GConf (1.0.x). GConf is a
+configuration database system written by Havoc Pennington et al, and
+part of the GNOME application development framework (although it can
+be used separately).
+
+Author: Neil Conway <neilconway@home.com>
+WWW: http://ruby-gnome.sf.net/gconf.html
diff --git a/devel/ruby-gconf2/pkg-plist b/devel/ruby-gconf2/pkg-plist
new file mode 100644
index 000000000000..196f339e4597
--- /dev/null
+++ b/devel/ruby-gconf2/pkg-plist
@@ -0,0 +1,9 @@
+%%RUBY_SITEARCHLIBDIR%%/gconf.so
+%%PORTDOCS%%%%RUBY_DOCDIR%%/gconf/CREDITS
+%%PORTDOCS%%%%RUBY_DOCDIR%%/gconf/ChangeLog
+%%PORTDOCS%%%%RUBY_DOCDIR%%/gconf/INSTALL
+%%PORTDOCS%%%%RUBY_DOCDIR%%/gconf/Makefile
+%%PORTDOCS%%%%RUBY_DOCDIR%%/gconf/README
+%%PORTDOCS%%%%RUBY_DOCDIR%%/gconf/README.DEV
+%%PORTDOCS%%%%RUBY_DOCDIR%%/gconf/TODO
+%%PORTDOCS%%@dirrm %%RUBY_DOCDIR%%/gconf