aboutsummaryrefslogtreecommitdiff
path: root/devel/ruby-mmap/Makefile
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2001-03-07 19:12:08 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2001-03-07 19:12:08 +0000
commitdc5d81c00326e228505b0f3fedbf52ca6c1cd02a (patch)
treeea077cf72637d5baf31f93db0ebae8947c118d38 /devel/ruby-mmap/Makefile
parent8e392f9152d7bead72d4144fe33fd14bfed06334 (diff)
downloadports-dc5d81c00326e228505b0f3fedbf52ca6c1cd02a.tar.gz
ports-dc5d81c00326e228505b0f3fedbf52ca6c1cd02a.zip
Notes
Diffstat (limited to 'devel/ruby-mmap/Makefile')
-rw-r--r--devel/ruby-mmap/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/devel/ruby-mmap/Makefile b/devel/ruby-mmap/Makefile
new file mode 100644
index 000000000000..343ccabe7baf
--- /dev/null
+++ b/devel/ruby-mmap/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: Ruby-Mmap
+# Date created: 8 March 2001
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mmap
+PORTVERSION= 0.1
+CATEGORIES= devel ruby
+MASTER_SITES= ftp://moulon.inra.fr/pub/ruby/
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
+DIST_SUBDIR= ruby
+
+MAINTAINER= knu@FreeBSD.org
+
+USE_RUBY= yes
+USE_RUBY_EXTCONF= yes
+
+INSTALL_TARGET= site-install
+
+DOCS= README.en mmap.html mmap.rd
+EXAMPLES= aa b.rb
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${RUBY_EXAMPLESDIR}/${PORTNAME}/
+.for f in ${EXAMPLES}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_EXAMPLESDIR}/${PORTNAME}/
+.endfor
+ ${MKDIR} ${RUBY_DOCDIR}/${PORTNAME}
+.for f in ${DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_DOCDIR}/${PORTNAME}/
+.endfor
+.endif
+
+.include <bsd.port.mk>