aboutsummaryrefslogtreecommitdiff
path: root/devel/ruby-rbison
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2000-11-02 03:03:24 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2000-11-02 03:03:24 +0000
commitf658c14d6cb4c8fa51033f40f442c677fad7c670 (patch)
treece89a461e7724987f96c96747ea0f70a1aa04d89 /devel/ruby-rbison
parent83e7bbbdc5dce6f4c3b141fb3f1a1cc0fd701e2e (diff)
downloadports-f658c14d6cb4c8fa51033f40f442c677fad7c670.tar.gz
ports-f658c14d6cb4c8fa51033f40f442c677fad7c670.zip
Notes
Diffstat (limited to 'devel/ruby-rbison')
-rw-r--r--devel/ruby-rbison/Makefile43
-rw-r--r--devel/ruby-rbison/distinfo1
-rw-r--r--devel/ruby-rbison/pkg-comment1
-rw-r--r--devel/ruby-rbison/pkg-descr7
-rw-r--r--devel/ruby-rbison/pkg-plist10
5 files changed, 62 insertions, 0 deletions
diff --git a/devel/ruby-rbison/Makefile b/devel/ruby-rbison/Makefile
new file mode 100644
index 000000000000..28266647edec
--- /dev/null
+++ b/devel/ruby-rbison/Makefile
@@ -0,0 +1,43 @@
+# New ports collection makefile for: rbison
+# Date created: 2 Nov 2000
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= rbison
+PORTVERSION= 0.0.5
+CATEGORIES= devel ruby
+MASTER_SITES= http://www.cs.umass.edu/~aseltine/rbison/
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
+DIST_SUBDIR= ruby
+
+MAINTAINER= knu@FreeBSD.org
+
+RUN_DEPENDS= bison:${PORTSDIR}/devel/bison
+
+USE_RUBY= yes
+
+RUBY_SHEBANG_FILES= ${WRKSRC}/rbison
+
+DOCS= ChangeLog README
+EXAMPLES= CalcFileLexer.rb CalcStringLexer.rb \
+ calc.in calc.ry calc_test.rb
+
+NO_WRKSUBDIR= yes
+NO_BUILD= yes
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/rbison ${PREFIX}/bin/
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${RUBY_EXAMPLESDIR}/rbison
+.for f in ${EXAMPLES}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_EXAMPLESDIR}/rbison/
+.endfor
+ ${MKDIR} ${RUBY_DOCDIR}/rbison
+.for f in ${DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_DOCDIR}/rbison/
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/ruby-rbison/distinfo b/devel/ruby-rbison/distinfo
new file mode 100644
index 000000000000..5eb3797cad54
--- /dev/null
+++ b/devel/ruby-rbison/distinfo
@@ -0,0 +1 @@
+MD5 (ruby/rbison-0.0.5.tar.gz) = 81cef8794d433f869a8aa04c7dafd543
diff --git a/devel/ruby-rbison/pkg-comment b/devel/ruby-rbison/pkg-comment
new file mode 100644
index 000000000000..23d485dc5b1d
--- /dev/null
+++ b/devel/ruby-rbison/pkg-comment
@@ -0,0 +1 @@
+Generates a Ruby parser class from a Bison-like specification file
diff --git a/devel/ruby-rbison/pkg-descr b/devel/ruby-rbison/pkg-descr
new file mode 100644
index 000000000000..b62f66982149
--- /dev/null
+++ b/devel/ruby-rbison/pkg-descr
@@ -0,0 +1,7 @@
+rbison generates a Ruby parser class from a Bison-like specification
+file. rbison uses Bison to do all the hard work (generating state
+transition tables, etc), then translates the Bison-generated C code
+into Ruby code.
+
+Author: Jonathan Aseltine <aseltine@cs.umass.edu>
+WWW: http://www.cs.umass.edu/~aseltine/rbison.html
diff --git a/devel/ruby-rbison/pkg-plist b/devel/ruby-rbison/pkg-plist
new file mode 100644
index 000000000000..5874c9c66c1e
--- /dev/null
+++ b/devel/ruby-rbison/pkg-plist
@@ -0,0 +1,10 @@
+bin/rbison
+%%RUBY_EXAMPLESDIR%%/rbison/CalcFileLexer.rb
+%%RUBY_EXAMPLESDIR%%/rbison/CalcStringLexer.rb
+%%RUBY_EXAMPLESDIR%%/rbison/calc.in
+%%RUBY_EXAMPLESDIR%%/rbison/calc.ry
+%%RUBY_EXAMPLESDIR%%/rbison/calc_test.rb
+%%RUBY_DOCDIR%%/rbison/ChangeLog
+%%RUBY_DOCDIR%%/rbison/README
+@dirrm %%RUBY_EXAMPLESDIR%%/rbison
+@dirrm %%RUBY_DOCDIR%%/rbison