aboutsummaryrefslogtreecommitdiff
path: root/devel/shiboken/Makefile
diff options
context:
space:
mode:
authorNicola Vitale <nivit@FreeBSD.org>2011-12-18 22:01:26 +0000
committerNicola Vitale <nivit@FreeBSD.org>2011-12-18 22:01:26 +0000
commit3cbf64b1c0646e09641ffd2aca5ee720641caa4e (patch)
tree4fbd4b5c6fb8ca111c033e44c5d9cdb5c0303c7d /devel/shiboken/Makefile
parentfc91609bb4c0524292315e0e22ca668101b255a7 (diff)
downloadports-3cbf64b1c0646e09641ffd2aca5ee720641caa4e.tar.gz
ports-3cbf64b1c0646e09641ffd2aca5ee720641caa4e.zip
Notes
Diffstat (limited to 'devel/shiboken/Makefile')
-rw-r--r--devel/shiboken/Makefile42
1 files changed, 42 insertions, 0 deletions
diff --git a/devel/shiboken/Makefile b/devel/shiboken/Makefile
new file mode 100644
index 000000000000..f99e87ac5d79
--- /dev/null
+++ b/devel/shiboken/Makefile
@@ -0,0 +1,42 @@
+# New ports collection makefile for: shiboken
+# Date created: 2011-03-21
+# Whom: Nicola Vitale <nivit@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= shiboken
+PORTVERSION= 1.0.10
+#PORTREVISION= 0
+CATEGORIES= devel
+MASTER_SITES= http://www.pyside.org/files/ \
+ http://nivi.interfree.it/distfiles/${PORTNAME}/
+
+MAINTAINER= nivit@FreeBSD.org
+COMMENT= C++ code generator for CPython extensions
+
+LICENSE= GPLv2 LGPL21
+LICENSE_COMB= multi
+
+BUILD_DEPENDS= sphinx-build:${PORTSDIR}/textproc/py-sphinx
+LIB_DEPENDS= apiextractor.0:${PORTSDIR}/devel/apiextractor \
+ genrunner.0:${PORTSDIR}/devel/generatorrunner
+
+PLIST_SUB= PORTVERSION=${PORTVERSION} \
+ PYTHON_VERSION=${PYTHON_VERSION}
+
+QT_COMPONENTS= corelib qmake_build moc_build uic_build rcc_build
+
+USE_BZIP2= yes
+USE_CMAKE= yes
+USE_LDCONFIG= yes
+USE_PYTHON= yes
+USE_QT_VER= 4
+
+.if !defined(NO_INSTALL_MANPAGES)
+MAN1= shiboken.1
+.else
+CMAKE_ARGS= -DNO_INSTALL_MANPAGES:BOOL="ON"
+.endif
+
+.include <bsd.port.mk>