aboutsummaryrefslogtreecommitdiff
path: root/devel/shmap
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-12-22 13:30:02 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-12-22 13:30:02 +0000
commit3954f0c130b2e697ed7d7c60bbd6bd03dfbe64db (patch)
tree8d33b660a9c936e761980a238d70f0eab47586f4 /devel/shmap
parente46f0a88fc03d33ad12ad10b35483ee90095232f (diff)
downloadports-3954f0c130b2e697ed7d7c60bbd6bd03dfbe64db.tar.gz
ports-3954f0c130b2e697ed7d7c60bbd6bd03dfbe64db.zip
Notes
Diffstat (limited to 'devel/shmap')
-rw-r--r--devel/shmap/Makefile2
-rw-r--r--devel/shmap/files/patch-Makefile.in11
-rw-r--r--devel/shmap/files/patch-shmap_Makefile.in15
3 files changed, 27 insertions, 1 deletions
diff --git a/devel/shmap/Makefile b/devel/shmap/Makefile
index 4511be85aa22..cf771e7dc63d 100644
--- a/devel/shmap/Makefile
+++ b/devel/shmap/Makefile
@@ -18,7 +18,7 @@ MAINTAINER= ports@FreeBSD.org
LIB_DEPENDS= mm.12:${PORTSDIR}/devel/mm
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
INSTALLS_SHLIB= yes
diff --git a/devel/shmap/files/patch-Makefile.in b/devel/shmap/files/patch-Makefile.in
new file mode 100644
index 000000000000..2da19fec84c4
--- /dev/null
+++ b/devel/shmap/files/patch-Makefile.in
@@ -0,0 +1,11 @@
+--- Makefile.in.orig Wed Jul 10 22:28:42 2002
++++ Makefile.in Sun Dec 15 06:00:55 2002
+@@ -78,7 +78,7 @@
+ am__quote = @am__quote@
+ install_sh = @install_sh@
+
+-SUBDIRS = mm-1.1.3 shmap
++SUBDIRS = shmap
+ include_HEADERS = shmap_config.h
+ subdir = .
+ ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
diff --git a/devel/shmap/files/patch-shmap_Makefile.in b/devel/shmap/files/patch-shmap_Makefile.in
new file mode 100644
index 000000000000..3435f95f0548
--- /dev/null
+++ b/devel/shmap/files/patch-shmap_Makefile.in
@@ -0,0 +1,15 @@
+--- shmap/Makefile.in.orig Wed Jul 10 22:28:42 2002
++++ shmap/Makefile.in Sun Dec 15 06:02:36 2002
+@@ -80,10 +80,10 @@
+
+ lib_LTLIBRARIES = libshmap.la
+ libshmap_la_SOURCES = core.c mem_core.c shmap.c shmap_hm.c shmap_ll.c shmap_value.c shmap_btree.c shmap_fifo.c pool.c
+-libshmap_la_LIBADD = -L../mm-1.1.3 -lmm
++libshmap_la_LIBADD = -lmm
+ noinst_HEADERS = core.h mem_core.h shmap_hm.h shmap_ll.h shmap_value.h shmap_btree.h shmap_fifo.h pool.h shmap_internals.h
+ include_HEADERS = shmap.h
+-CFLAGS = -Wall -g -O2 -I../mm-1.1.3
++CFLAGS = @CFLAGS@
+ subdir = shmap
+ mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
+ CONFIG_HEADER = $(top_builddir)/shmap_config.h