aboutsummaryrefslogtreecommitdiff
path: root/devel/soup
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2001-05-28 14:54:40 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2001-05-28 14:54:40 +0000
commitf9cb37cd5ead687ace7e156e94f16b176faeea4a (patch)
treece0d8ac26db3e8e017eb23f9714ebfc00d70ab69 /devel/soup
parentcff22159a4aaa62ccf582ccc8ad36a3047f42a16 (diff)
downloadports-f9cb37cd5ead687ace7e156e94f16b176faeea4a.tar.gz
ports-f9cb37cd5ead687ace7e156e94f16b176faeea4a.zip
Notes
Diffstat (limited to 'devel/soup')
-rw-r--r--devel/soup/Makefile35
-rw-r--r--devel/soup/distinfo1
-rw-r--r--devel/soup/files/patch-Makefile.in14
-rw-r--r--devel/soup/files/patch-configure25
-rw-r--r--devel/soup/files/patch-docs::reference::Makefile.in13
-rw-r--r--devel/soup/files/patch-src::soup-core::soup-private.h16
-rw-r--r--devel/soup/pkg-comment1
-rw-r--r--devel/soup/pkg-descr17
-rw-r--r--devel/soup/pkg-plist42
9 files changed, 164 insertions, 0 deletions
diff --git a/devel/soup/Makefile b/devel/soup/Makefile
new file mode 100644
index 000000000000..25906d204ec3
--- /dev/null
+++ b/devel/soup/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: soup
+# Date created: 29 May 2001
+# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= soup
+PORTVERSION= 0.2
+CATEGORIES= devel gnome
+MASTER_SITES= ${MASTER_SITE_GNOME}
+MASTER_SITE_SUBDIR= unstable/sources/soup
+
+MAINTAINER= gnome@FreeBSD.org
+
+LIB_DEPENDS= popt.0:${PORTSDIR}/devel/popt \
+ xml.5:${PORTSDIR}/textproc/libxml
+
+WRKSRC= ${WRKDIR}/${DISTNAME}.1
+
+USE_LIBTOOL= yes
+USE_GLIB= yes
+INSTALL_SHLIBS= yes
+CONFIGURE_ARGS= --with-html-dir=${PREFIX}/share/doc
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LIBS="-L${LOCALBASE}/lib"
+
+pre-patch:
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
+ s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
+ @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
+ 's|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g ; \
+ s|\$\(libdir\)/pkgconfig|\$\(prefix\)/libdata/pkgconfig|g'
+
+.include <bsd.port.mk>
diff --git a/devel/soup/distinfo b/devel/soup/distinfo
new file mode 100644
index 000000000000..f703b5c015db
--- /dev/null
+++ b/devel/soup/distinfo
@@ -0,0 +1 @@
+MD5 (soup-0.2.tar.gz) = e3698f35caeebb9da4958d3a57aebf79
diff --git a/devel/soup/files/patch-Makefile.in b/devel/soup/files/patch-Makefile.in
new file mode 100644
index 000000000000..6a76f498a72b
--- /dev/null
+++ b/devel/soup/files/patch-Makefile.in
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- Makefile.in 2001/05/28 13:16:59 1.1
++++ Makefile.in 2001/05/28 13:17:30
+@@ -115,7 +115,7 @@
+
+ bin_SCRIPTS = soup-config
+
+-confexecdir = $(libdir)
++confexecdir = $(prefix)/etc
+ confexec_DATA = soupConf.sh soup_apacheConf.sh soup_wsdlConf.sh
+
+ pkgconfigdir = $(libdir)/pkgconfig
diff --git a/devel/soup/files/patch-configure b/devel/soup/files/patch-configure
new file mode 100644
index 000000000000..3d546f6fcf4a
--- /dev/null
+++ b/devel/soup/files/patch-configure
@@ -0,0 +1,25 @@
+
+$FreeBSD$
+
+--- configure 2001/05/28 11:58:28 1.1
++++ configure 2001/05/28 12:00:46
+@@ -2202,8 +2202,8 @@
+ rm -f conf.glibtest
+
+
+-GLIB_CFLAGS=`glib-config --cflags glib`
+-GLIB_LIBS=`glib-config --libs glib`
++GLIB_CFLAGS=`$GLIB_CONFIG --cflags glib`
++GLIB_LIBS=`$GLIB_CONFIG --libs glib`
+
+
+
+@@ -2259,8 +2259,6 @@
+
+ save_CPPFLAGS=$CPPFLAGS
+ save_LIBS=$LIBS
+-CPPFLAGS=
+-LIBS=
+
+ echo $ac_n "checking for poptGetContext in -lpopt""... $ac_c" 1>&6
+ echo "configure:2267: checking for poptGetContext in -lpopt" >&5
diff --git a/devel/soup/files/patch-docs::reference::Makefile.in b/devel/soup/files/patch-docs::reference::Makefile.in
new file mode 100644
index 000000000000..a95c53a8151c
--- /dev/null
+++ b/devel/soup/files/patch-docs::reference::Makefile.in
@@ -0,0 +1,13 @@
+
+$FreeBSD$
+
+--- docs/reference/Makefile.in 2001/05/28 13:11:32 1.1
++++ docs/reference/Makefile.in 2001/05/28 13:12:10
+@@ -262,6 +262,7 @@
+
+
+ @ENABLE_GTK_DOC_TRUE@all-local: html-build.stamp
++@ENABLE_GTK_DOC_FALSE@all-local:
+
+ #### scan ####
+
diff --git a/devel/soup/files/patch-src::soup-core::soup-private.h b/devel/soup/files/patch-src::soup-core::soup-private.h
new file mode 100644
index 000000000000..ad904e7531aa
--- /dev/null
+++ b/devel/soup/files/patch-src::soup-core::soup-private.h
@@ -0,0 +1,16 @@
+
+$FreeBSD$
+
+--- src/soup-core/soup-private.h 2001/05/28 12:03:44 1.1
++++ src/soup-core/soup-private.h 2001/05/28 12:05:03
+@@ -16,7 +16,10 @@
+ #ifndef SOAP_PRIVATE_H
+ #define SOAP_PRIVATE_H 1
+
++#include <sys/types.h>
++#include <sys/socket.h>
+ #include <netinet/in.h>
++#include <arpa/inet.h>
+
+ #include "soup-context.h"
+ #include "soup-server.h"
diff --git a/devel/soup/pkg-comment b/devel/soup/pkg-comment
new file mode 100644
index 000000000000..0179e22c405c
--- /dev/null
+++ b/devel/soup/pkg-comment
@@ -0,0 +1 @@
+A SOAP (Simple Object Access Protocol) implementation in C
diff --git a/devel/soup/pkg-descr b/devel/soup/pkg-descr
new file mode 100644
index 000000000000..423bf5cfc4f6
--- /dev/null
+++ b/devel/soup/pkg-descr
@@ -0,0 +1,17 @@
+Soup is a SOAP (Simple Object Access Protocol) implementation in C.
+
+It provides an queued asynchronous callback-based mechanism for sending and
+servicing SOAP requests, and a WSDL (Web Service Definition Language) to C
+compiler which generates client stubs and server skeletons for easily calling
+and implementing SOAP methods.
+
+It uses the GLib main loop and is designed to work well with GTK applications.
+
+Features:
+ * Completely Asynchronous
+ * Connection cache
+ * HTTP chunked transfer and persistent connections
+ * authenticated HTTP, SOCKS4, and SOCKS5 proxy support
+ * SSL Support using OpenSSL
+ * Apache module server support
+ * Client digest authentication
diff --git a/devel/soup/pkg-plist b/devel/soup/pkg-plist
new file mode 100644
index 000000000000..72648ab9fda6
--- /dev/null
+++ b/devel/soup/pkg-plist
@@ -0,0 +1,42 @@
+bin/soup-config
+bin/soup-ssl-proxy
+bin/soup-wsdl
+etc/soupConf.sh
+etc/soup_apacheConf.sh
+etc/soup_wsdlConf.sh
+include/soup/soup-context.h
+include/soup/soup-env.h
+include/soup/soup-fault.h
+include/soup/soup-message.h
+include/soup/soup-misc.h
+include/soup/soup-parser.h
+include/soup/soup-serializer.h
+include/soup/soup-server.h
+include/soup/soup-socket.h
+include/soup/soup-uri.h
+include/soup/soup.h
+include/wsdl/wsdl-param.h
+include/wsdl/wsdl-schema-glib.h
+include/wsdl/wsdl-schema.h
+include/wsdl/wsdl-soap-marshal.h
+include/wsdl/wsdl-soap-memory.h
+include/wsdl/wsdl-soap-parse.h
+include/wsdl/wsdl-typecodes-c.h
+include/wsdl/wsdl-typecodes.h
+include/wsdl/wsdl.h
+lib/libsoup-apache.a
+lib/libsoup-apache.so
+lib/libsoup-apache.so.2
+lib/libsoup.a
+lib/libsoup.so
+lib/libsoup.so.2
+lib/libwsdl-build.a
+lib/libwsdl-build.so
+lib/libwsdl-build.so.2
+lib/libwsdl.a
+lib/libwsdl.so
+lib/libwsdl.so.2
+libdata/pkgconfig/soup.pc
+@dirrm share/doc/soup
+@dirrm include/wsdl
+@dirrm include/soup