aboutsummaryrefslogtreecommitdiff
path: root/devel/stlport
diff options
context:
space:
mode:
authorJustin M. Seger <jseger@FreeBSD.org>1998-12-18 03:09:05 +0000
committerJustin M. Seger <jseger@FreeBSD.org>1998-12-18 03:09:05 +0000
commitee8e25af3e45dba924ed05c7b2f13c886f9c2d69 (patch)
tree11c40c9e80925ecd07595f3305c7bc898e7e4019 /devel/stlport
parent986552f488852bca11b7faa5f707a20fe5c00ed0 (diff)
downloadports-ee8e25af3e45dba924ed05c7b2f13c886f9c2d69.tar.gz
ports-ee8e25af3e45dba924ed05c7b2f13c886f9c2d69.zip
Notes
Diffstat (limited to 'devel/stlport')
-rw-r--r--devel/stlport/Makefile33
-rw-r--r--devel/stlport/distinfo1
-rw-r--r--devel/stlport/files/patch-aa12
-rw-r--r--devel/stlport/pkg-comment1
-rw-r--r--devel/stlport/pkg-descr13
-rw-r--r--devel/stlport/pkg-plist95
6 files changed, 155 insertions, 0 deletions
diff --git a/devel/stlport/Makefile b/devel/stlport/Makefile
new file mode 100644
index 000000000000..14a468505a80
--- /dev/null
+++ b/devel/stlport/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: stlport
+# Version required: 3.01
+# Date Created: 2 December 1998
+# Whom: Josh Gilliam <josh@quick.net>
+#
+# $Id$
+#
+
+DISTNAME= STLport-3.01
+PKGNAME= stlport-3.01
+CATEGORIES= devel
+MASTER_SITES= http://corp.metabyte.com/~fbp/stl/ \
+ ftp://maroon.webmaster.com/pub/STLport/
+
+MAINTAINER= josh@quick.net
+
+NO_WRKSUBDIR= yes
+GNU_CONFIGURE= yes
+NO_BUILD= yes
+
+pre-configure:
+ chmod +x ${WRKSRC}/configure
+
+do-install:
+ ${MKDIR} ${PREFIX}/include/stlport
+
+.for include in *.h algorith algorithm deque functional hash_map hash_set \
+iterator list map memory numeric queue rope set slist stack utility vector \
+xmemory xutility
+ ${INSTALL_DATA} ${WRKSRC}/${include} ${PREFIX}/include/stlport
+.endfor
+
+.include <bsd.port.mk>
diff --git a/devel/stlport/distinfo b/devel/stlport/distinfo
new file mode 100644
index 000000000000..1295429a01dd
--- /dev/null
+++ b/devel/stlport/distinfo
@@ -0,0 +1 @@
+MD5 (STLport-3.01.tar.gz) = be39eaad3e86d23a77f4d579f26b7320
diff --git a/devel/stlport/files/patch-aa b/devel/stlport/files/patch-aa
new file mode 100644
index 000000000000..fbe88d7bf6fa
--- /dev/null
+++ b/devel/stlport/files/patch-aa
@@ -0,0 +1,12 @@
+--- stl_rope.h.orig Sun Feb 8 18:08:40 1998
++++ stl_rope.h Thu Dec 17 19:37:18 1998
+@@ -776,7 +776,8 @@
+ __rope_iterator_base<charT,Alloc>(r.tree_ptr, pos) {}
+ self& operator= (const self & x) {
+ if (0 != x.buf_ptr) {
+- *this = x;
++ *(static_cast<__rope_iterator_base<charT,Alloc>*>(this)) = x;
++ // bugfix by Kevin Atkinosn (kevina@clark.net) was *this = x;
+ } else {
+ current_pos = x.current_pos;
+ root = x.root;
diff --git a/devel/stlport/pkg-comment b/devel/stlport/pkg-comment
new file mode 100644
index 000000000000..889ad9993134
--- /dev/null
+++ b/devel/stlport/pkg-comment
@@ -0,0 +1 @@
+Adaptation of SGI's Standard Template Library
diff --git a/devel/stlport/pkg-descr b/devel/stlport/pkg-descr
new file mode 100644
index 000000000000..e8068bf83ad7
--- /dev/null
+++ b/devel/stlport/pkg-descr
@@ -0,0 +1,13 @@
+STLport is an an adaptation of SGI's Standard Template Library.
+The goal of the STLport effort is to make SGI's STL
+implementation usable with most compilers while retaining full
+functionality.
+
+The Standard Template Library is a C++ library of container
+classes, algorithms, and iterators providing many of the basic
+algorithms and data structures of computer science.
+
+STL: http://www.sgi.com/Technology/STL/
+
+--
+Josh Gilliam <josh@quick.net>
diff --git a/devel/stlport/pkg-plist b/devel/stlport/pkg-plist
new file mode 100644
index 000000000000..09c6b812f80f
--- /dev/null
+++ b/devel/stlport/pkg-plist
@@ -0,0 +1,95 @@
+include/stlport/algo.h
+include/stlport/algobase.h
+include/stlport/algorith
+include/stlport/algorith.h
+include/stlport/algorithm
+include/stlport/algorithm.h
+include/stlport/alloc.h
+include/stlport/auto_ptr.h
+include/stlport/bvector.h
+include/stlport/defalloc.h
+include/stlport/deque
+include/stlport/deque.h
+include/stlport/function.h
+include/stlport/functional
+include/stlport/hash_map
+include/stlport/hash_map.h
+include/stlport/hash_set
+include/stlport/hash_set.h
+include/stlport/hashtable.h
+include/stlport/heap.h
+include/stlport/iterator
+include/stlport/iterator.h
+include/stlport/list
+include/stlport/list.h
+include/stlport/map
+include/stlport/map.h
+include/stlport/memory
+include/stlport/mmemory.h
+include/stlport/msl_algobase.h
+include/stlport/msl_iterator.h
+include/stlport/multimap.h
+include/stlport/multiset.h
+include/stlport/numeric
+include/stlport/numeric.h
+include/stlport/pair.h
+include/stlport/ph_iterator.h
+include/stlport/pthread_alloc.h
+include/stlport/queue
+include/stlport/queue.h
+include/stlport/rope
+include/stlport/rope.h
+include/stlport/ropeimpl.h
+include/stlport/set
+include/stlport/set.h
+include/stlport/slist
+include/stlport/slist.h
+include/stlport/stack
+include/stlport/stack.h
+include/stlport/stl_algo.h
+include/stlport/stl_algobase.h
+include/stlport/stl_alloc.h
+include/stlport/stl_bvector.h
+include/stlport/stl_config.h
+include/stlport/stl_construct.h
+include/stlport/stl_deque.h
+include/stlport/stl_function.h
+include/stlport/stl_hash_fun.h
+include/stlport/stl_hash_map.h
+include/stlport/stl_hash_set.h
+include/stlport/stl_hashtable.h
+include/stlport/stl_heap.h
+include/stlport/stl_iterator.h
+include/stlport/stl_list.h
+include/stlport/stl_lock.h
+include/stlport/stl_map.h
+include/stlport/stl_multimap.h
+include/stlport/stl_multiset.h
+include/stlport/stl_numeric.h
+include/stlport/stl_pair.h
+include/stlport/stl_pthread_alloc.h
+include/stlport/stl_queue.h
+include/stlport/stl_raw_storage_iter.h
+include/stlport/stl_relops.h
+include/stlport/stl_rope.h
+include/stlport/stl_set.h
+include/stlport/stl_slist.h
+include/stlport/stl_stack.h
+include/stlport/stl_tempbuf.h
+include/stlport/stl_tree.h
+include/stlport/stl_uninitialized.h
+include/stlport/stl_vector.h
+include/stlport/stlcomp.h
+include/stlport/stlconf.h
+include/stlport/stldebug.h
+include/stlport/tempbuf.h
+include/stlport/tree.h
+include/stlport/type_traits.h
+include/stlport/utility
+include/stlport/utility.h
+include/stlport/vector
+include/stlport/vector.h
+include/stlport/xfunction.h
+include/stlport/xmemory
+include/stlport/xutility
+@dirrm include/stlport