aboutsummaryrefslogtreecommitdiff
path: root/devel/subversion
diff options
context:
space:
mode:
authorPhilip M. Gollucci <pgollucci@FreeBSD.org>2010-06-03 02:49:22 +0000
committerPhilip M. Gollucci <pgollucci@FreeBSD.org>2010-06-03 02:49:22 +0000
commitd491a98d99cb1e3d5823671fc5b1fb5a0c8d7f95 (patch)
tree7fd2cdc90ceb530e5b4a15f6df351c5354edeaec /devel/subversion
parent1f094e144a096583f3c05d33c64b912dcc7f7dd1 (diff)
downloadports-d491a98d99cb1e3d5823671fc5b1fb5a0c8d7f95.tar.gz
ports-d491a98d99cb1e3d5823671fc5b1fb5a0c8d7f95.zip
Notes
Diffstat (limited to 'devel/subversion')
-rw-r--r--devel/subversion/Makefile17
-rw-r--r--devel/subversion/Makefile.common38
2 files changed, 16 insertions, 39 deletions
diff --git a/devel/subversion/Makefile b/devel/subversion/Makefile
index 773c318b4b7e..e7a8f52cac5a 100644
--- a/devel/subversion/Makefile
+++ b/devel/subversion/Makefile
@@ -18,7 +18,6 @@ MAN8= svnserve.8
TXT_DOCS= BUGS CHANGES COMMITTERS COPYING HACKING INSTALL README
OPTIONS= MOD_DAV_SVN "mod_dav_svn module for Apache 2.X" off \
- APACHE2_APR "Use APR from Apache 2.X" off \
MOD_DONTDOTHAT "mod_dontdothat for Apache 2.X" off \
NEON "WebDAV/Delta-V repo access module (neon)" on \
SERF "WebDAV/Delta-V repo access module (serf)" off \
@@ -103,19 +102,10 @@ pre-everything::
@${FALSE}
.endif
@${ECHO_MSG} "mod_dav_svn module for Apache 2.X enabled."
- @${ECHO_MSG} "This option implies the WITH_APACHE2_APR option."
.else
@${ECHO_MSG} "You can enable the mod_dav_svn module for Apache 2.X"
.endif
@${ECHO_MSG} ""
-.if defined(WITH_APACHE2_APR)
- @${ECHO_MSG} "Using APR from ${APACHE_PORT}. If you have the devel/apr1"
- @${ECHO_MSG} "port/package installed, you may need to remove it."
-.else
- @${ECHO_MSG} "You can link subversion against the APR built with"
- @${ECHO_MSG} "the ${APACHE_PORT} port, rather than the devel/apr1 port."
-.endif
- @${ECHO_MSG} ""
.if defined(WITH_MOD_DONTDOTHAT) && defined(WITH_MOD_DAV_SVN)
@${ECHO_MSG} "mod_dontdothat module for Apache 2.X enabled."
.else
@@ -168,13 +158,6 @@ pre-everything::
@${ECHO_MSG} "Many useful scripts will be installed into ${DATADIR}"
pre-configure:
- @if [ ! -x ${APR_APU_DIR}/${APR_CONFIG} -o ! -x ${APR_APU_DIR}/${APU_CONFIG} ] ; then \
- ${ECHO_MSG} "" ; \
- ${ECHO_MSG} 'You selected to use`'"${APR_PORT}' for apr library." ; \
- ${ECHO_MSG} 'It seems that `'"${APR_PORT}' is not properly installed." ; \
- ${ECHO_MSG} "" ; \
- ${FALSE} ; \
- fi
.if !defined(WITHOUT_BDB)
@if [ `${APR_APU_DIR}/${APU_CONFIG} --db-version` != "4" ] ; then \
${ECHO_MSG} "" ; \
diff --git a/devel/subversion/Makefile.common b/devel/subversion/Makefile.common
index 5f04b4b358fd..b7aec91eb5e9 100644
--- a/devel/subversion/Makefile.common
+++ b/devel/subversion/Makefile.common
@@ -6,7 +6,7 @@
PORTNAME= subversion
PORTVERSION= 1.6.11
-PORTREVISION?= 2
+PORTREVISION?= 3
CATEGORIES+= devel
MASTER_SITES= http://subversion.tigris.org/downloads/:main \
http://svnbook.red-bean.com/en/1.5/:book
@@ -75,7 +75,7 @@ PLIST_SUB+= BDB="@comment "
.endif
.if defined(WITH_MOD_DAV_SVN)
-WITH_APACHE2_APR= yes
+WITH_APACHE= yes
CONFIGURE_ARGS+= --with-apxs=${APXS}
PLIST_SUB+= MOD_DAV_SVN=""
SUB_LIST+= MOD_DAV_SVN_INSTALL="YES"
@@ -94,34 +94,28 @@ SVNGROUP?= svn
SVNUSER?= svn
.endif
-.if defined(WITH_APACHE2_APR)
-USE_APACHE= 2.0+
+.if defined(WITH_APACHE)
+USE_APACHE= 2.0+
.include "${PORTSDIR}/Mk/bsd.apache.mk"
-.if ${APACHE_VERSION} >= 21
-APR_APU_DIR= ${LOCALBASE}/bin
-APR_CONFIG= apr-1-config
-APU_CONFIG= apu-1-config
+.if ${APACHE_VERSION} > 20
+LIB_DEPENDS+= apr-1:${PORTSDIR}/devel/apr1
+APR_CONFIG= ${LOCALBASE}/bin/apr-1-config
+APU_CONFIG= ${LOCALBASE}/bin/apu-1-config
.else
-APR_APU_DIR= ${LOCALBASE}/lib/apache2
-APR_CONFIG= apr-config
-APU_CONFIG= apu-config
+LIB_DEPENDS+= apr-0:${PORTSDIR}/devel/apr0
+APR_CONFIG= ${LOCALBASE}/bin/apr-config
+APU_CONFIG= ${LOCALBASE}/bin/apu-config
.endif
-APR_PORT= ${APACHE_PORT}
.else
-APR_PORT= devel/apr1
-LIB_DEPENDS+= apr-1:${PORTSDIR}/${APR_PORT}
-APR_APU_DIR= ${LOCALBASE}/bin
-APR_CONFIG= apr-1-config
-APU_CONFIG= apu-1-config
+LIB_DEPENDS+= apr-1:${PORTSDIR}/devel/apr1
+APR_CONFIG= ${LOCALBASE}/bin/apr-1-config
+APU_CONFIG= ${LOCALBASE}/bin/apu-1-config
.endif
-CONFIGURE_ARGS+=--with-apr=${APR_APU_DIR}/${APR_CONFIG} \
- --with-apr-util=${APR_APU_DIR}/${APU_CONFIG}
+CONFIGURE_ARGS+= --with-apr=${APR_CONFIG} --with-apr-util=${APU_CONFIG}
.if defined(WITH_SVNAUTHZ_VALIDATE)
-.if exists(${APR_APU_DIR}/${APR_CONFIG})
-APR_INCLUDE_DIR!= ${APR_APU_DIR}/${APR_CONFIG} --includedir
-.endif
+APR_INCLUDE_DIR!= ${APR_CONFIG} --includedir
PLIST_SUB+= SVNAUTHZ_VALIDATE=""
.else
PLIST_SUB+= SVNAUTHZ_VALIDATE="@comment "