aboutsummaryrefslogtreecommitdiff
path: root/devel/tclcl/Makefile
diff options
context:
space:
mode:
authorMartin Matuska <mm@FreeBSD.org>2007-04-30 13:00:03 +0000
committerMartin Matuska <mm@FreeBSD.org>2007-04-30 13:00:03 +0000
commit6c67af15a762b791a2b0113095d9d788fee1a65b (patch)
tree65e14b12f5bdc8d84a2d40b7f739b8b503936d58 /devel/tclcl/Makefile
parent382ab541925ae6874b455dad872b9112a5cfcc7d (diff)
downloadports-6c67af15a762b791a2b0113095d9d788fee1a65b.tar.gz
ports-6c67af15a762b791a2b0113095d9d788fee1a65b.zip
Notes
Diffstat (limited to 'devel/tclcl/Makefile')
-rw-r--r--devel/tclcl/Makefile23
1 files changed, 19 insertions, 4 deletions
diff --git a/devel/tclcl/Makefile b/devel/tclcl/Makefile
index c36079b60e1b..4b2b0ca9e1ad 100644
--- a/devel/tclcl/Makefile
+++ b/devel/tclcl/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= tclcl
-PORTVERSION= 1.18
+PORTVERSION= 1.19
DISTVERSIONPREFIX= src-
CATEGORIES= devel tcl84 tk84
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
@@ -19,20 +19,35 @@ LIB_DEPENDS= otcl:${PORTSDIR}/lang/otcl
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-USE_TK= yes
-USE_TK_BUILD= yes
USE_AUTOTOOLS= autoconf:259
GNU_CONFIGURE= yes
.if !defined(NOPORTDOCS)
-PORTDOCS= CHANGES.html
+PORTDOCS= CHANGES.html TODO.html
.endif
.include <bsd.port.pre.mk>
+# We have to link against the same Tcl/Tk version as OTcl does
+.if exists(${LOCALBASE}/bin/otclsh)
+OTCL_TCLVER!= ${ECHO_CMD} puts \$$tcl_version | ${LOCALBASE}/bin/otclsh
+USE_TK= ${OTCL_TCLVER:S/.//}
+.else
+USE_TK= 80+
+.endif
+
+.include "${PORTSDIR}/Mk/bsd.tcl.mk"
+
CONFIGURE_ARGS= --with-tcl-ver=${TCL_VER} --with-tk-ver=${TK_VER} \
--x-libraries=${X11BASE}/lib --x-includes=${X11BASE}/include
+post-patch:
+ @${REINPLACE_CMD} -e 's|exec tclsh|exec ${TCLSH}|g' ${WRKSRC}/otcldoc
+ @${REINPLACE_CMD} -e 's|../lib/tcl$$TCL_HI_VERS|${TCL_LIBDIR}|g' \
+ -e 's|../include|${TCL_INCLUDEDIR}/generic|g' ${WRKSRC}/conf/configure.in.tcl
+ @${REINPLACE_CMD} -e 's|../lib/tk$$TK_HI_VERS|${TK_LIBDIR}|g' \
+ -e 's|../include|${TK_INCLUDEDIR}/generic|g' ${WRKSRC}/conf/configure.in.tk
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/tcl2c++ ${PREFIX}/bin
${INSTALL_SCRIPT} ${WRKSRC}/otcldoc ${PREFIX}/bin