aboutsummaryrefslogtreecommitdiff
path: root/devel/tinylaf
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2005-06-12 19:19:06 +0000
committerThierry Thomas <thierry@FreeBSD.org>2005-06-12 19:19:06 +0000
commit414a0782bc7319d5f35c7bccfa7ee23f47124136 (patch)
treeca9b5658fa22ab4f707d76b1694266f248520870 /devel/tinylaf
parente36c8ed2347188f81932a728b81de9e5ae8d747d (diff)
downloadports-414a0782bc7319d5f35c7bccfa7ee23f47124136.tar.gz
ports-414a0782bc7319d5f35c7bccfa7ee23f47124136.zip
Notes
Diffstat (limited to 'devel/tinylaf')
-rw-r--r--devel/tinylaf/Makefile50
-rw-r--r--devel/tinylaf/distinfo2
-rw-r--r--devel/tinylaf/files/pkg-message.in1
-rw-r--r--devel/tinylaf/pkg-descr6
4 files changed, 59 insertions, 0 deletions
diff --git a/devel/tinylaf/Makefile b/devel/tinylaf/Makefile
new file mode 100644
index 000000000000..8256924cf319
--- /dev/null
+++ b/devel/tinylaf/Makefile
@@ -0,0 +1,50 @@
+# New ports collection makefile for: tinylaf
+# Date created: 22 May 2005
+# Whom: Thierry Thomas <thierry@pompo.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= tinylaf
+PORTVERSION= 1.2.1
+CATEGORIES= devel java
+MASTER_SITES= http://www.muntjak.de/hans/java/tinylaf/
+DISTNAME= ${PORTNAME}-beta-${PORTVERSION}
+
+MAINTAINER= thierry@FreeBSD.org
+COMMENT= A pluggable Look and Feel for Java
+
+USE_ZIP= yes
+USE_JAVA= yes
+JAVA_VERSION= 1.4+
+NO_BUILD= yes
+
+JARFILE= ${PORTNAME}.jar
+
+PORTDOCS= readme.txt
+THEMES= 98\ Earth.theme 98\ Lego.theme 98\ Light.theme 98\ Pool.theme \
+ XP\ Forest.theme XP\ Golden.theme XP\ Plastic.theme Xp\ Silver.theme
+
+PLIST_FILES= %%JAVAJARDIR%%/${JARFILE}
+PLIST_FILES+= ${THEMES:S|^|%%DATADIR%%/|}
+PLIST_DIRS+= %%DATADIR%%
+
+SUB_FILES= pkg-message
+PKGMESSAGE= ${WRKDIR}/pkg-message
+
+do-install:
+ ${MKDIR} ${DATADIR}
+ ${INSTALL_DATA} ${JARFILE:S|^|${WRKSRC}/|} ${JAVAJARDIR}
+ ${INSTALL_DATA} ${THEMES:S|^|${WRKSRC}/|} ${DATADIR}
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
+ @${ECHO_MSG} "===> Documentation installed in ${DOCSDIR}."
+.endif
+
+post-install:
+ @${ECHO_MSG}
+ @${CAT} ${PKGMESSAGE}
+ @${ECHO_MSG}
+
+.include <bsd.port.mk>
diff --git a/devel/tinylaf/distinfo b/devel/tinylaf/distinfo
new file mode 100644
index 000000000000..17e69dab5eeb
--- /dev/null
+++ b/devel/tinylaf/distinfo
@@ -0,0 +1,2 @@
+MD5 (tinylaf-beta-1.2.1.zip) = bcbaf0364fa42f9d9f967336e61f926a
+SIZE (tinylaf-beta-1.2.1.zip) = 484367
diff --git a/devel/tinylaf/files/pkg-message.in b/devel/tinylaf/files/pkg-message.in
new file mode 100644
index 000000000000..308d6ed08fe8
--- /dev/null
+++ b/devel/tinylaf/files/pkg-message.in
@@ -0,0 +1 @@
+Common themes have been installed in %%DATADIR%%.
diff --git a/devel/tinylaf/pkg-descr b/devel/tinylaf/pkg-descr
new file mode 100644
index 000000000000..13b0debc7e53
--- /dev/null
+++ b/devel/tinylaf/pkg-descr
@@ -0,0 +1,6 @@
+TinyLaF is a (mostly painted) pluggable Look and Feel for Java.
+
+TinyLaF can look like Windows 98 or like Windows XP. With the assistance of
+the control panel, the user can define the component's colors and behaviour.
+
+WWW: http://www.muntjak.de/hans/java/tinylaf/index.html