aboutsummaryrefslogtreecommitdiff
path: root/devel/tla
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2008-11-09 20:48:19 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2008-11-09 20:48:19 +0000
commitf497386f853ea6388dc26080f520aea44703a6e3 (patch)
tree623418cf5fc5f4ffda9137b16340786a044578b8 /devel/tla
parente45c84fb94688c67c97ab7082496d4e7dff9ea42 (diff)
Notes
Diffstat (limited to 'devel/tla')
-rw-r--r--devel/tla/Makefile37
-rw-r--r--devel/tla/pkg-descr13
2 files changed, 26 insertions, 24 deletions
diff --git a/devel/tla/Makefile b/devel/tla/Makefile
index 4869e16620c8..3a16eae2a075 100644
--- a/devel/tla/Makefile
+++ b/devel/tla/Makefile
@@ -1,6 +1,6 @@
-# Ports collection makefile for: tla
-# Date Created: August 17th, 2003
-# Whom: seanc
+# New ports collection makefile for: tla
+# Date created: August 17th, 2003
+# Whom: Sean Chittenden <seanc@FreeBSD.org>
#
# $FreeBSD$
#
@@ -20,11 +20,18 @@ COMMENT= The original arch source control management CLI written in C
BUILD_DEPENDS= gpatch:${PORTSDIR}/devel/patch \
gdiff:${PORTSDIR}/textproc/diffutils \
gtar:${PORTSDIR}/archivers/gtar
-RUN_DEPENDS= ${BUILD_DEPENDS}
+RUN_DEPENDS:= ${BUILD_DEPENDS}
-GNU_CONFIGURE= yes
+HAS_CONFIGURE= yes
USE_GMAKE= yes
+CONFIGURE_SCRIPT= ../configure
+CONFIGURE_ARGS= --prefix=${PREFIX} \
+ --with-gnu-patch gpatch \
+ --with-gnu-diff gdiff \
+ --with-gnu-diff3 gdiff3 \
+ --with-gnu-tar gtar
+
ORIGWRKSRC= ${WRKDIR}/${DISTNAME}/src
PATCH_WRKSRC= ${ORIGWRKSRC}/..
WRKSRC= ${ORIGWRKSRC}/=build
@@ -34,22 +41,17 @@ PLIST_FILES= bin/tla bin/tla-gpg-check
pre-patch:
${MKDIR} ${WRKSRC}
-do-configure:
- cd ${WRKSRC} ; ../configure --prefix ${LOCALBASE} \
- --with-gnu-patch gpatch \
- --with-gnu-diff gdiff \
- --with-gnu-diff3 gdiff3 \
- --with-gnu-tar gtar
-
test:
cd ${WRKSRC} ; ${GMAKE} test
pre-install:
.if !defined(NOPORTDOCS)
- ${RM} -rf ${ORIGWRKSRC}/docs-tla/PLUGIN ${ORIGWRKSRC}/docs-tla/{arch} \
- ${ORIGWRKSRC}/docs-tla/.arch-ids
- cd ${ORIGWRKSRC}/docs-tla && ${FIND} . -type f -name '*.html' -exec ${ECHO_CMD} "%%DOCSDIR%%/{}" \; > ${PLIST}
- cd ${ORIGWRKSRC}/docs-tla && ${FIND} -d . -mindepth 1 -maxdepth 1 -type d -exec ${ECHO_CMD} "@dirrm %%DOCSDIR%%/{}" \; >> ${PLIST}
+ ${RM} -rf ${ORIGWRKSRC}/docs-tla/PLUGIN \
+ ${ORIGWRKSRC}/docs-tla/{arch} ${ORIGWRKSRC}/docs-tla/.arch-ids
+ cd ${ORIGWRKSRC}/docs-tla && ${FIND} . -type f -name '*.html' \
+ -exec ${ECHO_CMD} "%%DOCSDIR%%/{}" \; > ${PLIST}
+ cd ${ORIGWRKSRC}/docs-tla && ${FIND} -d . -mindepth 1 -maxdepth 1 \
+ -type d -exec ${ECHO_CMD} "@dirrm %%DOCSDIR%%/{}" \; >> ${PLIST}
${ECHO} @dirrm %%DOCSDIR%% >> ${PLIST}
.endif
@@ -60,7 +62,8 @@ do-install:
${INSTALL_SCRIPT} ${WRKDIR}/tla-gpg-check ${PREFIX}/bin
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
- cd ${ORIGWRKSRC}/docs-tla && ${FIND} . -name '*.html' | ${CPIO} -pdm -R ${SHAREOWN}:${SHAREGRP} ${DOCSDIR}
+ cd ${ORIGWRKSRC}/docs-tla && ${FIND} . -name '*.html' | \
+ ${CPIO} -pdm -R ${SHAREOWN}:${SHAREGRP} ${DOCSDIR}
${CHMOD} -R a=rX ${DOCSDIR}
.endif
diff --git a/devel/tla/pkg-descr b/devel/tla/pkg-descr
index 51a57af3d5f4..a97feaaba149 100644
--- a/devel/tla/pkg-descr
+++ b/devel/tla/pkg-descr
@@ -1,9 +1,8 @@
-Arch is a really nifty revision control system. It's "whole-tree
-changeset based" which means, roughly, that it can handle (with atomic
-commits) file and directory adds, deletes, and renames cleanly, and
-that it does branching simply and easily. Arch is also "distributed"
-which means, for example that you can make arch branches of your own
-from remote projects, even if you don't have write access to the
-revision control archives for those projects.
+Arch is a really nifty revision control system. It's "whole-tree changeset
+based" which means, roughly, that it can handle (with atomic commits) file
+and directory adds, deletes, and renames cleanly, and that it does branching
+simply and easily. Arch is also "distributed" which means, for example that
+you can make arch branches of your own from remote projects, even if you do
+not have write access to the revision control archives for those projects.
WWW: http://gnuarch.org/