aboutsummaryrefslogtreecommitdiff
path: root/devel/tpg
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-03-15 12:24:15 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-03-15 12:24:15 +0000
commit8fff289bbbe64a0ff502d177958707ddf1f025cc (patch)
treedb8295c6d45c8efee803b3f65842f1b48747e959 /devel/tpg
parent3045f57804c6623195171e83003bcaebd5476ca1 (diff)
downloadports-8fff289bbbe64a0ff502d177958707ddf1f025cc.tar.gz
ports-8fff289bbbe64a0ff502d177958707ddf1f025cc.zip
Notes
Diffstat (limited to 'devel/tpg')
-rw-r--r--devel/tpg/Makefile24
-rw-r--r--devel/tpg/distinfo1
-rw-r--r--devel/tpg/pkg-comment1
-rw-r--r--devel/tpg/pkg-descr15
-rw-r--r--devel/tpg/pkg-plist1
5 files changed, 42 insertions, 0 deletions
diff --git a/devel/tpg/Makefile b/devel/tpg/Makefile
new file mode 100644
index 000000000000..87116555ff8f
--- /dev/null
+++ b/devel/tpg/Makefile
@@ -0,0 +1,24 @@
+# ex:ts=8
+# Ports collection makefile for: tpg
+# Date created: Mar 15, 2002
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= tpg
+PORTVERSION= 0.1.6
+CATEGORIES= devel python
+MASTER_SITES= http://christophe.delord.free.fr/en/tpg/
+DISTNAME= ${PORTNAME:U}-${PORTVERSION}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= ports@FreeBSD.org
+
+USE_PYTHON= yes
+NO_BUILD= yes
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/TPG.py ${PREFIX}/bin/tpg
+
+.include <bsd.port.mk>
diff --git a/devel/tpg/distinfo b/devel/tpg/distinfo
new file mode 100644
index 000000000000..93d5292cdf09
--- /dev/null
+++ b/devel/tpg/distinfo
@@ -0,0 +1 @@
+MD5 (TPG-0.1.6.tgz) = f135ab1930aefcac12ab015fcf9ed14e
diff --git a/devel/tpg/pkg-comment b/devel/tpg/pkg-comment
new file mode 100644
index 000000000000..6dd2c45d827d
--- /dev/null
+++ b/devel/tpg/pkg-comment
@@ -0,0 +1 @@
+Toy Parser Generator -- A parser generator in Python
diff --git a/devel/tpg/pkg-descr b/devel/tpg/pkg-descr
new file mode 100644
index 000000000000..af5c43cb6b3e
--- /dev/null
+++ b/devel/tpg/pkg-descr
@@ -0,0 +1,15 @@
+Toy Parser Generator is a lexical and syntactic parser generator for Python.
+This generator was born from a simple statement: YACC is to complex to use
+in simple cases (calculators, configuration files, small programming
+languages, ...).
+
+TPG can very simply write parsers that are usefull for most every day needs
+(even if it can't make your coffee). With a very clear and simple syntax, you
+can write an attributed grammar that is translated into a recursive descendant
+parser. TPG generated code is very closed to the original grammar. This means
+that the parser works "like" the grammar. A grammar rule can be seen as a
+method of the parser class, symbols as method calls, attributes as method
+parameters and semantic values as return values. You can also add Python code
+directly into grammar rules and build abstract syntax trees while parsing.
+
+WWW: http://christophe.delord.free.fr/en/tpg/
diff --git a/devel/tpg/pkg-plist b/devel/tpg/pkg-plist
new file mode 100644
index 000000000000..d632c01768a1
--- /dev/null
+++ b/devel/tpg/pkg-plist
@@ -0,0 +1 @@
+bin/tpg