aboutsummaryrefslogtreecommitdiff
path: root/devel/valgrind
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-12-09 23:08:41 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-12-09 23:08:41 +0000
commit0b3795dfcfad7e4dfeae43c6876d92760d389b5a (patch)
tree5f95556bff3accad33262f01b895587ae099c6a8 /devel/valgrind
parentedc017dfd39e943503abefa10b66b2c1c0d79b27 (diff)
- Starting from some point after FreeBSD 5.2.1, valgrind did not terminate
correctly, but got stuck in state ``umtx''. This was mentioned on the lists and in kern/68992 [closed], but I was never able to fix the problem. On FreeBSD >= 502120, the kernel's and valgrind's definition of UMTX_CONTESTED flag were out of sync, which is why valgrind did not terminate on these systems. PR: ports/74903 Submitted by: Simon Barner <barner@gmx.de> (maintainer)
Notes
Notes: svn path=/head/; revision=123592
Diffstat (limited to 'devel/valgrind')
-rw-r--r--devel/valgrind/Makefile2
-rw-r--r--devel/valgrind/files/patch-coregrind-vg_proxylwp.c10
2 files changed, 11 insertions, 1 deletions
diff --git a/devel/valgrind/Makefile b/devel/valgrind/Makefile
index 835cc070fe5a..9e855f83fe58 100644
--- a/devel/valgrind/Makefile
+++ b/devel/valgrind/Makefile
@@ -7,7 +7,7 @@
PORTNAME= valgrind
PORTVERSION= 352
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel
MASTER_SITES= http://www.rabson.org/
DISTNAME= ${PORTNAME}-stable-${PORTVERSION}
diff --git a/devel/valgrind/files/patch-coregrind-vg_proxylwp.c b/devel/valgrind/files/patch-coregrind-vg_proxylwp.c
new file mode 100644
index 000000000000..21354e263c44
--- /dev/null
+++ b/devel/valgrind/files/patch-coregrind-vg_proxylwp.c
@@ -0,0 +1,10 @@
+--- coregrind/vg_proxylwp.c.orig Thu Dec 9 20:02:58 2004
++++ coregrind/vg_proxylwp.c Thu Dec 9 20:03:16 2004
+@@ -30,6 +30,7 @@
+
+
+ #include "vg_include.h"
++#include "vg_unsafe.h"
+
+ #ifndef UMTX_CONTESTED
+ # if __FreeBSD_version < 502120