aboutsummaryrefslogtreecommitdiff
path: root/devel/viewcvs/Makefile
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2000-07-03 00:34:20 +0000
committerWill Andrews <will@FreeBSD.org>2000-07-03 00:34:20 +0000
commitc45597ab5693c133ab9d87989ba6a0c061ecdaf6 (patch)
tree090680d06d67e571bad491c445b0cae2f1efbdcf /devel/viewcvs/Makefile
parent7acea3ead68a9697cec8853da095b08bc030c4bb (diff)
Notes
Diffstat (limited to 'devel/viewcvs/Makefile')
-rw-r--r--devel/viewcvs/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/devel/viewcvs/Makefile b/devel/viewcvs/Makefile
new file mode 100644
index 000000000000..c4278287de7a
--- /dev/null
+++ b/devel/viewcvs/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: groach
+# Date created: Sun 02 Jul 2000
+# Whom: will
+#
+# $FreeBSD$
+#
+
+PORTNAME= viewcvs
+PORTVERSION= 0.5
+CATEGORIES= devel python
+MASTER_SITES= http://www.lyra.org/viewcvs/
+
+MAINTAINER= ports@FreeBSD.org
+
+BUILD_DEPENDS= python:${PORTSDIR}/lang/python
+RUN_DEPENDS= python:${PORTSDIR}/lang/python
+
+NO_BUILD= yes
+
+pre-install:
+ ${PERL} -pi -e "s:/usr/local/viewcvs:${PREFIX}/share/viewcvs:g" ${WRKSRC}/viewcvs-install
+
+do-install:
+ (cd ${WRKSRC} && ${LOCALBASE}/bin/python ${WRKSRC}/viewcvs-install)
+
+post-install:
+ @${ECHO}
+ @${CAT} ${PKGMESSAGE} | ${SED} -e "s:%%PREFIX%%:${PREFIX}:g"
+ @${ECHO}
+
+.include <bsd.port.mk>