aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorJun Kuriyama <kuriyama@FreeBSD.org>2015-01-25 13:59:23 +0000
committerJun Kuriyama <kuriyama@FreeBSD.org>2015-01-25 13:59:23 +0000
commit03b53317fa2d1f3c787af6b56bbb6cea5726e74d (patch)
treea83c0759621dfe464c997ff68d2a9c454896ae84 /devel
parent3c9b46758936bcbdbd6286ee798c3440386623ec (diff)
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/go-slices/Makefile26
-rw-r--r--devel/go-slices/distinfo2
-rw-r--r--devel/go-slices/pkg-descr7
-rw-r--r--devel/go-slices/pkg-plist46
5 files changed, 82 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index c77f61527e5e..1193c2d85cfd 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -590,6 +590,7 @@
SUBDIR += go-pretty
SUBDIR += go-raw
SUBDIR += go-runewidth
+ SUBDIR += go-slices
SUBDIR += go-sql-driver
SUBDIR += go-termbox
SUBDIR += go-uuid
diff --git a/devel/go-slices/Makefile b/devel/go-slices/Makefile
new file mode 100644
index 000000000000..d5dde701a80a
--- /dev/null
+++ b/devel/go-slices/Makefile
@@ -0,0 +1,26 @@
+# $FreeBSD$
+
+PORTNAME= slices
+PORTVERSION= 0.0.0.20130325
+CATEGORIES= devel
+MASTER_SITES= GH GHC
+PKGNAMEPREFIX= go-
+
+MAINTAINER= kuriyama@FreeBSD.org
+COMMENT= Go library for slice-based datatypes
+
+#LICENSE= MIT based, with no-evli clause
+
+BUILD_DEPENDS= go-raw>0:${PORTSDIR}/devel/go-raw
+
+USE_GITHUB= yes
+GH_ACCOUNT= feyeleanor
+GH_PROJECT= ${PORTNAME}
+GH_TAGNAME= ${GH_COMMIT}
+GH_COMMIT= bb44bb2
+
+GO_PKGNAME= github.com/${GH_ACCOUNT}/${GH_PROJECT}
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/lang/go/files/bsd.go.mk"
+.include <bsd.port.post.mk>
diff --git a/devel/go-slices/distinfo b/devel/go-slices/distinfo
new file mode 100644
index 000000000000..00ba39de66f0
--- /dev/null
+++ b/devel/go-slices/distinfo
@@ -0,0 +1,2 @@
+SHA256 (slices-0.0.0.20130325.tar.gz) = fff3c97ab18a7e06bfffc4141cebab1abd707444fae66e6af8e139d2ae6f0ec6
+SIZE (slices-0.0.0.20130325.tar.gz) = 106369
diff --git a/devel/go-slices/pkg-descr b/devel/go-slices/pkg-descr
new file mode 100644
index 000000000000..9978e4e1b9ca
--- /dev/null
+++ b/devel/go-slices/pkg-descr
@@ -0,0 +1,7 @@
+The Slices package provides implementations of slice-based datatypes
+for all of Go's basic types, as well as two separate implementations
+for handling slices in the context of reflection values. Currently
+there's no documentation but the extensive test suite includes
+numerous examples of how to use slices to solve common tasks.
+
+WWW: https://github.com/feyeleanor/slices/
diff --git a/devel/go-slices/pkg-plist b/devel/go-slices/pkg-plist
new file mode 100644
index 000000000000..4d7b5c061b3b
--- /dev/null
+++ b/devel/go-slices/pkg-plist
@@ -0,0 +1,46 @@
+%%GO_LIBDIR%%/%%GO_PKGNAME%%.a
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/LICENSE
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/README
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/complex128.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/complex128_test.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/complex64.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/complex64_benchmark_test.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/complex64_test.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/error.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/error_test.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/float32.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/float32_test.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/float64.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/float64_test.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/int.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/int16.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/int16_test.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/int32.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/int32_test.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/int64.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/int64_test.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/int8.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/int8_test.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/int_test.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/reflected.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/reflected_test.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/slice.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/slice_test.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/slices.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/slices_test.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/string.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/string_test.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/uint.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/uint16.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/uint16_test.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/uint32.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/uint32_test.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/uint64.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/uint64_test.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/uint8.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/uint8_test.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/uint_test.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/uintptr.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/uintptr_test.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/value.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/value_test.go