aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2013-07-13 21:30:51 +0000
committerSteve Wills <swills@FreeBSD.org>2013-07-13 21:30:51 +0000
commit10fcf4d003b55d4757df7aae1ff876b1a7810aa6 (patch)
tree8309fde6416461fa0103581d120d2350494c8c59 /devel
parentc860313ec2fe4a35c51bd1acfe6be8d4594b8bee (diff)
- Update rubygem-sequel to 4.0.0
- Create sequel3 port for rubygem-larch
Notes
Notes: svn path=/head/; revision=322972
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/rubygem-sequel/Makefile2
-rw-r--r--devel/rubygem-sequel/distinfo4
-rw-r--r--devel/rubygem-sequel3/Makefile23
-rw-r--r--devel/rubygem-sequel3/distinfo2
-rw-r--r--devel/rubygem-sequel3/pkg-descr14
6 files changed, 43 insertions, 3 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 5f51eaaea58f..720388ee076f 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4210,6 +4210,7 @@
SUBDIR += rubygem-safe_yaml
SUBDIR += rubygem-sdl
SUBDIR += rubygem-sequel
+ SUBDIR += rubygem-sequel3
SUBDIR += rubygem-sexp_processor
SUBDIR += rubygem-shoulda
SUBDIR += rubygem-shoulda-context
diff --git a/devel/rubygem-sequel/Makefile b/devel/rubygem-sequel/Makefile
index ad77b1eb4d00..3cb6d22eb908 100644
--- a/devel/rubygem-sequel/Makefile
+++ b/devel/rubygem-sequel/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= sequel
-PORTVERSION= 3.48.0
+PORTVERSION= 4.0.0
CATEGORIES= devel rubygems
MASTER_SITES= RG
diff --git a/devel/rubygem-sequel/distinfo b/devel/rubygem-sequel/distinfo
index 3f260011898a..7b04615d0fa5 100644
--- a/devel/rubygem-sequel/distinfo
+++ b/devel/rubygem-sequel/distinfo
@@ -1,2 +1,2 @@
-SHA256 (rubygem/sequel-3.48.0.gem) = 5ef9ef0b85dc686a610f55ffd18e0b3a432a1155f48ddec9894e5a01b0986360
-SIZE (rubygem/sequel-3.48.0.gem) = 1160192
+SHA256 (rubygem/sequel-4.0.0.gem) = 756b52c836ef0200f5fd7dd0beff69ce10a0ccab5b7bf656c7e996d036a8789e
+SIZE (rubygem/sequel-4.0.0.gem) = 1146368
diff --git a/devel/rubygem-sequel3/Makefile b/devel/rubygem-sequel3/Makefile
new file mode 100644
index 000000000000..67dfc66089ff
--- /dev/null
+++ b/devel/rubygem-sequel3/Makefile
@@ -0,0 +1,23 @@
+# Created by: Wen Heping<wenheping@gmail.com>
+# $FreeBSD$
+
+# legacy for rubygem-larch
+
+PORTNAME= sequel
+PORTVERSION= 3.48.0
+CATEGORIES= devel rubygems
+MASTER_SITES= RG
+
+MAINTAINER= ruby@FreeBSD.org
+COMMENT= The Database Toolkit for Ruby
+
+PORTSCOUT= limit:^3
+NO_LATEST_LINK= yes
+
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+RUBYGEM_AUTOPLIST=yes
+
+PLIST_FILES= bin/sequel
+
+.include <bsd.port.mk>
diff --git a/devel/rubygem-sequel3/distinfo b/devel/rubygem-sequel3/distinfo
new file mode 100644
index 000000000000..3f260011898a
--- /dev/null
+++ b/devel/rubygem-sequel3/distinfo
@@ -0,0 +1,2 @@
+SHA256 (rubygem/sequel-3.48.0.gem) = 5ef9ef0b85dc686a610f55ffd18e0b3a432a1155f48ddec9894e5a01b0986360
+SIZE (rubygem/sequel-3.48.0.gem) = 1160192
diff --git a/devel/rubygem-sequel3/pkg-descr b/devel/rubygem-sequel3/pkg-descr
new file mode 100644
index 000000000000..0d4915dbe461
--- /dev/null
+++ b/devel/rubygem-sequel3/pkg-descr
@@ -0,0 +1,14 @@
+Sequel is a database toolkit for Ruby.
+ * Sequel provides thread safety, connection pooling and a concise
+ DSL for constructing database queries and table schemas.
+ * Sequel also includes a lightweight but comprehensive ORM layer for
+ mapping records to Ruby objects and handling associated records.
+ * Sequel supports advanced database features such as prepared
+ statements, bound variables, master/slave configurations, and database
+ sharding.
+ * Sequel makes it easy to deal with multiple records without having
+ to break your teeth on SQL.
+ * Sequel currently has adapters for ADO, DB2, DBI, Informix, JDBC,
+ MySQL, ODBC, OpenBase, Oracle, PostgreSQL and SQLite3.
+
+WWW: http://sequel.rubyforge.org