aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2011-08-10 12:13:56 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2011-08-10 12:13:56 +0000
commit24e2dd9b5ba06440e1126de6255f167590ae63d8 (patch)
treeb960228e22f2ef01f891913135def56fc6391b9d /devel
parent32a2dc1df12427cf1fb554bf975b9293ce02b6d7 (diff)
downloadports-24e2dd9b5ba06440e1126de6255f167590ae63d8.tar.gz
ports-24e2dd9b5ba06440e1126de6255f167590ae63d8.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Test-LeakTrace/Makefile30
-rw-r--r--devel/p5-Test-LeakTrace/distinfo2
-rw-r--r--devel/p5-Test-LeakTrace/pkg-descr11
-rw-r--r--devel/p5-Test-LeakTrace/pkg-plist10
5 files changed, 54 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 4ca8f10550ea..671684888fef 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -2345,6 +2345,7 @@
SUBDIR += p5-Test-Inter
SUBDIR += p5-Test-JSON
SUBDIR += p5-Test-Kwalitee
+ SUBDIR += p5-Test-LeakTrace
SUBDIR += p5-Test-LectroTest
SUBDIR += p5-Test-LoadAllModules
SUBDIR += p5-Test-Log4perl
diff --git a/devel/p5-Test-LeakTrace/Makefile b/devel/p5-Test-LeakTrace/Makefile
new file mode 100644
index 000000000000..963d55b4b6bb
--- /dev/null
+++ b/devel/p5-Test-LeakTrace/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: p5-Test-LeakTrace
+# Date created: 2011-08-01
+# Whom: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Test-LeakTrace
+PORTVERSION= 0.13
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Traces memory leaks
+
+PERL_CONFIGURE= 5.8.3+
+
+MAN3= Test::LeakTrace.3 \
+ Test::LeakTrace::JA.3 \
+ Test::LeakTrace::Script.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500808
+RUN_DEPENDS+= p5-Test-Simple>=0.62:${PORTSDIR}/devel/p5-Test-Simple
+TEST_DEPENDS+= p5-Test-Simple>=0.62:${PORTSDIR}/devel/p5-Test-Simple
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Test-LeakTrace/distinfo b/devel/p5-Test-LeakTrace/distinfo
new file mode 100644
index 000000000000..1b45c62aa314
--- /dev/null
+++ b/devel/p5-Test-LeakTrace/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Test-LeakTrace-0.13.tar.gz) = 5dfd39d409c8fe872d1b17005e3a8e048d5d9bb91201643d0c57285785c9ab4f
+SIZE (Test-LeakTrace-0.13.tar.gz) = 49022
diff --git a/devel/p5-Test-LeakTrace/pkg-descr b/devel/p5-Test-LeakTrace/pkg-descr
new file mode 100644
index 000000000000..c1a631d66641
--- /dev/null
+++ b/devel/p5-Test-LeakTrace/pkg-descr
@@ -0,0 +1,11 @@
+Test::LeakTrace provides several functions that trace memory leaks. This module
+scans arenas, the memory allocation system, so it can detect any leaked SVs in
+given blocks.
+
+Leaked SVs are SVs which are not released after the end of the scope they have
+been created. These SVs include global variables and internal caches. For
+example, if you call a method in a tracing block, perl might prepare a cache for
+the method. Thus, to trace true leaks, no_leaks_ok() and leaks_cmp_ok() executes
+a block more than once.
+
+WWW: http://search.cpan.org/dist/Test-LeakTrace/
diff --git a/devel/p5-Test-LeakTrace/pkg-plist b/devel/p5-Test-LeakTrace/pkg-plist
new file mode 100644
index 000000000000..14e38b881196
--- /dev/null
+++ b/devel/p5-Test-LeakTrace/pkg-plist
@@ -0,0 +1,10 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/Test/LeakTrace.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/Test/LeakTrace/JA.pod
+%%SITE_PERL%%/%%PERL_ARCH%%/Test/LeakTrace/Script.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Test/LeakTrace/.packlist
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Test/LeakTrace/LeakTrace.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Test/LeakTrace/LeakTrace.so
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Test/LeakTrace
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Test
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/Test/LeakTrace
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/Test