aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2015-03-21 19:20:33 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2015-03-21 19:20:33 +0000
commit25593399fc0a494a543620f1046cfdb427d6c2a2 (patch)
treeb1879d741fe36e672987486c29d74f57e6c81257 /devel
parent09495a42246140b7b9fa1c39bdc831336e888b65 (diff)
downloadports-25593399fc0a494a543620f1046cfdb427d6c2a2.tar.gz
ports-25593399fc0a494a543620f1046cfdb427d6c2a2.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/glog/Makefile10
-rw-r--r--devel/glog/distinfo4
-rw-r--r--devel/glog/files/patch-src-glog-stl_logging.h.in (renamed from devel/glog/files/patch-stl_logging.h.in)26
-rw-r--r--devel/glog/files/patch-src-googletest.h10
-rw-r--r--devel/glog/files/patch-src-logging_unittest.cc10
-rw-r--r--devel/glog/files/patch-src-stl_logging_unittest.cc10
-rw-r--r--devel/glog/pkg-descr2
7 files changed, 51 insertions, 21 deletions
diff --git a/devel/glog/Makefile b/devel/glog/Makefile
index 90997ece610b..372eee2e6a67 100644
--- a/devel/glog/Makefile
+++ b/devel/glog/Makefile
@@ -2,10 +2,8 @@
# $FreeBSD$
PORTNAME= glog
-PORTVERSION= 0.3.3
-PORTREVISION= 3
+PORTVERSION= 0.3.4
CATEGORIES= devel
-MASTER_SITES= GOOGLE_CODE
MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Library of C++ classes for flexible logging
@@ -22,10 +20,14 @@ INSTALL_TARGET= install-strip
LDFLAGS+= -L${LOCALBASE}/lib -lexecinfo
USE_LDCONFIG= yes
USES= execinfo libtool pathfix
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
PORTDOCS= *
-PROJECTHOST= google-glog
+GH_ACCOUNT= google
+GH_PROJECT= ${PORTNAME}
+GH_TAGNAME= v${PORTVERSION}
+USE_GITHUB= yes
post-patch:
@${REINPLACE_CMD} -e '/^docdir = / s| = .*| = ${DOCSDIR}|' ${WRKSRC}/Makefile.in
diff --git a/devel/glog/distinfo b/devel/glog/distinfo
index 802ec0dcbf17..860d6d5e7c30 100644
--- a/devel/glog/distinfo
+++ b/devel/glog/distinfo
@@ -1,2 +1,2 @@
-SHA256 (glog-0.3.3.tar.gz) = fbf90c2285ba0561db7a40f8a4eefb9aa963e7d399bd450363e959929fe849d0
-SIZE (glog-0.3.3.tar.gz) = 509676
+SHA256 (google-glog-0.3.4-v0.3.4_GH0.tar.gz) = ce99d58dce74458f7656a68935d7a0c048fa7b4626566a71b7f4e545920ceb10
+SIZE (google-glog-0.3.4-v0.3.4_GH0.tar.gz) = 522508
diff --git a/devel/glog/files/patch-stl_logging.h.in b/devel/glog/files/patch-src-glog-stl_logging.h.in
index d3449a748efe..9807edb350cc 100644
--- a/devel/glog/files/patch-stl_logging.h.in
+++ b/devel/glog/files/patch-src-glog-stl_logging.h.in
@@ -1,27 +1,25 @@
---- src/glog/stl_logging.h.in.orig 2013-01-09 21:57:36.000000000 +0800
-+++ src/glog/stl_logging.h.in 2013-09-20 19:39:39.000000000 +0800
-@@ -53,8 +53,12 @@
- #ifdef __GNUC__
- # include <ext/hash_set>
- # include <ext/hash_map>
-+#ifdef _LIBCPP_VERSION
-+# include <forward_list>
-+#else
+--- src/glog/stl_logging.h.in.orig 2015-03-11 12:02:27.000000000 +0800
++++ src/glog/stl_logging.h.in 2015-03-22 01:13:41.132580961 +0800
+@@ -76,6 +76,9 @@
+ #ifdef GLOG_STL_LOGGING_FOR_EXT_SLIST
# include <ext/slist>
#endif
++#ifdef GLOG_STL_LOGGING_FOR_FORWARD_LIST
++# include <forward_list>
+#endif
// Forward declare these two, and define them after all the container streams
// operators so that we can recurse from pair -> container -> container -> pair
-@@ -81,8 +85,12 @@ OUTPUT_TWO_ARG_CONTAINER(std::vector)
+@@ -101,9 +104,13 @@
+ OUTPUT_TWO_ARG_CONTAINER(std::vector)
OUTPUT_TWO_ARG_CONTAINER(std::deque)
OUTPUT_TWO_ARG_CONTAINER(std::list)
- #ifdef __GNUC__
-+#ifdef _LIBCPP_VERSION
-+OUTPUT_TWO_ARG_CONTAINER(std::forward_list)
-+#else
++
+ #ifdef GLOG_STL_LOGGING_FOR_EXT_SLIST
OUTPUT_TWO_ARG_CONTAINER(__gnu_cxx::slist)
#endif
++#ifdef GLOG_STL_LOGGING_FOR_FORWARD_LIST
++OUTPUT_TWO_ARG_CONTAINER(std::forward_list)
+#endif
#undef OUTPUT_TWO_ARG_CONTAINER
diff --git a/devel/glog/files/patch-src-googletest.h b/devel/glog/files/patch-src-googletest.h
new file mode 100644
index 000000000000..57cb1a5e5988
--- /dev/null
+++ b/devel/glog/files/patch-src-googletest.h
@@ -0,0 +1,10 @@
+--- src/googletest.h.orig 2015-03-11 12:02:27.000000000 +0800
++++ src/googletest.h 2015-03-22 00:56:38.711647313 +0800
+@@ -58,6 +58,7 @@
+
+ #include "base/commandlineflags.h"
+
++using namespace gflags;
+ using std::map;
+ using std::string;
+ using std::vector;
diff --git a/devel/glog/files/patch-src-logging_unittest.cc b/devel/glog/files/patch-src-logging_unittest.cc
new file mode 100644
index 000000000000..9001ab567482
--- /dev/null
+++ b/devel/glog/files/patch-src-logging_unittest.cc
@@ -0,0 +1,10 @@
+--- src/logging_unittest.cc.orig 2015-03-11 12:02:27.000000000 +0800
++++ src/logging_unittest.cc 2015-03-22 00:54:39.798664493 +0800
+@@ -78,6 +78,7 @@
+ #endif
+
+ using namespace std;
++using namespace gflags;
+ using namespace GOOGLE_NAMESPACE;
+
+ // Some non-advertised functions that we want to test or use.
diff --git a/devel/glog/files/patch-src-stl_logging_unittest.cc b/devel/glog/files/patch-src-stl_logging_unittest.cc
new file mode 100644
index 000000000000..2e6f60b51f14
--- /dev/null
+++ b/devel/glog/files/patch-src-stl_logging_unittest.cc
@@ -0,0 +1,10 @@
+--- src/stl_logging_unittest.cc.orig 2015-03-11 12:02:27.000000000 +0800
++++ src/stl_logging_unittest.cc 2015-03-22 01:03:23.871621079 +0800
+@@ -41,6 +41,7 @@
+ // C++0x isn't enabled by default in GCC and libc++ does not have
+ // non-standard ext/* and tr1/unordered_*.
+ # if defined(_LIBCPP_VERSION)
++# define GLOG_STL_LOGGING_FOR_FORWARD_LIST
+ # define GLOG_STL_LOGGING_FOR_UNORDERED
+ # else
+ # define GLOG_STL_LOGGING_FOR_EXT_HASH
diff --git a/devel/glog/pkg-descr b/devel/glog/pkg-descr
index a2026b61ef02..df6e288737de 100644
--- a/devel/glog/pkg-descr
+++ b/devel/glog/pkg-descr
@@ -3,4 +3,4 @@ The glog library implements application-level logging.
This library provides logging APIs based on C++-style streams
and various helper macros.
-WWW: http://code.google.com/p/google-glog/
+WWW: https://github.com/google/glog