aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2019-04-28 20:23:59 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2019-04-28 20:23:59 +0000
commit27852e60b7d7673d3423ae842e62762ea3d837a8 (patch)
treebc93ef71bc9b0a0b84ba668f512623fa85877ba2 /devel
parent0df249f8bb97534e995a8d759d5f6b70d45880f7 (diff)
downloadports-27852e60b7d7673d3423ae842e62762ea3d837a8.tar.gz
ports-27852e60b7d7673d3423ae842e62762ea3d837a8.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/golint/Makefile33
-rw-r--r--devel/golint/distinfo5
-rw-r--r--devel/golint/pkg-descr12
4 files changed, 51 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index d50c4b896f2a..8150117102e4 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -841,6 +841,7 @@
SUBDIR += goffice010
SUBDIR += gogland-eap
SUBDIR += gogs
+ SUBDIR += golint
SUBDIR += google-gdata
SUBDIR += google-perftools
SUBDIR += google-styleguide
diff --git a/devel/golint/Makefile b/devel/golint/Makefile
new file mode 100644
index 000000000000..38f8e2a43463
--- /dev/null
+++ b/devel/golint/Makefile
@@ -0,0 +1,33 @@
+# $FreeBSD$
+
+PORTNAME= golint
+PORTVERSION= g20190409
+CATEGORIES= devel
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Linter for Go source code
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/${GO_SUBDIR}/LICENSE
+
+BUILD_DEPENDS= go:lang/go
+
+USE_GITHUB= nodefault
+GH_ACCOUNT= golang
+GH_PROJECT= lint
+GH_TAGNAME= 959b441
+GH_TUPLE= golang:lint:959b441:main/src/golang.org/x/lint \
+ golang:tools:e65039e:golang_tools/src/golang.org/x/tools
+
+GO_SUBDIR= src/golang.org/x/lint
+
+PLIST_FILES= bin/golint
+
+do-build:
+ @cd ${WRKSRC}/${GO_SUBDIR}/golint && \
+ ${SETENV} ${MAKE_ENV} GOPATH=${WRKSRC} go build
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${GO_SUBDIR}/${PORTNAME}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/
+
+.include <bsd.port.mk>
diff --git a/devel/golint/distinfo b/devel/golint/distinfo
new file mode 100644
index 000000000000..c2986571f6c5
--- /dev/null
+++ b/devel/golint/distinfo
@@ -0,0 +1,5 @@
+TIMESTAMP = 1556481010
+SHA256 (golang-lint-959b441_GH0.tar.gz) = df0c8369150fcf23d5a79851293c232e3f79c931bfcff59460b0298b774c0a12
+SIZE (golang-lint-959b441_GH0.tar.gz) = 32982
+SHA256 (golang-tools-e65039e_GH0.tar.gz) = 29fd59183877a438012e2ec6d2875f4403b0f4b58aa8a793372edc9df3a3a20c
+SIZE (golang-tools-e65039e_GH0.tar.gz) = 2681790
diff --git a/devel/golint/pkg-descr b/devel/golint/pkg-descr
new file mode 100644
index 000000000000..79c2045e133b
--- /dev/null
+++ b/devel/golint/pkg-descr
@@ -0,0 +1,12 @@
+A linter for Go source code.
+
+Invoke golint with one or more filenames, directories, or packages named by its
+import path. Golint uses the same import path syntax as the go command and
+therefore also supports relative import paths like ./.... Additionally the ...
+wildcard can be used as suffix on relative and absolute file paths to recurse
+into them.
+
+The output of this tool is a list of suggestions in Vim quickfix format, which
+is accepted by lots of different editors.
+
+WWW: https://github.com/golang/lint/