aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorAaron Dalton <aaron@FreeBSD.org>2006-06-23 02:20:41 +0000
committerAaron Dalton <aaron@FreeBSD.org>2006-06-23 02:20:41 +0000
commit298a438a1b4f95d1d4f40e64a1260a63f6a5f6e3 (patch)
tree17c696c55999f3845ef91d285d0f2ccf7eaeddb2 /devel
parent141f6c4cfc204ee9a2880bf6415189255473b446 (diff)
downloadports-298a438a1b4f95d1d4f40e64a1260a63f6a5f6e3.tar.gz
ports-298a438a1b4f95d1d4f40e64a1260a63f6a5f6e3.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Data-Postponed/Makefile34
-rw-r--r--devel/p5-Data-Postponed/distinfo3
-rw-r--r--devel/p5-Data-Postponed/pkg-descr15
-rw-r--r--devel/p5-Data-Postponed/pkg-plist14
5 files changed, 67 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 8f6d5a89569a..99df2b649e6a 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -865,6 +865,7 @@
SUBDIR += p5-Data-Hierarchy
SUBDIR += p5-Data-Lazy
SUBDIR += p5-Data-OptList
+ SUBDIR += p5-Data-Postponed
SUBDIR += p5-Data-Properties
SUBDIR += p5-Data-Random
SUBDIR += p5-Data-Serializer
diff --git a/devel/p5-Data-Postponed/Makefile b/devel/p5-Data-Postponed/Makefile
new file mode 100644
index 000000000000..bfc53c04c2f5
--- /dev/null
+++ b/devel/p5-Data-Postponed/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: p5-Data-Postponed
+# Date created: 22 Jun 2006
+# Whom: Aaron Dalton <aaron@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Data-Postponed
+PORTVERSION= 0.20
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Data
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= aaron@FreeBSD.org
+COMMENT= Delay the evaluation of expressions to allow changes to variables
+
+BUILD_DEPENDS= p5-Scalar-List-Utils>0:${PORTSDIR}/lang/p5-Scalar-List-Utils
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+MAN3= Data::Postponed.3 \
+ Data::Postponed::Forever.3 \
+ Data::Postponed::Once.3 \
+ Data::Postponed::OnceOnly.3
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600 # due to 'make test' failures
+IGNORE= requires at least Perl 5.6. Please install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Data-Postponed/distinfo b/devel/p5-Data-Postponed/distinfo
new file mode 100644
index 000000000000..1212e8e6b9c6
--- /dev/null
+++ b/devel/p5-Data-Postponed/distinfo
@@ -0,0 +1,3 @@
+MD5 (Data-Postponed-0.20.tar.gz) = fac6c27b9bc9e435419eb50dd98a4b73
+SHA256 (Data-Postponed-0.20.tar.gz) = 96ca6a2325bfa1c6ad135ece92c9e24e30e713a7b9ba4d857457e462cd850d8c
+SIZE (Data-Postponed-0.20.tar.gz) = 22467
diff --git a/devel/p5-Data-Postponed/pkg-descr b/devel/p5-Data-Postponed/pkg-descr
new file mode 100644
index 000000000000..4ea04102b367
--- /dev/null
+++ b/devel/p5-Data-Postponed/pkg-descr
@@ -0,0 +1,15 @@
+This module allows you to delay the computation of values, usually so you
+can change your mind about the returned value. Its a sort of time travel.
+
+The values returned by this module are overloaded objects which can be
+operated on like numbers, strings, or booleans but aren't actually made
+"real" until you use them in some context that requires that they be
+computed first.
+
+As an aide to debugging and to prevent time paradoxes, the default
+postpone() function's effect is that once a value has been computed, it
+ceases to be overloaded and all of the input variables to it are turned
+read only.
+
+WWW: http://search.cpan.org/dist/Data-Postponed
+Author: Joshua ben Jore <jjore@cpan.org>
diff --git a/devel/p5-Data-Postponed/pkg-plist b/devel/p5-Data-Postponed/pkg-plist
new file mode 100644
index 000000000000..78c0a30e80e1
--- /dev/null
+++ b/devel/p5-Data-Postponed/pkg-plist
@@ -0,0 +1,14 @@
+%%SITE_PERL%%/Data/Postponed.pm
+%%SITE_PERL%%/Data/Postponed/Forever.pm
+%%SITE_PERL%%/Data/Postponed/Once.pm
+%%SITE_PERL%%/Data/Postponed/OnceOnly.pm
+%%SITE_PERL%%/Data/Postponed/Util/NoLonger.pm
+%%SITE_PERL%%/Data/Postponed/Util/ReadOnly/Array.pm
+%%SITE_PERL%%/Data/Postponed/Util/ReadOnly/Scalar.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Data/Postponed/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Data/Postponed
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Data
+@dirrm %%SITE_PERL%%/Data/Postponed/Util/ReadOnly
+@dirrm %%SITE_PERL%%/Data/Postponed/Util
+@dirrm %%SITE_PERL%%/Data/Postponed
+@dirrmtry %%SITE_PERL%%/Data