aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorPeter Pentchev <roam@FreeBSD.org>2001-04-18 17:36:11 +0000
committerPeter Pentchev <roam@FreeBSD.org>2001-04-18 17:36:11 +0000
commit2f094db440cf8bad2637747785f17aa84e67d2ea (patch)
tree6b96907c6e6dea8ed9f0ee3018921c4779a8f854 /devel
parentcec16eb0991781c8262ef52e6c9afdb4019ee433 (diff)
downloadports-2f094db440cf8bad2637747785f17aa84e67d2ea.tar.gz
ports-2f094db440cf8bad2637747785f17aa84e67d2ea.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/libelf/Makefile26
-rw-r--r--devel/libelf/distinfo1
-rw-r--r--devel/libelf/files/patch-configure20
-rw-r--r--devel/libelf/pkg-comment1
-rw-r--r--devel/libelf/pkg-descr9
-rw-r--r--devel/libelf/pkg-plist9
7 files changed, 67 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 78fba4d02cd2..c901f9ccb998 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -180,6 +180,7 @@
SUBDIR += libcoro
SUBDIR += libdlmalloc
SUBDIR += libdsp
+ SUBDIR += libelf
SUBDIR += libffi
SUBDIR += libg++
SUBDIR += libgetline
diff --git a/devel/libelf/Makefile b/devel/libelf/Makefile
new file mode 100644
index 000000000000..0cff46def638
--- /dev/null
+++ b/devel/libelf/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: libelf
+# Date created: 18 Apr 2001
+# Whom: roam@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= libelf
+PORTVERSION= 0.7.0
+CATEGORIES= devel
+MASTER_SITES= ${MASTER_SITE_SUNSITE} \
+ http://www.stud.uni-hannover.de/~michael/software/ \
+ ftp://ftp.stud.uni-hannover.de/pub/users/michael/
+MASTER_SITE_SUBDIR= libs .
+
+MAINTAINER= roam@FreeBSD.org
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS+= --enable-shared
+INSTALLS_SHLIB= yes
+PLIST_SUB+= LIBVER=${PORTVERSION} \
+ LIBVER_SHORT=${PORTVERSION:R}
+
+NOMAN= defined
+
+.include <bsd.port.mk>
diff --git a/devel/libelf/distinfo b/devel/libelf/distinfo
new file mode 100644
index 000000000000..8d2649df820b
--- /dev/null
+++ b/devel/libelf/distinfo
@@ -0,0 +1 @@
+MD5 (libelf-0.7.0.tar.gz) = 0a831d024d42cf2dcb94f696452219a6
diff --git a/devel/libelf/files/patch-configure b/devel/libelf/files/patch-configure
new file mode 100644
index 000000000000..1489b14b900a
--- /dev/null
+++ b/devel/libelf/files/patch-configure
@@ -0,0 +1,20 @@
+--- configure Wed Apr 18 13:20:42 2001
++++ configure Wed Apr 18 13:20:56 2001
+@@ -1038,7 +1038,7 @@
+
+ fi
+
+-for ac_hdr in unistd.h elf.h sys/elf.h
++for ac_hdr in unistd.h sys/elf.h
+ do
+ ac_safe=`echo "$ac_hdr" | sed 'y%./+-%__p_%'`
+ echo $ac_n "checking for $ac_hdr""... $ac_c" 1>&6
+@@ -2692,7 +2692,7 @@
+ fi
+
+ case "$host" in
+- *-linux*)
++ *-linux*|*-freebsd*)
+ if test "$GCC" = yes; then
+
+
diff --git a/devel/libelf/pkg-comment b/devel/libelf/pkg-comment
new file mode 100644
index 000000000000..445e91e8976d
--- /dev/null
+++ b/devel/libelf/pkg-comment
@@ -0,0 +1 @@
+A public ELF file access library
diff --git a/devel/libelf/pkg-descr b/devel/libelf/pkg-descr
new file mode 100644
index 000000000000..b2e84fab5bd6
--- /dev/null
+++ b/devel/libelf/pkg-descr
@@ -0,0 +1,9 @@
+From the libelf README file:
+
+ This is the public release of libelf-0.7.0, a free ELF object
+ file access library. If you have problems with applications
+ that use libelf and work with the commercial (SVR4, Solaris)
+ version but not with this one, please contact me.
+
+WWW: http://www.stud.uni-hannover.de/~michael/software/
+Author: Michael Riepe <michael@stud.uni-hannover.de>
diff --git a/devel/libelf/pkg-plist b/devel/libelf/pkg-plist
new file mode 100644
index 000000000000..0ff3652314f1
--- /dev/null
+++ b/devel/libelf/pkg-plist
@@ -0,0 +1,9 @@
+include/libelf/libelf.h
+include/libelf/nlist.h
+include/libelf/sys_elf.h
+include/libelf/elf_repl.h
+lib/libelf.a
+lib/libelf.so
+lib/libelf.so.%%LIBVER_SHORT%%
+lib/libelf.so.%%LIBVER%%
+@dirrm include/libelf