aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorJun Kuriyama <kuriyama@FreeBSD.org>2009-03-17 14:53:05 +0000
committerJun Kuriyama <kuriyama@FreeBSD.org>2009-03-17 14:53:05 +0000
commit2f224ec5293eced2cb4f8a1ecba5229d7590699b (patch)
tree9f17727986f617bfa904e218dd8697f64a0fa56a /devel
parent8e81eb9b4242c0912e092364c9229300014dc8af (diff)
downloadports-2f224ec5293eced2cb4f8a1ecba5229d7590699b.tar.gz
ports-2f224ec5293eced2cb4f8a1ecba5229d7590699b.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Test-Declare/Makefile28
-rw-r--r--devel/p5-Test-Declare/distinfo3
-rw-r--r--devel/p5-Test-Declare/pkg-descr4
-rw-r--r--devel/p5-Test-Declare/pkg-plist5
5 files changed, 41 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 4b5951f255a8..0eeded2b86d9 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1829,6 +1829,7 @@
SUBDIR += p5-Test-Compile
SUBDIR += p5-Test-Data
SUBDIR += p5-Test-Debugger
+ SUBDIR += p5-Test-Declare
SUBDIR += p5-Test-Deep
SUBDIR += p5-Test-Dependencies
SUBDIR += p5-Test-Differences
diff --git a/devel/p5-Test-Declare/Makefile b/devel/p5-Test-Declare/Makefile
new file mode 100644
index 000000000000..c2cbef3d83d7
--- /dev/null
+++ b/devel/p5-Test-Declare/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: Test::Declare
+# Date created: 17 Mar 2009
+# Whom: Jun Kuriyama <kuriyama@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Test-Declare
+PORTVERSION= 0.03
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= kuriyama@FreeBSD.org
+COMMENT= Perl extension for declarative testing
+
+RUN_DEPENDS= \
+ p5-IO-stringy>=0:${PORTSDIR}/devel/p5-IO-stringy \
+ p5-PPI>0:${PORTSDIR}/textproc/p5-PPI \
+ p5-Test-Deep>0:${PORTSDIR}/devel/p5-Test-Deep \
+ p5-Test-Exception>0:${PORTSDIR}/devel/p5-Test-Exception
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Test::Declare.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Test-Declare/distinfo b/devel/p5-Test-Declare/distinfo
new file mode 100644
index 000000000000..5b705b0d7564
--- /dev/null
+++ b/devel/p5-Test-Declare/distinfo
@@ -0,0 +1,3 @@
+MD5 (Test-Declare-0.03.tar.gz) = e6694417a6d6497297e2a0935a080d9e
+SHA256 (Test-Declare-0.03.tar.gz) = 1cd040d271513670ac118a2afcdeb3449a971ad5bfdbb1c62ed453f70716ee06
+SIZE (Test-Declare-0.03.tar.gz) = 43870
diff --git a/devel/p5-Test-Declare/pkg-descr b/devel/p5-Test-Declare/pkg-descr
new file mode 100644
index 000000000000..26bacc4fd506
--- /dev/null
+++ b/devel/p5-Test-Declare/pkg-descr
@@ -0,0 +1,4 @@
+Test::More and Test::Exception and Test::Deep wrapper module for
+declarative testing.
+
+WWW: http://search.cpan.org/dist/Test-Declare/
diff --git a/devel/p5-Test-Declare/pkg-plist b/devel/p5-Test-Declare/pkg-plist
new file mode 100644
index 000000000000..240f750c5f64
--- /dev/null
+++ b/devel/p5-Test-Declare/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Test/Declare/.packlist
+%%SITE_PERL%%/Test/Declare.pm
+@dirrmtry %%SITE_PERL%%/Test
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Test/Declare
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Test