aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorJun Kuriyama <kuriyama@FreeBSD.org>2010-11-22 02:14:39 +0000
committerJun Kuriyama <kuriyama@FreeBSD.org>2010-11-22 02:14:39 +0000
commit31b59df09cb0de436856834f8306d35ae096de56 (patch)
tree22b2bd4683c9b206a547d7885120ee29beb91c48 /devel
parent5718a1eea05fe99c8e48295e40b9fefbea1fdcd4 (diff)
downloadports-31b59df09cb0de436856834f8306d35ae096de56.tar.gz
ports-31b59df09cb0de436856834f8306d35ae096de56.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-B-Hooks-OP-Check-EntersubForCV/Makefile26
-rw-r--r--devel/p5-B-Hooks-OP-Check-EntersubForCV/distinfo2
-rw-r--r--devel/p5-B-Hooks-OP-Check-EntersubForCV/pkg-descr3
-rw-r--r--devel/p5-B-Hooks-OP-Check-EntersubForCV/pkg-plist9
5 files changed, 41 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 8058eac0c350..ce7c3dabfe12 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1196,6 +1196,7 @@
SUBDIR += p5-B-Graph
SUBDIR += p5-B-Hooks-EndOfScope
SUBDIR += p5-B-Hooks-OP-Check
+ SUBDIR += p5-B-Hooks-OP-Check-EntersubForCV
SUBDIR += p5-B-Hooks-OP-PPAddr
SUBDIR += p5-B-Hooks-Parser
SUBDIR += p5-B-Keywords
diff --git a/devel/p5-B-Hooks-OP-Check-EntersubForCV/Makefile b/devel/p5-B-Hooks-OP-Check-EntersubForCV/Makefile
new file mode 100644
index 000000000000..d8be2a9b2a37
--- /dev/null
+++ b/devel/p5-B-Hooks-OP-Check-EntersubForCV/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: B::Hooks::OP::Check::EntersubForCV
+# Date created: 22 Nov 2010
+# Whom: Jun Kuriyama <kuriyama@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= B-Hooks-OP-Check-EntersubForCV
+PORTVERSION= 0.06
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= kuriyama@FreeBSD.org
+COMMENT= Perl extension to invoke callback on construction of entersub OPs
+
+RUN_DEPENDS= \
+ p5-B-Hooks-OP-Check>=0.11:${PORTSDIR}/devel/p5-B-Hooks-OP-Check \
+ p5-B-Utils>0:${PORTSDIR}/devel/p5-B-Utils
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= B::Hooks::OP::Check::EntersubForCV.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-B-Hooks-OP-Check-EntersubForCV/distinfo b/devel/p5-B-Hooks-OP-Check-EntersubForCV/distinfo
new file mode 100644
index 000000000000..682bdda67bf4
--- /dev/null
+++ b/devel/p5-B-Hooks-OP-Check-EntersubForCV/distinfo
@@ -0,0 +1,2 @@
+SHA256 (B-Hooks-OP-Check-EntersubForCV-0.06.tar.gz) = 8aa164e0453a63e024ba9a1dbd5b631c11a04370af5261041125d6f215d0b481
+SIZE (B-Hooks-OP-Check-EntersubForCV-0.06.tar.gz) = 22023
diff --git a/devel/p5-B-Hooks-OP-Check-EntersubForCV/pkg-descr b/devel/p5-B-Hooks-OP-Check-EntersubForCV/pkg-descr
new file mode 100644
index 000000000000..10ff726b4877
--- /dev/null
+++ b/devel/p5-B-Hooks-OP-Check-EntersubForCV/pkg-descr
@@ -0,0 +1,3 @@
+Invoke callbacks on construction of entersub OPs for certain CVs.
+
+WWW: http://search.cpan.org/dist/B-Hooks-OP-Check-EntersubForCV/
diff --git a/devel/p5-B-Hooks-OP-Check-EntersubForCV/pkg-plist b/devel/p5-B-Hooks-OP-Check-EntersubForCV/pkg-plist
new file mode 100644
index 000000000000..a284e3ea92a3
--- /dev/null
+++ b/devel/p5-B-Hooks-OP-Check-EntersubForCV/pkg-plist
@@ -0,0 +1,9 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/B/Hooks/OP/Check/EntersubForCV/.packlist
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/B/Hooks/OP/Check/EntersubForCV/EntersubForCV.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/B/Hooks/OP/Check/EntersubForCV/EntersubForCV.so
+%%SITE_PERL%%/%%PERL_ARCH%%/B/Hooks/OP/Check/EntersubForCV.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/B/Hooks/OP/Check/EntersubForCV/Install/hook_op_check_entersubforcv.h
+%%SITE_PERL%%/%%PERL_ARCH%%/B/Hooks/OP/Check/EntersubForCV/Install/Files.pm
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/B/Hooks/OP/Check/EntersubForCV/Install
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/B/Hooks/OP/Check/EntersubForCV
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/B/Hooks/OP/Check/EntersubForCV