aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorFernando ApesteguĂ­a <fernape@FreeBSD.org>2020-10-24 12:26:45 +0000
committerFernando ApesteguĂ­a <fernape@FreeBSD.org>2020-10-24 12:26:45 +0000
commit34f51c4f76b8bbe70296f3ba92e9beb720e0c36a (patch)
tree9f478f106a1a750d0d5aeac9172f5ce6d4a7111c /devel
parent228df9358a1fd6e071da70afc06b68ced215c9de (diff)
downloadports-34f51c4f76b8bbe70296f3ba92e9beb720e0c36a.tar.gz
ports-34f51c4f76b8bbe70296f3ba92e9beb720e0c36a.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/easyexif/Makefile37
-rw-r--r--devel/easyexif/distinfo3
-rw-r--r--devel/easyexif/files/patch-Makefile15
-rw-r--r--devel/easyexif/pkg-descr8
5 files changed, 64 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 98c759d3bffd..7ff0dd9cdef3 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -504,6 +504,7 @@
SUBDIR += e00compr
SUBDIR += e2fsprogs-libss
SUBDIR += eastl
+ SUBDIR += easyefix
SUBDIR += easygit
SUBDIR += easyloggingpp
SUBDIR += ebnf2yacc
diff --git a/devel/easyexif/Makefile b/devel/easyexif/Makefile
new file mode 100644
index 000000000000..3434db826bb2
--- /dev/null
+++ b/devel/easyexif/Makefile
@@ -0,0 +1,37 @@
+# $FreeBSD$
+
+PORTNAME= easyexif
+DISTVERSIONPREFIX= v
+DISTVERSION= 1.0
+CATEGORIES= devel
+
+MAINTAINER= fernape@FreeBSD.org
+COMMENT= Tiny ISO-compliant C++ EXIF parsing library
+
+LICENSE= BSD2CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= compiler:c++11-lib shebangfix
+USE_GITHUB= yes
+GH_ACCOUNT= mayanklahiri
+
+SHEBANG_FILES= test.sh
+
+PLIST_FILES= easyexif/bin/demo \
+ easyexif/src/demo.cpp \
+ easyexif/src/exif.cpp \
+ include/exif.h
+
+do-install:
+ @${MKDIR} ${STAGEDIR}${PREFIX}/include
+ ${CP} ${WRKSRC}/*.h ${STAGEDIR}${PREFIX}/include
+ @${MKDIR} ${STAGEDIR}${PREFIX}/${PORTNAME}/src
+ ${CP} ${WRKSRC}/*.cpp ${STAGEDIR}${PREFIX}/${PORTNAME}/src
+ @${MKDIR} ${STAGEDIR}${PREFIX}/${PORTNAME}/bin
+ ${STRIP_CMD} ${WRKSRC}/demo
+ ${CP} ${WRKSRC}/demo ${STAGEDIR}${PREFIX}/${PORTNAME}/bin
+
+do-test:
+ cd ${WRKSRC} && ./test.sh
+
+.include <bsd.port.mk>
diff --git a/devel/easyexif/distinfo b/devel/easyexif/distinfo
new file mode 100644
index 000000000000..e11c2df451d5
--- /dev/null
+++ b/devel/easyexif/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1603453365
+SHA256 (mayanklahiri-easyexif-v1.0_GH0.tar.gz) = e4251ae76a172bfd676e9e24a5a27b970a81d1731296822ef1afaeb4857f045a
+SIZE (mayanklahiri-easyexif-v1.0_GH0.tar.gz) = 7549061
diff --git a/devel/easyexif/files/patch-Makefile b/devel/easyexif/files/patch-Makefile
new file mode 100644
index 000000000000..c4b76d4171da
--- /dev/null
+++ b/devel/easyexif/files/patch-Makefile
@@ -0,0 +1,15 @@
+--- Makefile.orig 2015-11-14 20:31:28 UTC
++++ Makefile
+@@ -1,5 +1,4 @@
+-CXX=g++
+-CXXFLAGS=-O2 -pedantic -Wall -Wextra -ansi -std=c++11
++#CXXFLAGS+=-O2 -pedantic -Wall -Wextra -ansi -std=c++11
+
+ all: demo
+
+@@ -10,4 +9,4 @@ demo: exif.o demo.cpp
+ $(CXX) $(CXXFLAGS) -o demo exif.o demo.cpp
+
+ clean:
+- rm -f *.o demo demo.exe
++ rm -f *.o demo
diff --git a/devel/easyexif/pkg-descr b/devel/easyexif/pkg-descr
new file mode 100644
index 000000000000..4d42ca2d567b
--- /dev/null
+++ b/devel/easyexif/pkg-descr
@@ -0,0 +1,8 @@
+EasyEXIF is a tiny, lightweight C++ library that parses basic information out of
+JPEG files. It uses only the std::string library and is otherwise pure C++. You
+pass it the binary contents of a JPEG file, and it parses several of the most
+important EXIF fields for you.
+
+Why use this library? Include one .h file, compile one .cc file, and that's it.
+
+WWW: https://github.com/mayanklahiri/easyexif