aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorAlexander Nedotsukov <bland@FreeBSD.org>2010-07-26 11:55:19 +0000
committerAlexander Nedotsukov <bland@FreeBSD.org>2010-07-26 11:55:19 +0000
commit3c1991f7d2c6ce8f74f3cadcd7367298e5f4ecb2 (patch)
tree10260cf7b4a1b89b2c66a99b071fd24dffabfb57 /devel
parentcec7778e5cf7472abb0836f2a8dc34e096f016b2 (diff)
downloadports-3c1991f7d2c6ce8f74f3cadcd7367298e5f4ecb2.tar.gz
ports-3c1991f7d2c6ce8f74f3cadcd7367298e5f4ecb2.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/py-icu/Makefile15
1 files changed, 12 insertions, 3 deletions
diff --git a/devel/py-icu/Makefile b/devel/py-icu/Makefile
index 20b6b3670624..cb27b969c4fc 100644
--- a/devel/py-icu/Makefile
+++ b/devel/py-icu/Makefile
@@ -7,6 +7,7 @@
PORTNAME= icu
PORTVERSION= 1.0
+PORTREVISION= 1
CATEGORIES= devel python
MASTER_SITES= ${MASTER_SITE_CHEESESHOP}
MASTER_SITE_SUBDIR= source/P/PyICU
@@ -16,8 +17,6 @@ DISTNAME= PyICU-${PORTVERSION}
MAINTAINER= bland@FreeBSD.org
COMMENT= Python extension wrapping IBM's ICU C++ API
-LIB_DEPENDS= icudata:${PORTSDIR}/devel/icu
-
USE_PYTHON= yes
USE_PYDISTUTILS= easy_install
PYDISTUTILS_PKGNAME= PyICU
@@ -29,4 +28,14 @@ MAKE_ENV+= \
PYICU_LFLAGS="-L${PREFIX}/lib" \
PYICU_LIBRARIES="icui18n:icuuc:icudata"
-.include <bsd.port.mk>
+OPTIONS= ICU4 "Use ICU 4.x instead of 3.8" off
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_ICU4) || exists(${LOCALBASE}/lib/libicudata.so.44)
+LIB_DEPENDS+= icudata:${PORTSDIR}/devel/icu4
+.else
+LIB_DEPENDS+= icudata:${PORTSDIR}/devel/icu
+.endif
+
+.include <bsd.port.post.mk>