aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2021-04-21 07:09:13 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2021-04-21 07:10:26 +0000
commit3cef5a93279bcf0b2de047592efd5365a90069b8 (patch)
tree34d3ba69d55f26d42789f97bff01f1d5d5ae1aed /devel
parentfe254a6435bbe85f5e6c42a52de80e5b713df63e (diff)
downloadports-3cef5a93279bcf0b2de047592efd5365a90069b8.tar.gz
ports-3cef5a93279bcf0b2de047592efd5365a90069b8.zip
devel/vexcl: Add build dependencies as run dependencies because this header-only library expects them at run-time
Diffstat (limited to 'devel')
-rw-r--r--devel/vexcl/Makefile13
1 files changed, 9 insertions, 4 deletions
diff --git a/devel/vexcl/Makefile b/devel/vexcl/Makefile
index f478b1dde040..ea7f7e7137c7 100644
--- a/devel/vexcl/Makefile
+++ b/devel/vexcl/Makefile
@@ -1,6 +1,6 @@
PORTNAME= vexcl
DISTVERSION= 1.4.1
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= devel
MAINTAINER= yuri@FreeBSD.org
@@ -9,13 +9,18 @@ COMMENT= C++ vector expression template library for OpenCL/CUDA
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE.md
-BUILD_DEPENDS= boost-libs>0:devel/boost-libs \
- opencl>0:devel/opencl \
- ocl-icd>0:devel/ocl-icd
+HPP_DEPENDS= boost-libs>0:devel/boost-libs \
+ opencl>0:devel/opencl
+BUILD_DEPENDS= ${HPP_DEPENDS} \
+ ocl-icd>0:devel/ocl-icd # devel/ocl-icd is probably not needed
+RUN_DEPENDS= ${HPP_DEPENDS}
USES= cmake localbase:ldflags
+
USE_GITHUB= yes
GH_ACCOUNT= ddemidov
+
+NO_BUILD= yes
NO_ARCH= yes
.include <bsd.port.mk>