aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorLev A. Serebryakov <lev@FreeBSD.org>2014-02-15 13:44:00 +0000
committerLev A. Serebryakov <lev@FreeBSD.org>2014-02-15 13:44:00 +0000
commit4b24b0341c86d1c5674de66d8b017ebc1f36ac5b (patch)
treef227e8421f2b706a2203f70cfcceb515f7382ed7 /devel
parent5c75ca783593d8ecd37e7e78b41352cae99191d0 (diff)
downloadports-4b24b0341c86d1c5674de66d8b017ebc1f36ac5b.tar.gz
ports-4b24b0341c86d1c5674de66d8b017ebc1f36ac5b.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/lm4tools/Makefile35
-rw-r--r--devel/lm4tools/distinfo2
-rw-r--r--devel/lm4tools/files/patch-lm4flash--Makefile18
-rw-r--r--devel/lm4tools/files/patch-lmicdiusb--Makefile15
-rw-r--r--devel/lm4tools/pkg-descr13
6 files changed, 84 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index b4f90ecc298e..f8f0c31acacb 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1156,6 +1156,7 @@
SUBDIR += llvm32
SUBDIR += llvm33
SUBDIR += llvm34
+ SUBDIR += lm4tools
SUBDIR += lmdbg
SUBDIR += lndir
SUBDIR += lockfree-malloc
diff --git a/devel/lm4tools/Makefile b/devel/lm4tools/Makefile
new file mode 100644
index 000000000000..4149d2beb9fc
--- /dev/null
+++ b/devel/lm4tools/Makefile
@@ -0,0 +1,35 @@
+# $FreeBSD$
+
+PORTNAME= lm4tools
+PORTVERSION= 0.1.3
+CATEGORIES= devel
+
+MAINTAINER= lev@FreeBSD.org
+COMMENT= TI Tiva C ARM microcontroller tools
+
+LICENSE= GPLv2 TIBSD
+LICENSE_COMB= multi
+LICENSE_NAME_TIBSD= Texas Instruments Software License Agreement
+LICENSE_FILE_TIBSD= ${WRKSRC}/lmicdiusb/license.txt
+LICENSE_PERMS_TIBSD= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
+
+USE_GITHUB= yes
+GH_ACCOUNT= utzig
+GH_TAGNAME= ${GH_COMMIT}
+GH_COMMIT= 1cfd813
+
+USES= gmake
+
+PLIST_FILES= bin/lm4flash bin/lmicdi
+
+.include <bsd.port.pre.mk>
+
+do-build:
+ @${GMAKE} -C ${WRKSRC}/lm4flash all
+ @${GMAKE} -C ${WRKSRC}/lmicdiusb all
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/lm4flash/lm4flash ${STAGEDIR}${PREFIX}/bin/
+ ${INSTALL_PROGRAM} ${WRKSRC}/lmicdiusb/lmicdi ${STAGEDIR}${PREFIX}/bin/
+
+.include <bsd.port.post.mk>
diff --git a/devel/lm4tools/distinfo b/devel/lm4tools/distinfo
new file mode 100644
index 000000000000..98acfe571ad1
--- /dev/null
+++ b/devel/lm4tools/distinfo
@@ -0,0 +1,2 @@
+SHA256 (lm4tools-0.1.3.tar.gz) = 6ddac399f13498902eb4c797add4f88366c369f7e60171ac5f44365b73ef9ada
+SIZE (lm4tools-0.1.3.tar.gz) = 25423
diff --git a/devel/lm4tools/files/patch-lm4flash--Makefile b/devel/lm4tools/files/patch-lm4flash--Makefile
new file mode 100644
index 000000000000..7d8f8fa75f13
--- /dev/null
+++ b/devel/lm4tools/files/patch-lm4flash--Makefile
@@ -0,0 +1,18 @@
+--- lm4flash/Makefile.orig 2013-09-24 05:12:04.000000000 +0400
++++ lm4flash/Makefile 2014-01-24 13:17:54.000000000 +0400
+@@ -1,12 +1,12 @@
+ EXE := lm4flash
+
+-CFLAGS := -Wall -g -O2 $(shell pkg-config --cflags libusb-1.0)
+-LDFLAGS := $(shell pkg-config --libs libusb-1.0)
++CFLAGS := -Wall -g -O2
++LDFLAGS := -lusb
+
+ all: $(EXE)
+
+ $(EXE): $(EXE).c
+- gcc $(CFLAGS) $^ $(LDFLAGS) -o $@
++ $(CC) $(CFLAGS) $^ $(LDFLAGS) -o $@
+
+ clean:
+ rm -f *.o $(EXE)
diff --git a/devel/lm4tools/files/patch-lmicdiusb--Makefile b/devel/lm4tools/files/patch-lmicdiusb--Makefile
new file mode 100644
index 000000000000..2331924d60d8
--- /dev/null
+++ b/devel/lm4tools/files/patch-lmicdiusb--Makefile
@@ -0,0 +1,15 @@
+--- lmicdiusb/Makefile.orig 2013-09-24 05:12:04.000000000 +0400
++++ lmicdiusb/Makefile 2014-01-24 13:20:08.000000000 +0400
+@@ -43,6 +43,12 @@
+ LDFLAGS += -framework AppKit -framework Carbon -framework IOKit
+ endif
+
++ifeq ($(shell uname),FreeBSD)
++ LIBUSB_CFLAGS :=
++ LIBUSB_LIBDIR := /usr/lib
++ LIBUSB_LIBS := -lusb
++endif
++
+ ifeq ($(shell uname),Linux)
+ LIBUSB_CFLAGS ?= $(shell pkg-config --cflags libusb-1.0)
+ LIBUSB_LIBDIR ?= $(shell pkg-config --variable=libdir libusb-1.0)
diff --git a/devel/lm4tools/pkg-descr b/devel/lm4tools/pkg-descr
new file mode 100644
index 000000000000..25d8236b06b1
--- /dev/null
+++ b/devel/lm4tools/pkg-descr
@@ -0,0 +1,13 @@
+ Some tools which enable multi-platform development on the TI Stellaris
+Launchpad boards. The Stellaris Launchpad is a low cost development board
+created by Texas Instruments that comes with an ARM Cortex-M4F processor.
+
+Included tools:
+
+ lm4flash Command-line firmware flashing tool using libusb-1.0
+ to communicate with the Stellaris Launchpad ICDI.
+
+ lmicdiusb TCP/USB bridge created by TI, letting GDB communicate with
+ the Stellaris Launchpad ICDI.
+
+WWW: https://launchpad.net/gcc-arm-embedded