aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorSheldon Hearn <sheldonh@FreeBSD.org>2000-08-15 10:22:36 +0000
committerSheldon Hearn <sheldonh@FreeBSD.org>2000-08-15 10:22:36 +0000
commit4e28d4de05080ad0b7b8856a3d4b645e47378d55 (patch)
treea7c667b9dd9e0be60fd47ff3bf6068ea94e1b149 /devel
parentbd9d1979dda9036d0ce5451e12ac694a83fc8880 (diff)
downloadports-4e28d4de05080ad0b7b8856a3d4b645e47378d55.tar.gz
ports-4e28d4de05080ad0b7b8856a3d4b645e47378d55.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/linux_devtools-6/Makefile13
-rw-r--r--devel/linux_devtools-6/pkg-install17
-rw-r--r--devel/linux_devtools-7/Makefile13
-rw-r--r--devel/linux_devtools-7/pkg-install17
-rw-r--r--devel/linux_devtools/Makefile13
-rw-r--r--devel/linux_devtools/pkg-install17
6 files changed, 60 insertions, 30 deletions
diff --git a/devel/linux_devtools-6/Makefile b/devel/linux_devtools-6/Makefile
index 05d0506c512e..ec843b794b92 100644
--- a/devel/linux_devtools-6/Makefile
+++ b/devel/linux_devtools-6/Makefile
@@ -91,17 +91,10 @@ NEEDLOADLINK= true
do-patch:
@${DO_NADA}
+pre-install:
+ @${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
+
do-install:
- @if [ -z "`kldstat -v | ${GREP} -E 'linux(aout|elf)'`" ]; then \
- ${ECHO} 'Linux mode is not enabled.\
- Loading linux kernel module...' | fmt; \
- linux || { \
- ${ECHO} 'The linux kernel module could not be loaded.\
- Please manually load the module and retry.\
- See "man linux" for details.' | fmt; \
- ${FALSE}; \
- };\
- fi
#
# Setup a chroot'able environment
#
diff --git a/devel/linux_devtools-6/pkg-install b/devel/linux_devtools-6/pkg-install
new file mode 100644
index 000000000000..957ee313fa57
--- /dev/null
+++ b/devel/linux_devtools-6/pkg-install
@@ -0,0 +1,17 @@
+#!/bin/sh
+# an installation script for linux_devtools
+
+case "$2" in
+PRE-INSTALL)
+ if [ -z "`kldstat -v | ${GREP} -E 'linux(aout|elf)'`" ]; then
+ echo 'Linux mode is not enabled.'
+ echo 'Loading linux kernel module now...'
+ if ! kldload linux; then
+ echo 'The linux kernel module could not be loaded.'
+ echo 'Please enable linux mode manually and retry.'
+ exit 1
+ fi
+ ;;
+esac
+
+exit 0
diff --git a/devel/linux_devtools-7/Makefile b/devel/linux_devtools-7/Makefile
index 05d0506c512e..ec843b794b92 100644
--- a/devel/linux_devtools-7/Makefile
+++ b/devel/linux_devtools-7/Makefile
@@ -91,17 +91,10 @@ NEEDLOADLINK= true
do-patch:
@${DO_NADA}
+pre-install:
+ @${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
+
do-install:
- @if [ -z "`kldstat -v | ${GREP} -E 'linux(aout|elf)'`" ]; then \
- ${ECHO} 'Linux mode is not enabled.\
- Loading linux kernel module...' | fmt; \
- linux || { \
- ${ECHO} 'The linux kernel module could not be loaded.\
- Please manually load the module and retry.\
- See "man linux" for details.' | fmt; \
- ${FALSE}; \
- };\
- fi
#
# Setup a chroot'able environment
#
diff --git a/devel/linux_devtools-7/pkg-install b/devel/linux_devtools-7/pkg-install
new file mode 100644
index 000000000000..957ee313fa57
--- /dev/null
+++ b/devel/linux_devtools-7/pkg-install
@@ -0,0 +1,17 @@
+#!/bin/sh
+# an installation script for linux_devtools
+
+case "$2" in
+PRE-INSTALL)
+ if [ -z "`kldstat -v | ${GREP} -E 'linux(aout|elf)'`" ]; then
+ echo 'Linux mode is not enabled.'
+ echo 'Loading linux kernel module now...'
+ if ! kldload linux; then
+ echo 'The linux kernel module could not be loaded.'
+ echo 'Please enable linux mode manually and retry.'
+ exit 1
+ fi
+ ;;
+esac
+
+exit 0
diff --git a/devel/linux_devtools/Makefile b/devel/linux_devtools/Makefile
index 05d0506c512e..ec843b794b92 100644
--- a/devel/linux_devtools/Makefile
+++ b/devel/linux_devtools/Makefile
@@ -91,17 +91,10 @@ NEEDLOADLINK= true
do-patch:
@${DO_NADA}
+pre-install:
+ @${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
+
do-install:
- @if [ -z "`kldstat -v | ${GREP} -E 'linux(aout|elf)'`" ]; then \
- ${ECHO} 'Linux mode is not enabled.\
- Loading linux kernel module...' | fmt; \
- linux || { \
- ${ECHO} 'The linux kernel module could not be loaded.\
- Please manually load the module and retry.\
- See "man linux" for details.' | fmt; \
- ${FALSE}; \
- };\
- fi
#
# Setup a chroot'able environment
#
diff --git a/devel/linux_devtools/pkg-install b/devel/linux_devtools/pkg-install
new file mode 100644
index 000000000000..957ee313fa57
--- /dev/null
+++ b/devel/linux_devtools/pkg-install
@@ -0,0 +1,17 @@
+#!/bin/sh
+# an installation script for linux_devtools
+
+case "$2" in
+PRE-INSTALL)
+ if [ -z "`kldstat -v | ${GREP} -E 'linux(aout|elf)'`" ]; then
+ echo 'Linux mode is not enabled.'
+ echo 'Loading linux kernel module now...'
+ if ! kldload linux; then
+ echo 'The linux kernel module could not be loaded.'
+ echo 'Please enable linux mode manually and retry.'
+ exit 1
+ fi
+ ;;
+esac
+
+exit 0