aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2014-09-06 13:02:52 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2014-09-06 13:02:52 +0000
commit521f90159c96b935e8c40ea2d64dadcb864e2db9 (patch)
treed542c759b6b8ae0e6eebf3a2a07b28b1ac6a9b28 /devel
parent69778959042abc76e1ecb8cc3dd7d2e245eda0d1 (diff)
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/libgetline/Makefile3
-rw-r--r--devel/libgetline/files/patch-Makefile8
2 files changed, 4 insertions, 7 deletions
diff --git a/devel/libgetline/Makefile b/devel/libgetline/Makefile
index 96151275b072..dc48e447eef8 100644
--- a/devel/libgetline/Makefile
+++ b/devel/libgetline/Makefile
@@ -25,7 +25,4 @@ MAKE_ENV+= INST_INCDIR="${STAGEDIR}${PREFIX}/include"
MAKE_ENV+= INST_LIBDIR="${STAGEDIR}${PREFIX}/lib"
MAKE_ENV+= INST_MANDIR="${STAGEDIR}${PREFIX}/man"
-post-install:
- ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libgetline.so
-
.include <bsd.port.mk>
diff --git a/devel/libgetline/files/patch-Makefile b/devel/libgetline/files/patch-Makefile
index 42a7deb7ccae..9f3f0a2f3695 100644
--- a/devel/libgetline/files/patch-Makefile
+++ b/devel/libgetline/files/patch-Makefile
@@ -72,11 +72,11 @@
- cp getline.3 $(INST_MANDIR)/man3
-
+ [ -d $(INST_LIBDIR) ] || $(INSTALL) -d $(INST_LIBDIR)
-+ $(INSTALL) -c -g bin -o bin -m 644 libgetline.a libgetline.so.1 \
-+ $(INST_LIBDIR)
++ $(BSD_INSTALL_DATA) libgetline.a $(INST_LIBDIR)
++ $(BSD_INSTALL_LIB) libgetline.so.1 $(INST_LIBDIR)
+ $(LN) -fs libgetline.so.$(SHLIB_VERSION) \
+ $(INST_LIBDIR)/libgetline.so
+ [ -d $(INST_MANDIR)/man3 ] || $(INSTALL) -d $(INST_MANDIR)/man3
-+ $(INSTALL) -c -g bin -o bin -m 644 getline.3 $(INST_MANDIR)/man3
++ $(BSD_INSTALL_MAN) getline.3 $(INST_MANDIR)/man3
+ [ -d $(INST_INCDIR) ] || $(INSTALL) -d $(INST_INCDIR)
-+ $(INSTALL) -c -g bin -o bin -m 644 getline.h $(INST_INCDIR)
++ $(BSD_INSTALL_DATA) getline.h $(INST_INCDIR)