aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorKevin Lo <kevlo@FreeBSD.org>2002-06-28 07:59:02 +0000
committerKevin Lo <kevlo@FreeBSD.org>2002-06-28 07:59:02 +0000
commit567d5a0d9496030b6e146cad01257bacff5928a7 (patch)
tree25b9c635611533d2177342d0108a5c464f938d75 /devel
parenta33196df5ea4ec7bc2af4c1b825c1cf7c0bf4ea6 (diff)
downloadports-567d5a0d9496030b6e146cad01257bacff5928a7.tar.gz
ports-567d5a0d9496030b6e146cad01257bacff5928a7.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/stlport/Makefile14
1 files changed, 13 insertions, 1 deletions
diff --git a/devel/stlport/Makefile b/devel/stlport/Makefile
index 0e9bb4873f8e..e9be2833fb90 100644
--- a/devel/stlport/Makefile
+++ b/devel/stlport/Makefile
@@ -34,6 +34,14 @@ INSTALLS_SHLIB= yes
BROKEN= "Not supported on systems prior to FreeBSD 4.4"
.endif
+.if ${OSVERSION} < 460000
+pre-everything:
+ @${ECHO_MSG}
+ @${ECHO_MSG} "There may be a bug in your version of gcc's exception"
+ @${ECHO_MSG} "handling code. Consider upgrading to FreeBSD 4.6"
+ @${ECHO_MSG} "or above."
+.endif
+
post-install:
${FIND} ${PREFIX}/include/stlport -name \*.orig -delete
.if !defined(NOPORTDOCS)
@@ -43,7 +51,11 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/../doc/images/* ${DOCSDIR}/images
.endif
-post-build test:
+.if ${OSVERSION} >= 46000
+post-build: test
+.endif
+
+test:
cd ${WRKSRC}/../test/eh && ${SETENV} CC=${CC} CXX=${CXX} \
${GMAKE} -f ${MAKEFILE} PTHREAD_CFLAGS=${PTHREAD_CFLAGS} \
PTHREAD_LIBS=${PTHREAD_LIBS} PTHREAD_CFLAGS=${PTHREAD_CFLAGS} \