aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2017-05-18 16:02:57 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2017-05-18 16:02:57 +0000
commit5b9336260d9ef239418b5f5341c4628ba9f5e6f6 (patch)
treeba86dcb6663b21f39d6c11bbbe522a01881b1838 /devel
parent7c6049efcb29044a36cab0ada75559e12e8d488f (diff)
downloadports-5b9336260d9ef239418b5f5341c4628ba9f5e6f6.tar.gz
ports-5b9336260d9ef239418b5f5341c4628ba9f5e6f6.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-smmap2/Makefile21
-rw-r--r--devel/py-smmap2/distinfo3
-rw-r--r--devel/py-smmap2/pkg-descr12
4 files changed, 37 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index b5b3d89e62c0..08373fc15a54 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4723,6 +4723,7 @@
SUBDIR += py-sip
SUBDIR += py-six
SUBDIR += py-smmap
+ SUBDIR += py-smmap2
SUBDIR += py-sortedcontainers
SUBDIR += py-sourcemap
SUBDIR += py-spark
diff --git a/devel/py-smmap2/Makefile b/devel/py-smmap2/Makefile
new file mode 100644
index 000000000000..a86a928b5ea7
--- /dev/null
+++ b/devel/py-smmap2/Makefile
@@ -0,0 +1,21 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= smmap2
+PORTVERSION= 2.0.1
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Sliding-window memory map manager
+
+LICENSE= BSD3CLAUSE
+
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}nose>=0:devel/py-nose
+
+NO_ARCH= yes
+USE_PYTHON= autoplist distutils
+USES= python
+
+.include <bsd.port.mk>
diff --git a/devel/py-smmap2/distinfo b/devel/py-smmap2/distinfo
new file mode 100644
index 000000000000..d4b97eedcf40
--- /dev/null
+++ b/devel/py-smmap2/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1495051618
+SHA256 (smmap2-2.0.1.tar.gz) = 5c9fd3ac4a30b85d041a8bd3779e16aa704a161991e74b9a46692bc368e68752
+SIZE (smmap2-2.0.1.tar.gz) = 21948
diff --git a/devel/py-smmap2/pkg-descr b/devel/py-smmap2/pkg-descr
new file mode 100644
index 000000000000..8cd7aa22ad2f
--- /dev/null
+++ b/devel/py-smmap2/pkg-descr
@@ -0,0 +1,12 @@
+Smmap wraps an interface around mmap and tracks the mapped files as well as the
+amount of clients who use it. If the system runs out of resources, or if a
+memory limit is reached, it will automatically unload unused maps to allow
+continued operation.
+
+To allow processing large files even on 32 bit systems, it allows only portions
+of the file to be mapped. Once the user reads beyond the mapped region, smmap
+will automatically map the next required region, unloading unused regions using
+a LRU algorithm.
+
+WWW: https://pypi.python.org/pypi/smmap2
+WWW: https://github.com/gitpython-developers/smmap