aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorAndrej Zverev <az@FreeBSD.org>2013-09-16 08:39:20 +0000
committerAndrej Zverev <az@FreeBSD.org>2013-09-16 08:39:20 +0000
commit6600d6be8a6ea1a652282364f19ee9f37cd9ad1c (patch)
treed471d509e8536b17b01a19757858c0918802bab8 /devel
parent7ec4b3d1a268df1e30726e5ae185bfa7ec7af2dc (diff)
downloadports-6600d6be8a6ea1a652282364f19ee9f37cd9ad1c.tar.gz
ports-6600d6be8a6ea1a652282364f19ee9f37cd9ad1c.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/avr-gcc/Makefile4
-rw-r--r--devel/baz/Makefile5
-rw-r--r--devel/cvsweb3/Makefile2
-rw-r--r--devel/gitolite2/Makefile2
-rw-r--r--devel/msp430-gcc/Makefile5
-rw-r--r--devel/otrs/Makefile2
-rw-r--r--devel/p5-Data-RoundRobin/Makefile3
-rw-r--r--devel/p5-Debug-Client/Makefile3
-rw-r--r--devel/p5-MooseX-OneArgNew/Makefile3
-rw-r--r--devel/p5-Object-InsideOut/Makefile3
-rw-r--r--devel/p5-String-Errf/Makefile3
-rw-r--r--devel/p5-Test-NoWarnings/Makefile3
-rw-r--r--devel/p5-Test-Portability-Files/Makefile3
-rw-r--r--devel/p5-Thread-Suspend/Makefile3
-rw-r--r--devel/p5-doxygenfilter/Makefile3
-rw-r--r--devel/quilt/Makefile3
-rw-r--r--devel/svk/Makefile3
17 files changed, 30 insertions, 23 deletions
diff --git a/devel/avr-gcc/Makefile b/devel/avr-gcc/Makefile
index 2b81516900c6..3896989e87ed 100644
--- a/devel/avr-gcc/Makefile
+++ b/devel/avr-gcc/Makefile
@@ -32,10 +32,10 @@ CONFIGURE_WRKSRC= ${BUILD_WRKSRC}
INSTALL_WRKSRC= ${BUILD_WRKSRC}
CONFIGURE_SCRIPT= ../gcc-${PORTVERSION}/configure
-USE_PERL5_BUILD= yes
+USE_PERL5= build
USE_BZIP2= yes
CPPFLAGS+= -I${LOCALBASE}/include
-USES= bison gettext gmake
+USES= bison gettext gmake perl5
GNU_CONFIGURE= yes
.include <bsd.port.pre.mk>
diff --git a/devel/baz/Makefile b/devel/baz/Makefile
index 43762b066541..86e77a9a0f06 100644
--- a/devel/baz/Makefile
+++ b/devel/baz/Makefile
@@ -24,9 +24,8 @@ LIB_DEPENDS= neon.27:${PORTSDIR}/www/neon29 \
CONFLICTS= gd-2.*
-USE_GMAKE= yes
-USES= gettext
-USE_PERL5_BUILD=yes
+USES= gettext gmake perl5
+USE_PERL5= build
GNU_CONFIGURE= yes
MAKE_JOBS_UNSAFE= yes
diff --git a/devel/cvsweb3/Makefile b/devel/cvsweb3/Makefile
index 69e64068294b..f7f7641847b8 100644
--- a/devel/cvsweb3/Makefile
+++ b/devel/cvsweb3/Makefile
@@ -30,8 +30,8 @@ RUN_DEPENDS+= enscript:${PORTSDIR}/print/enscript-${PAPERSIZE}
LATEST_LINK= cvsweb3
CONFLICTS= cvsweb-2.*
+USES= perl5
NO_BUILD= yes
-USE_PERL5= yes
.include <bsd.port.pre.mk>
diff --git a/devel/gitolite2/Makefile b/devel/gitolite2/Makefile
index a34f675c5f6f..156800d54c45 100644
--- a/devel/gitolite2/Makefile
+++ b/devel/gitolite2/Makefile
@@ -16,7 +16,7 @@ RUN_DEPENDS= git>=0:${PORTSDIR}/devel/git
LATEST_LINK= gitolite2
CONFLICTS= gitolite-[^2]*
-USE_PERL5= yes
+USES= perl5
SUB_FILES= pkg-message
diff --git a/devel/msp430-gcc/Makefile b/devel/msp430-gcc/Makefile
index 82f7d533535d..df7a5cb6ba17 100644
--- a/devel/msp430-gcc/Makefile
+++ b/devel/msp430-gcc/Makefile
@@ -46,9 +46,8 @@ WRKSRC= ${WRKDIR}/build
PATCH_WRKSRC= ${SRCDIR}
USE_BZIP2= yes
-USE_GMAKE= yes
-USES= bison iconv
-USE_PERL5_BUILD=yes
+USES= bison iconv gmake perl5
+USE_PERL5= build
GNU_CONFIGURE= yes
CONFIGURE_SCRIPT=../${SRCDIR:S/${WRKDIR}\///}/configure
diff --git a/devel/otrs/Makefile b/devel/otrs/Makefile
index 09e454dcd703..ee97499f3933 100644
--- a/devel/otrs/Makefile
+++ b/devel/otrs/Makefile
@@ -75,8 +75,8 @@ CLEAN_FILES= scripts/suse* scripts/redhat* \
var/httpd/htdocs/js/thirdparty/ckeditor-4.0/_source \
var/httpd/htdocs/skins/Agent/*/img/source
+USES= perl5
USE_APACHE_RUN= 22+
-USE_PERL5= yes
PLIST_SUB+= VER_CKEDITOR="4.0"
diff --git a/devel/p5-Data-RoundRobin/Makefile b/devel/p5-Data-RoundRobin/Makefile
index 76b2b6c115c1..865816bb1831 100644
--- a/devel/p5-Data-RoundRobin/Makefile
+++ b/devel/p5-Data-RoundRobin/Makefile
@@ -14,7 +14,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= lwhsu@FreeBSD.org
COMMENT= Serve data in a round robin manner
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Data::RoundRobin.3
diff --git a/devel/p5-Debug-Client/Makefile b/devel/p5-Debug-Client/Makefile
index c4fd6b76203a..3666880644fe 100644
--- a/devel/p5-Debug-Client/Makefile
+++ b/devel/p5-Debug-Client/Makefile
@@ -20,7 +20,8 @@ TEST_DEPENDS= p5-File-HomeDir>=1.00:${PORTSDIR}/devel/p5-File-HomeDir \
p5-Test-Class>=0.38:${PORTSDIR}/devel/p5-Test-Class \
p5-Test-Deep>=0.110:${PORTSDIR}/devel/p5-Test-Deep
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Debug::Client.3
diff --git a/devel/p5-MooseX-OneArgNew/Makefile b/devel/p5-MooseX-OneArgNew/Makefile
index 6a1cee7eebdd..b23207bff0e0 100644
--- a/devel/p5-MooseX-OneArgNew/Makefile
+++ b/devel/p5-MooseX-OneArgNew/Makefile
@@ -22,7 +22,8 @@ RUN_DEPENDS= p5-MooseX-Role-Parameterized>=0:${PORTSDIR}/devel/p5-MooseX-Role-Pa
p5-namespace-autoclean>=0:${PORTSDIR}/devel/p5-namespace-autoclean
BUILD_DEPENDS:= ${RUN_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERl5= configure
MAN3= MooseX::OneArgNew.3
diff --git a/devel/p5-Object-InsideOut/Makefile b/devel/p5-Object-InsideOut/Makefile
index e082b524b98a..2ed59db39db3 100644
--- a/devel/p5-Object-InsideOut/Makefile
+++ b/devel/p5-Object-InsideOut/Makefile
@@ -19,7 +19,8 @@ BUILD_DEPENDS= p5-Data-Dumper>=2.131:${PORTSDIR}/devel/p5-Data-Dumper \
p5-Want>=0.21:${PORTSDIR}/devel/p5-Want
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Bundle::Object::InsideOut.3 \
Object::InsideOut.3 \
diff --git a/devel/p5-String-Errf/Makefile b/devel/p5-String-Errf/Makefile
index e01d9666ce3d..57ec1428a9a0 100644
--- a/devel/p5-String-Errf/Makefile
+++ b/devel/p5-String-Errf/Makefile
@@ -22,7 +22,8 @@ BUILD_DEPENDS:= p5-TimeDate>=0:${PORTSDIR}/devel/p5-TimeDate \
p5-autodie>=0:${PORTSDIR}/devel/p5-autodie \
${RUN_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= String::Errf.3
diff --git a/devel/p5-Test-NoWarnings/Makefile b/devel/p5-Test-NoWarnings/Makefile
index 81f01f5732b2..c02464fcf7db 100644
--- a/devel/p5-Test-NoWarnings/Makefile
+++ b/devel/p5-Test-NoWarnings/Makefile
@@ -13,7 +13,8 @@ COMMENT= Hide and store warnings while running test scripts
TEST_DEPENDS= p5-Test-Tester>=0.10.7:${PORTSDIR}/devel/p5-Test-Tester
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Test::NoWarnings.3
diff --git a/devel/p5-Test-Portability-Files/Makefile b/devel/p5-Test-Portability-Files/Makefile
index 18d7b72991cc..5e2fac79172c 100644
--- a/devel/p5-Test-Portability-Files/Makefile
+++ b/devel/p5-Test-Portability-Files/Makefile
@@ -10,7 +10,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= lippe@FreeBSD.org
COMMENT= Test::Portability::Files Check file names portability
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Test::Portability::Files.3
diff --git a/devel/p5-Thread-Suspend/Makefile b/devel/p5-Thread-Suspend/Makefile
index cbda72772244..bb01049543f9 100644
--- a/devel/p5-Thread-Suspend/Makefile
+++ b/devel/p5-Thread-Suspend/Makefile
@@ -11,7 +11,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= pclin@FreeBSD.org
COMMENT= Suspend and resume operations for threads
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Thread::Suspend.3
diff --git a/devel/p5-doxygenfilter/Makefile b/devel/p5-doxygenfilter/Makefile
index 16e08595db48..0a4d5936cd14 100644
--- a/devel/p5-doxygenfilter/Makefile
+++ b/devel/p5-doxygenfilter/Makefile
@@ -17,7 +17,8 @@ COMMENT= Input filter for Doxygen enabling support for Perl code documentation
RUN_DEPENDS= ${LOCALBASE}/bin/doxygen:${PORTSDIR}/devel/doxygen
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= DoxyGen::Filter.3
diff --git a/devel/quilt/Makefile b/devel/quilt/Makefile
index 862d1350a34b..17495a71d9f2 100644
--- a/devel/quilt/Makefile
+++ b/devel/quilt/Makefile
@@ -21,8 +21,7 @@ BUILD_DEPENDS= bash:${PORTSDIR}/shells/bash \
RUN_DEPENDS:= ${BUILD_DEPENDS} \
formail:${PORTSDIR}/mail/procmail
-USE_GMAKE= yes
-USE_PERL5= yes
+USES= gmake perl5
OPTIONS_DEFINE= RPMBUILD DOCS NLS
RPMBUILD_DESC= rpmbuild support
diff --git a/devel/svk/Makefile b/devel/svk/Makefile
index fa1cd2de0aa4..800e8444eb38 100644
--- a/devel/svk/Makefile
+++ b/devel/svk/Makefile
@@ -53,7 +53,8 @@ BUILD_DEPENDS= p5-List-MoreUtils>=0:${PORTSDIR}/lang/p5-List-MoreUtils \
p5-version>=0.68:${PORTSDIR}/devel/p5-version
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN1= svk.1
MAN3= SVK.3 \