aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2006-02-21 20:49:48 +0000
committerRenato Botelho <garga@FreeBSD.org>2006-02-21 20:49:48 +0000
commit6918ca3b2909e66632b093a7fa23c61516db4e5e (patch)
tree5bccb9133f5b44216a51dc0dadf551b3994e4f7a /devel
parent5fc54b32b209e75d721462bd7932ac986568c0a3 (diff)
downloadports-6918ca3b2909e66632b093a7fa23c61516db4e5e.tar.gz
ports-6918ca3b2909e66632b093a7fa23c61516db4e5e.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/libytnef/Makefile32
-rw-r--r--devel/libytnef/distinfo3
-rw-r--r--devel/libytnef/pkg-descr17
-rw-r--r--devel/libytnef/pkg-plist9
5 files changed, 62 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index dc9fa06a0073..fd2b73786553 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -542,6 +542,7 @@
SUBDIR += libvanessa_socket
SUBDIR += libvc
SUBDIR += libxalloc
+ SUBDIR += libytnef
SUBDIR += libzvbi
SUBDIR += lightning
SUBDIR += lincvs
diff --git a/devel/libytnef/Makefile b/devel/libytnef/Makefile
new file mode 100644
index 000000000000..e3445cda0874
--- /dev/null
+++ b/devel/libytnef/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: libytnef
+# Date created: 21 Feb 2005
+# Whom: Rodrigo Graeff <delphus@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libytnef
+PORTVERSION= 1.5
+CATEGORIES= devel mail
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ytnef
+
+MAINTAINER= delphus@gmail.com
+COMMENT= Unpack data in MS Outlook TNEF format
+
+GNU_CONFIGURE= yes
+USE_AUTOTOOLS= libtool:15
+INSTALLS_SHLIB= yes
+USE_GETOPT_LONG=yes
+
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+
+PORTDOCS= AUTHORS NEWS README
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/libytnef/distinfo b/devel/libytnef/distinfo
new file mode 100644
index 000000000000..bbe5fcdcb0b9
--- /dev/null
+++ b/devel/libytnef/distinfo
@@ -0,0 +1,3 @@
+MD5 (libytnef-1.5.tar.gz) = 6c44b955f33cf714c75a7bbe895cc352
+SHA256 (libytnef-1.5.tar.gz) = 1b22a1e42e047c41a41917e89544992c33d30e9bd798b5b8ca7ef1eb75e1752e
+SIZE (libytnef-1.5.tar.gz) = 212412
diff --git a/devel/libytnef/pkg-descr b/devel/libytnef/pkg-descr
new file mode 100644
index 000000000000..8333d75aadb5
--- /dev/null
+++ b/devel/libytnef/pkg-descr
@@ -0,0 +1,17 @@
+This is the library needed to YTNEF aaplication
+
+This program decodes those annoying application/ms-tnef MIME attachments that
+Microsoft mail servers helpfully use to encapsulate your already MIME encoded
+attachments.
+
+Due to the proliferation of Microsoft Outlook and Exchange mail servers,
+more and more mail is encapsulated into this format.
+
+The YTNEF program allows one to unpack the attachments which were encapsulated
+into the YTNEF attachment. Thus alleviating the need to use Microsoft Outlook
+to view them.
+
+Now supports winmail.dat Outlook files
+
+Author: Randall Hand <randall.hand@gmail.com>
+WWW: http://ytnef.sourceforge.net/
diff --git a/devel/libytnef/pkg-plist b/devel/libytnef/pkg-plist
new file mode 100644
index 000000000000..4c6b011bef79
--- /dev/null
+++ b/devel/libytnef/pkg-plist
@@ -0,0 +1,9 @@
+include/mapi.h
+include/mapidefs.h
+include/mapitags.h
+include/tnef-errors.h
+include/tnef-types.h
+include/ytnef.h
+lib/libytnef.a
+lib/libytnef.so
+lib/libytnef.so.0