aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2013-11-15 16:48:33 +0000
committerMathieu Arnold <mat@FreeBSD.org>2013-11-15 16:48:33 +0000
commit6bf99e9ee67f2f1025aabe1803233f26f4c163d8 (patch)
tree066e904c645b5925cbeaedaec337e7e9996f67f7 /devel
parent2bdc8c6a517a66450ec8d336f3571ef55735c6e0 (diff)
downloadports-6bf99e9ee67f2f1025aabe1803233f26f4c163d8.tar.gz
ports-6bf99e9ee67f2f1025aabe1803233f26f4c163d8.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-DateTime-Format-RSS/Makefile25
-rw-r--r--devel/p5-DateTime-Format-RSS/distinfo2
-rw-r--r--devel/p5-DateTime-Format-RSS/pkg-descr7
-rw-r--r--devel/p5-DateTime-Format-RSS/pkg-plist8
5 files changed, 43 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 18a8a11dbe66..b80ab7d7147d 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1809,6 +1809,7 @@
SUBDIR += p5-DateTime-Format-Oracle
SUBDIR += p5-DateTime-Format-Pg
SUBDIR += p5-DateTime-Format-RFC3339
+ SUBDIR += p5-DateTime-Format-RSS
SUBDIR += p5-DateTime-Format-Roman
SUBDIR += p5-DateTime-Format-SQLite
SUBDIR += p5-DateTime-Format-Strptime
diff --git a/devel/p5-DateTime-Format-RSS/Makefile b/devel/p5-DateTime-Format-RSS/Makefile
new file mode 100644
index 000000000000..9b779c3a57f0
--- /dev/null
+++ b/devel/p5-DateTime-Format-RSS/Makefile
@@ -0,0 +1,25 @@
+# Created by: Anes Mukhametov <anes@anes.su>
+# $FreeBSD$
+
+PORTNAME= DateTime-Format-RSS
+PORTVERSION= 0.03000
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= anes@anes.su
+COMMENT= Format DateTime For RSS
+
+RUN_DEPENDS= p5-DateTime-Format-DateParse>=0:${PORTSDIR}/devel/p5-DateTime-Format-DateParse \
+ p5-DateTime-Format-ISO8601>=0:${PORTSDIR}/devel/p5-DateTime-Format-ISO8601 \
+ p5-DateTime-Format-Mail>=0:${PORTSDIR}/devel/p5-DateTime-Format-Mail \
+ p5-Class-Accessor-Fast-XS>=0:${PORTSDIR}/devel/p5-Class-Accessor-Fast-XS
+BUILD_DEPENDS= p5-DateTime-Format-DateParse>=0:${PORTSDIR}/devel/p5-DateTime-Format-DateParse \
+ p5-DateTime-Format-ISO8601>=0:${PORTSDIR}/devel/p5-DateTime-Format-ISO8601 \
+ p5-DateTime-Format-Mail>=0:${PORTSDIR}/devel/p5-DateTime-Format-Mail \
+ p5-Class-Accessor-Fast-XS>=0:${PORTSDIR}/devel/p5-Class-Accessor-Fast-XS
+
+USES= perl5
+USE_PERL5= configure
+
+.include <bsd.port.mk>
diff --git a/devel/p5-DateTime-Format-RSS/distinfo b/devel/p5-DateTime-Format-RSS/distinfo
new file mode 100644
index 000000000000..5bf040fa28b9
--- /dev/null
+++ b/devel/p5-DateTime-Format-RSS/distinfo
@@ -0,0 +1,2 @@
+SHA256 (DateTime-Format-RSS-0.03000.tar.gz) = ec17a6233a225fdf7e8700b096fa33aa3285a0fac1ffc1173ccbfb6160561631
+SIZE (DateTime-Format-RSS-0.03000.tar.gz) = 18846
diff --git a/devel/p5-DateTime-Format-RSS/pkg-descr b/devel/p5-DateTime-Format-RSS/pkg-descr
new file mode 100644
index 000000000000..a464390aa664
--- /dev/null
+++ b/devel/p5-DateTime-Format-RSS/pkg-descr
@@ -0,0 +1,7 @@
+Format DateTime For RSS
+
+DateTime::Format::RSS attempts to deal with those nasty RSS
+date/time strings used in fields (such as <issued>, <modified>,
+<pubDate>) that never ever seems to be right.
+
+WWW: http://search.cpan.org/dist/DateTime-Format-RSS/
diff --git a/devel/p5-DateTime-Format-RSS/pkg-plist b/devel/p5-DateTime-Format-RSS/pkg-plist
new file mode 100644
index 000000000000..c98e5593ee4e
--- /dev/null
+++ b/devel/p5-DateTime-Format-RSS/pkg-plist
@@ -0,0 +1,8 @@
+%%PERL5_MAN3%%/DateTime::Format::RSS.3.gz
+%%SITE_PERL%%/DateTime/Format/RSS.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/DateTime/Format/RSS/.packlist
+@dirrmtry %%SITE_PERL%%/DateTime/Format
+@dirrmtry %%SITE_PERL%%/DateTime
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/DateTime/Format/RSS
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/DateTime/Format
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/DateTime