aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorWesley Shields <wxs@FreeBSD.org>2009-03-31 20:06:07 +0000
committerWesley Shields <wxs@FreeBSD.org>2009-03-31 20:06:07 +0000
commit787a3b3f86fb19f629774aa25a871db544ba5381 (patch)
treebcf55a7b7769574ff9cde7fff17bb8d480f12de9 /devel
parent64346c0d660f6cc897c9d2205eae5dd962947fe2 (diff)
downloadports-787a3b3f86fb19f629774aa25a871db544ba5381.tar.gz
ports-787a3b3f86fb19f629774aa25a871db544ba5381.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Getopt-Mixed/Makefile26
-rw-r--r--devel/p5-Getopt-Mixed/distinfo3
-rw-r--r--devel/p5-Getopt-Mixed/pkg-descr4
-rw-r--r--devel/p5-Getopt-Mixed/pkg-plist6
5 files changed, 40 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 6451699380a8..8cdbbeac7aa2 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1415,6 +1415,7 @@
SUBDIR += p5-Getopt-Euclid
SUBDIR += p5-Getopt-Long
SUBDIR += p5-Getopt-Long-Descriptive
+ SUBDIR += p5-Getopt-Mixed
SUBDIR += p5-Getopt-Popt
SUBDIR += p5-Git-PurePerl
SUBDIR += p5-Glib2
diff --git a/devel/p5-Getopt-Mixed/Makefile b/devel/p5-Getopt-Mixed/Makefile
new file mode 100644
index 000000000000..13e527730b34
--- /dev/null
+++ b/devel/p5-Getopt-Mixed/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: devel/p5-Getopt-Mixed
+# Date created: 17 Jan 2003
+# Whom: sumikawa
+#
+# $FreeBSD$
+#
+
+PORTNAME= Getopt-Mixed
+PORTVERSION= 1.10
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Perl module for processing of both short and long command line options
+
+DEPRECATED= Use devel/p5-Getopt-Long instead
+
+PERL_CONFIGURE= yes
+
+MAN3= Getopt::Mixed.3
+
+pre-configure:
+ ${PERL} -pi -e 'm.INSTALLDIRS.&&s,.,,sg' ${WRKSRC}/Makefile.PL
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Getopt-Mixed/distinfo b/devel/p5-Getopt-Mixed/distinfo
new file mode 100644
index 000000000000..f077885b4ca7
--- /dev/null
+++ b/devel/p5-Getopt-Mixed/distinfo
@@ -0,0 +1,3 @@
+MD5 (Getopt-Mixed-1.10.tar.gz) = 9d384322a4368b326efdf899bce5838a
+SHA256 (Getopt-Mixed-1.10.tar.gz) = 0fe4e5ba512fc35d07f097dede07088463482e26517bb2836175535c8bcfa0eb
+SIZE (Getopt-Mixed-1.10.tar.gz) = 11199
diff --git a/devel/p5-Getopt-Mixed/pkg-descr b/devel/p5-Getopt-Mixed/pkg-descr
new file mode 100644
index 000000000000..b9e5ee03f25a
--- /dev/null
+++ b/devel/p5-Getopt-Mixed/pkg-descr
@@ -0,0 +1,4 @@
+This module provides GNU-style option processing for Perl 5 scripts,
+with both long and short options. Please see the documentation at the
+end of the module for instructions on its use and licensing
+restrictions.
diff --git a/devel/p5-Getopt-Mixed/pkg-plist b/devel/p5-Getopt-Mixed/pkg-plist
new file mode 100644
index 000000000000..92824667e6a9
--- /dev/null
+++ b/devel/p5-Getopt-Mixed/pkg-plist
@@ -0,0 +1,6 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Getopt/Mixed/.packlist
+%%SITE_PERL%%/Getopt/Mixed.pm
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Getopt/Mixed
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Mixed
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Getopt
+@dirrmtry %%SITE_PERL%%/Getopt