aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorAlex Kozlov <ak@FreeBSD.org>2013-10-18 19:42:31 +0000
committerAlex Kozlov <ak@FreeBSD.org>2013-10-18 19:42:31 +0000
commit7e5197398288f31e7370d072dbbbee3201704e5b (patch)
tree6f14c3b3663e97af7f1291381dd90c9ae5953660 /devel
parenteaec20c9e45547fe82683a3ddc2ce2d9e8b03344 (diff)
downloadports-7e5197398288f31e7370d072dbbbee3201704e5b.tar.gz
ports-7e5197398288f31e7370d072dbbbee3201704e5b.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/jwasm/Makefile21
-rw-r--r--devel/jwasm/pkg-descr14
2 files changed, 15 insertions, 20 deletions
diff --git a/devel/jwasm/Makefile b/devel/jwasm/Makefile
index b34b732efa09..b1ae165385e1 100644
--- a/devel/jwasm/Makefile
+++ b/devel/jwasm/Makefile
@@ -7,8 +7,8 @@ CATEGORIES= devel
MASTER_SITES= http://www.japheth.de/Download/JWasm/
DISTNAME= JWasm${PORTVERSION}s
-MAINTAINER= ports@FreeBSD.org
-COMMENT= Fork of OpenWatcom's x86 assembler with AMD64 support
+MAINTAINER= ak@FreeBSD.org
+COMMENT= Fork of OpenWatcom x86 assembler with AMD64 support
OPTIONS_DEFINE= DOCS
@@ -18,13 +18,12 @@ NO_WRKSUBDIR= yes
USE_ZIP= yes
USE_DOS2UNIX= yes
-USE_GMAKE= yes
+USES= gmake
MAKEFILE= GccUnix.mak
PORTDOCS= *
PLIST_FILES= bin/jwasm
-NO_STAGE= yes
.include <bsd.port.options.mk>
post-patch:
@@ -34,14 +33,10 @@ post-patch:
s|-s -o|-o|' ${WRKSRC}/GccUnix.mak
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/GccUnixR/jwasm ${PREFIX}/bin
-.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/*.txt ${DOCSDIR}
- @${GZIP_CMD} ${DOCSDIR}/*.txt
- @${MKDIR} ${DOCSDIR}/manual
- ${INSTALL_DATA} ${WRKSRC}/Doc/*.txt ${DOCSDIR}/manual
- @${GZIP_CMD} ${DOCSDIR}/manual/*.txt
-.endif
+ ${INSTALL_PROGRAM} ${WRKSRC}/GccUnixR/jwasm ${STAGEDIR}${PREFIX}/bin
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/*.txt ${STAGEDIR}${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}/manual
+ ${INSTALL_DATA} ${WRKSRC}/Doc/*.txt ${STAGEDIR}${DOCSDIR}/manual
.include <bsd.port.mk>
diff --git a/devel/jwasm/pkg-descr b/devel/jwasm/pkg-descr
index 9542554a43d9..281feaecad93 100644
--- a/devel/jwasm/pkg-descr
+++ b/devel/jwasm/pkg-descr
@@ -1,18 +1,18 @@
-JWasm is a MASM v6 compatible assembler. It's a fork of Open Watcom's WASM
-and released under the Sybase Open Watcom Public License, which allows
-free commercial and non-commercial use. JWasm is written in C, source code
+JWasm is a MASM v6 compatible assembler. It's a fork of Open Watcom's WASM
+and released under the Sybase Open Watcom Public License, which allows
+free commercial and non-commercial use. JWasm is written in C, source code
is open.
JWasm Features:
-- JWasm natively supports output formats Intel OMF, MS Coff (32- and
+- JWasm natively supports output formats Intel OMF, MS Coff (32- and
64-bit), Elf (32- and 64-bit), Bin and DOS MZ.
-- precompiled JWasm binaries are available for DOS, Windows and Linux. For
+- precompiled JWasm binaries are available for DOS, Windows and Linux. For
OS/2 and FreeBSD, makefiles are supplied.
- Instructions up to SSSE3 are supported.
-- The JWasm source is portable and has successfully been tested with Open
+- The JWasm source is portable and has successfully been tested with Open
Watcom, MS VC, GCC and more.
-- As far as programming for Windows is concerned, JWasm can be used with
+- As far as programming for Windows is concerned, JWasm can be used with
both Win32Inc and Masm32.
- C header files can be converted to include files for JWasm with h2incX.