aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorAaron Dalton <aaron@FreeBSD.org>2006-06-25 16:23:20 +0000
committerAaron Dalton <aaron@FreeBSD.org>2006-06-25 16:23:20 +0000
commit8eb1d23284eae1d02a1582ddbc6d9224eb7d86e9 (patch)
tree7dc5967d5fed774ae771c1a7d5c424321a6e8225 /devel
parent0cbae168906befab015e79fad597fb12df894198 (diff)
downloadports-8eb1d23284eae1d02a1582ddbc6d9224eb7d86e9.tar.gz
ports-8eb1d23284eae1d02a1582ddbc6d9224eb7d86e9.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Package-Constants/Makefile22
-rw-r--r--devel/p5-Package-Constants/distinfo3
-rw-r--r--devel/p5-Package-Constants/pkg-descr6
-rw-r--r--devel/p5-Package-Constants/pkg-plist5
5 files changed, 37 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index e8cc4d44ae9b..76b80867882b 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1170,6 +1170,7 @@
SUBDIR += p5-POE-XS-Queue-Array
SUBDIR += p5-PPerl
SUBDIR += p5-PV
+ SUBDIR += p5-Package-Constants
SUBDIR += p5-PadWalker
SUBDIR += p5-Parallel-ForkManager
SUBDIR += p5-Params-CallbackRequest
diff --git a/devel/p5-Package-Constants/Makefile b/devel/p5-Package-Constants/Makefile
new file mode 100644
index 000000000000..e3e6e09efb8a
--- /dev/null
+++ b/devel/p5-Package-Constants/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: p5-Package-Constants
+# Date created: 25 Jun 2006
+# Whom: Aaron Dalton <aaron@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Package-Constants
+PORTVERSION= 0.01
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../../authors/id/K/KA/KANE
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= aaron@FreeBSD.org
+COMMENT= List all constants declared in a package
+
+MAN3= Package::Constants.3
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Package-Constants/distinfo b/devel/p5-Package-Constants/distinfo
new file mode 100644
index 000000000000..907d1bfadc55
--- /dev/null
+++ b/devel/p5-Package-Constants/distinfo
@@ -0,0 +1,3 @@
+MD5 (Package-Constants-0.01.tar.gz) = 1449c0b9f1cbf42d8588734322085d18
+SHA256 (Package-Constants-0.01.tar.gz) = 699a56f53f593e8a3acfee61cd06457b7c989d33ac0b31844a942aa19231c217
+SIZE (Package-Constants-0.01.tar.gz) = 2543
diff --git a/devel/p5-Package-Constants/pkg-descr b/devel/p5-Package-Constants/pkg-descr
new file mode 100644
index 000000000000..ad81ec012db5
--- /dev/null
+++ b/devel/p5-Package-Constants/pkg-descr
@@ -0,0 +1,6 @@
+Package::Constants lists all the constants defined in a certain package.
+This can be useful for, among others, setting up an autogenerated
+@EXPORT/@EXPORT_OK for a Constants.pm file.
+
+WWW: http://search.cpan.org/dist/Package-Constants
+Author: Jos Boumans <kane@cpan.org>
diff --git a/devel/p5-Package-Constants/pkg-plist b/devel/p5-Package-Constants/pkg-plist
new file mode 100644
index 000000000000..aa5ec0bc0425
--- /dev/null
+++ b/devel/p5-Package-Constants/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/Package/Constants.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Package/Constants/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Package/Constants
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Package
+@dirrmtry %%SITE_PERL%%/Package