aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2019-05-23 09:12:33 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2019-05-23 09:12:33 +0000
commit908306a459a672eb3086a3eb078e17d829f210e0 (patch)
tree148865817eb7d5480fb49c6ddd0bda76f55c6878 /devel
parente9847a5fea1dc0295ed1a725cbcd0b1d07d6b5c4 (diff)
downloadports-908306a459a672eb3086a3eb078e17d829f210e0.tar.gz
ports-908306a459a672eb3086a3eb078e17d829f210e0.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/llvm60/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/devel/llvm60/Makefile b/devel/llvm60/Makefile
index f8e77762360c..555007065c22 100644
--- a/devel/llvm60/Makefile
+++ b/devel/llvm60/Makefile
@@ -256,6 +256,12 @@ _COMPILER_RT_LIBS+= \
CXXFLAGS+= -D_GLIBCXX_USE_C99
.endif
+# Use lld for armv6 on clang 7 and up to avoid binutils ld issues
+# PR: 235282
+.if ${COMPILER_TYPE} == clang && ${COMPILER_VERSION} >= 70
+LDFLAGS_armv6=-fuse-ld=lld
+.endif
+
.if ${ARCH} == "armv6"
BUILD_DEPENDS+= ${LOCALBASE}/bin/ld:devel/binutils
CONFIGURE_ENV+= COMPILER_PATH=${LOCALBASE}/bin