aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorTom McLaughlin <tmclaugh@FreeBSD.org>2007-02-04 22:44:39 +0000
committerTom McLaughlin <tmclaugh@FreeBSD.org>2007-02-04 22:44:39 +0000
commitb6c1c263c68d3508ce4f091c32d30cc77a0af980 (patch)
tree94ee95f0ac7a876d9072c2a2b8ea9322c6b85b10 /devel
parent0707b3c1db64fecbda5d89236946ef85909f1724 (diff)
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/dbus-sharp/Makefile15
1 files changed, 4 insertions, 11 deletions
diff --git a/devel/dbus-sharp/Makefile b/devel/dbus-sharp/Makefile
index 627e82e7d8e9..9cc404601640 100644
--- a/devel/dbus-sharp/Makefile
+++ b/devel/dbus-sharp/Makefile
@@ -3,12 +3,12 @@
# Whom: Tom McLaughlin <tmclaugh@sdf.lonestar.org>
#
# $FreeBSD$
-# $Id: Makefile,v 1.18 2006/01/02 20:54:03 tmclau02 Exp $
+# $Id: Makefile,v 1.26 2006/11/15 16:22:08 tmclau02 Exp $
#
PORTNAME= dbus-sharp
PORTVERSION= 0.62
-PORTREVISION= 17
+PORTREVISION= 19
CATEGORIES= devel gnome
MASTER_SITES= http://dbus.freedesktop.org/releases/dbus/
DISTNAME= dbus-${PORTVERSION}
@@ -17,13 +17,11 @@ MAINTAINER= bsd-sharp-list@forge.novell.com
COMMENT= Mono interface to the D-BUS messaging system
LIB_DEPENDS= dbus-1.3:${PORTSDIR}/devel/dbus
-BUILD_DEPENDS= monodoc:${PORTSDIR}/devel/mono-tools
-RUN_DEPENDS= monodoc:${PORTSDIR}/devel/mono-tools
BUILD_WRKSRC= ${WRKSRC}/mono
INSTALL_WRKSRC= ${BUILD_WRKSRC}
-USE_GNOME= gnomehack gnometarget
+USE_GNOME= gnomehack gnometarget gtksharp10
USE_GMAKE= yes
USE_AUTOTOOLS= libtool:15
CONFIGURE_ARGS= --enable-mono \
@@ -37,14 +35,9 @@ CONFIGURE_ARGS= --enable-mono \
--with-session-socket-dir=/var/tmp \
--disable-doxygen-docs \
--disable-xml-docs
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib" \
PTHREAD_LIBS="${PTHREAD_LIBS}"
-# Disable those, since it doesn't install docs yet.
-#post-patch:
-# @${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g' \
-# ${WRKSRC}/mono/doc/Makefile.in
-
.include "${.CURDIR}/../../lang/mono/bsd.mono.mk"
.include <bsd.port.mk>