aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2013-09-18 02:36:27 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2013-09-18 02:36:27 +0000
commitc22ba52bd0563af33f5336b79822aa8d5139e75e (patch)
tree65e62a1c1885feecd8f0a7be59a75a749a4fafe2 /devel
parentd3fa8d53422adb0c6d94dd7c387798f258f1ad90 (diff)
downloadports-c22ba52bd0563af33f5336b79822aa8d5139e75e.tar.gz
ports-c22ba52bd0563af33f5336b79822aa8d5139e75e.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/libclaw/Makefile2
-rw-r--r--devel/libclaw/files/patch-claw-impl-box__2d.tpp13
-rw-r--r--devel/libclaw/files/patch-claw-impl-rectangle.tpp11
-rw-r--r--devel/libclaw/files/patch-claw-impl-socket__stream.tpp20
4 files changed, 45 insertions, 1 deletions
diff --git a/devel/libclaw/Makefile b/devel/libclaw/Makefile
index 57cd3327e082..d212657796f9 100644
--- a/devel/libclaw/Makefile
+++ b/devel/libclaw/Makefile
@@ -16,7 +16,7 @@ BUILD_DEPENDS= ${LOCALBASE}/include/boost/bind.hpp:${PORTSDIR}/devel/boost-libs
USES= cmake gettext
CMAKE_ARGS= -DCLAW_CMAKE_MODULES_INSTALL_PATH="${DATADIR}/cmake"
USE_LDCONFIG= yes
-USE_GCC= yes
+#USE_GCC= yes
post-patch:
@${REINPLACE_CMD} -e '/subdirs/ s|doc||' ${WRKSRC}/CMakeLists.txt
diff --git a/devel/libclaw/files/patch-claw-impl-box__2d.tpp b/devel/libclaw/files/patch-claw-impl-box__2d.tpp
new file mode 100644
index 000000000000..14068036e2af
--- /dev/null
+++ b/devel/libclaw/files/patch-claw-impl-box__2d.tpp
@@ -0,0 +1,13 @@
+--- claw/impl/box_2d.tpp.orig 2013-07-03 23:34:38.000000000 +0400
++++ claw/impl/box_2d.tpp 2013-09-14 02:59:04.591227299 +0400
+@@ -136,8 +136,8 @@
+ claw::math::box_2d<U> claw::math::box_2d<T>::cast_value_type_to() const
+ {
+ return claw::math::box_2d<U>
+- ( first_point.cast_value_type_to<U>(),
+- second_point.cast_value_type_to<U>() );
++ ( first_point.template cast_value_type_to<U>(),
++ second_point.template cast_value_type_to<U>() );
+ } // box_2d::cast_value_type_to()
+
+ /*----------------------------------------------------------------------------*/
diff --git a/devel/libclaw/files/patch-claw-impl-rectangle.tpp b/devel/libclaw/files/patch-claw-impl-rectangle.tpp
new file mode 100644
index 000000000000..56371294f060
--- /dev/null
+++ b/devel/libclaw/files/patch-claw-impl-rectangle.tpp
@@ -0,0 +1,11 @@
+--- claw/impl/rectangle.tpp.orig 2013-07-03 23:34:38.000000000 +0400
++++ claw/impl/rectangle.tpp 2013-09-14 02:57:21.105226690 +0400
+@@ -140,7 +140,7 @@
+ claw::math::rectangle<U> claw::math::rectangle<T>::cast_value_type_to() const
+ {
+ return claw::math::rectangle<U>
+- ( position.cast_value_type_to<U>(), (U)width, (U)height );
++ ( position.template cast_value_type_to<U>(), (U)width, (U)height );
+ } // rectangle::cast_value_type_to()
+
+ /*----------------------------------------------------------------------------*/
diff --git a/devel/libclaw/files/patch-claw-impl-socket__stream.tpp b/devel/libclaw/files/patch-claw-impl-socket__stream.tpp
new file mode 100644
index 000000000000..776ceb9429f0
--- /dev/null
+++ b/devel/libclaw/files/patch-claw-impl-socket__stream.tpp
@@ -0,0 +1,20 @@
+--- claw/impl/socket_stream.tpp.orig 2013-07-03 23:34:38.000000000 +0400
++++ claw/impl/socket_stream.tpp 2013-09-14 03:12:49.742226665 +0400
+@@ -37,7 +37,7 @@
+ template<typename CharT, typename Traits>
+ claw::net::basic_socket_stream<CharT, Traits>::basic_socket_stream
+ ( int read_delay )
+- : m_buffer(read_delay)
++ : std::basic_iostream<CharT, Traits>(&m_buffer), m_buffer(read_delay)
+ {
+ this->init(&m_buffer);
+ } // basic_socket_stream::basic_socket_stream()
+@@ -53,7 +53,7 @@
+ template<typename CharT, typename Traits>
+ claw::net::basic_socket_stream<CharT, Traits>::basic_socket_stream
+ ( const char* address, int port, int read_delay )
+- : m_buffer(read_delay)
++ : std::basic_iostream<CharT, Traits>(&m_buffer), m_buffer(read_delay)
+ {
+ this->init(&m_buffer);
+ open(address, port);