aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2015-11-15 13:25:58 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2015-11-15 13:25:58 +0000
commitcf0becfc3b02394142f5b7eaa7a3a94bc9eaf1d8 (patch)
treef1a3515773a75bcfa9d972ef96660b14f7aca9b0 /devel
parent660fbacf685278f31830600206b7e7a2ee8754f1 (diff)
downloadports-cf0becfc3b02394142f5b7eaa7a3a94bc9eaf1d8.tar.gz
ports-cf0becfc3b02394142f5b7eaa7a3a94bc9eaf1d8.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/capstone/Makefile8
-rw-r--r--devel/capstone/distinfo4
-rw-r--r--devel/capstone/pkg-plist6
3 files changed, 11 insertions, 7 deletions
diff --git a/devel/capstone/Makefile b/devel/capstone/Makefile
index c76f419c3702..7a0178890712 100644
--- a/devel/capstone/Makefile
+++ b/devel/capstone/Makefile
@@ -1,13 +1,14 @@
# $FreeBSD$
PORTNAME= capstone
-PORTVERSION= 2.1.2
+PORTVERSION= 3.0.4
CATEGORIES= devel
MAINTAINER= oliver.pntr@gmail.com
COMMENT= Multi-platform, multi-architecture disassembly framework
LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE.TXT
USES= gmake
USE_LDCONFIG= yes
@@ -17,8 +18,7 @@ GH_ACCOUNT= aquynh
MAKE_ENV+= INSTALL_LIB="${INSTALL_LIB}" \
INSTALL_DATA="${INSTALL_DATA}"
-post-build:
- # The pkgconfig file is generated and points to stagedir
- ${REINPLACE_CMD} -e '/libdir/s|\(libdir=\)\(.*\)\(devel/capstone/work/stage\)|\1|g' ${WRKSRC}/capstone.pc
+TEST_ENV= ${MAKE_ENV} LD_LIBRARY_PATH=${STAGEDIR}${PREFIX}/lib
+TEST_TARGET= check
.include <bsd.port.mk>
diff --git a/devel/capstone/distinfo b/devel/capstone/distinfo
index bcbdfabbe3b5..c59304332f77 100644
--- a/devel/capstone/distinfo
+++ b/devel/capstone/distinfo
@@ -1,2 +1,2 @@
-SHA256 (aquynh-capstone-2.1.2_GH0.tar.gz) = 5312ba5fc09fe193f7fc2fd6cbbc34b6ea7a7b002c0fd7acb2b38ee6c492fb9c
-SIZE (aquynh-capstone-2.1.2_GH0.tar.gz) = 1366145
+SHA256 (aquynh-capstone-3.0.4_GH0.tar.gz) = 5d6dadf5864c56f8de66c66088fa68e849d0bff6577865a4f81b6f23112b14f2
+SIZE (aquynh-capstone-3.0.4_GH0.tar.gz) = 2800818
diff --git a/devel/capstone/pkg-plist b/devel/capstone/pkg-plist
index 6d2fc6c432ee..4425c5aa533d 100644
--- a/devel/capstone/pkg-plist
+++ b/devel/capstone/pkg-plist
@@ -2,9 +2,13 @@ include/capstone/arm.h
include/capstone/arm64.h
include/capstone/capstone.h
include/capstone/mips.h
+include/capstone/platform.h
include/capstone/ppc.h
+include/capstone/sparc.h
+include/capstone/systemz.h
include/capstone/x86.h
+include/capstone/xcore.h
lib/libcapstone.a
lib/libcapstone.so
-lib/libcapstone.so.2
+lib/libcapstone.so.3
libdata/pkgconfig/capstone.pc