aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorFlorian Smeets <flo@FreeBSD.org>2012-12-14 15:47:00 +0000
committerFlorian Smeets <flo@FreeBSD.org>2012-12-14 15:47:00 +0000
commitd26530b7136cdbbc743cb41cba488928a2fb490e (patch)
tree2f5c5fe4cb36fc6a28856c97750108bf78f9b5b4 /devel
parent7045030009ee59cfe75c17ba591c3798c3478b68 (diff)
downloadports-d26530b7136cdbbc743cb41cba488928a2fb490e.tar.gz
ports-d26530b7136cdbbc743cb41cba488928a2fb490e.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/gvfs/Makefile3
-rw-r--r--devel/libewf/Makefile3
-rw-r--r--devel/libvshadow/Makefile4
-rw-r--r--devel/py-fusefs/Makefile3
4 files changed, 4 insertions, 9 deletions
diff --git a/devel/gvfs/Makefile b/devel/gvfs/Makefile
index 3b97ec6cb81c..9f8956f8f0da 100644
--- a/devel/gvfs/Makefile
+++ b/devel/gvfs/Makefile
@@ -39,8 +39,7 @@ OPTIONS= FUSE "Enable fuse" off \
.include <bsd.port.pre.mk>
.if defined(WITH_FUSE)
-LIB_DEPENDS+= fuse.2:${PORTSDIR}/sysutils/fusefs-libs
-RUN_DEPENDS+= mount_fusefs:${PORTSDIR}/sysutils/fusefs-kmod
+USE_FUSE= yes
PLIST_SUB+= FUSE=""
.else
CONFIGURE_ARGS+= --disable-fuse
diff --git a/devel/libewf/Makefile b/devel/libewf/Makefile
index b6e5cdc406c1..93e1435302be 100644
--- a/devel/libewf/Makefile
+++ b/devel/libewf/Makefile
@@ -17,9 +17,8 @@ LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= uuid:${PORTSDIR}/misc/e2fsprogs-libuuid \
- fuse:${PORTSDIR}/sysutils/fusefs-libs
-RUN_DEPENDS= ${LOCALBASE}/modules/fuse.ko:${PORTSDIR}/sysutils/fusefs-kmod
+USE_FUSE= yes
USE_GETTEXT= yes
USE_ICONV= yes
USE_LDCONFIG= yes
diff --git a/devel/libvshadow/Makefile b/devel/libvshadow/Makefile
index f9dacd80b203..a9ecbf6999a8 100644
--- a/devel/libvshadow/Makefile
+++ b/devel/libvshadow/Makefile
@@ -17,9 +17,7 @@ COMMENT= A library to support the Volume Service Snapshot (VSS) format
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/COPYING
-LIB_DEPENDS= fuse:${PORTSDIR}/sysutils/fusefs-libs
-RUN_DEPENDS= ${LOCALBASE}/modules/fuse.ko:${PORTSDIR}/sysutils/fusefs-kmod
-
+USE_FUSE= yes
USE_GETTEXT= yes
USE_ICONV= yes
USE_LDCONFIG= yes
diff --git a/devel/py-fusefs/Makefile b/devel/py-fusefs/Makefile
index afbecc59769a..bce6720114d1 100644
--- a/devel/py-fusefs/Makefile
+++ b/devel/py-fusefs/Makefile
@@ -15,8 +15,7 @@ DISTNAME= fuse-python-${DISTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= FUSE Python bindings
-LIB_DEPENDS= fuse.2:${PORTSDIR}/sysutils/fusefs-libs
-
+USE_FUSE= yes
USE_PYTHON= yes
USE_PKGCONFIG= yes
USE_PYDISTUTILS=easy_install