aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2001-01-14 06:05:16 +0000
committerWill Andrews <will@FreeBSD.org>2001-01-14 06:05:16 +0000
commitdb3f608af1d96d5da456b48b555972234cd877e0 (patch)
tree2d8d86f3686eec3499bcbfcbdf1e3e492cc72f0f /devel
parent776b1b5e879b47190458979767623555c93fbed5 (diff)
downloadports-db3f608af1d96d5da456b48b555972234cd877e0.tar.gz
ports-db3f608af1d96d5da456b48b555972234cd877e0.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Class-Singleton/Makefile24
-rw-r--r--devel/p5-Class-Singleton/distinfo1
-rw-r--r--devel/p5-Class-Singleton/pkg-comment1
-rw-r--r--devel/p5-Class-Singleton/pkg-descr13
-rw-r--r--devel/p5-Class-Singleton/pkg-plist3
6 files changed, 43 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 9b2e94c31888..495435a6c610 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -225,6 +225,7 @@
SUBDIR += p5-C-Scan
SUBDIR += p5-Class-MethodMaker
SUBDIR += p5-ConfigReader
+ SUBDIR += p5-Class-Singleton
SUBDIR += p5-Class-Tom
SUBDIR += p5-Config-IniFiles
SUBDIR += p5-Curses
diff --git a/devel/p5-Class-Singleton/Makefile b/devel/p5-Class-Singleton/Makefile
new file mode 100644
index 000000000000..e0cccdc4aef4
--- /dev/null
+++ b/devel/p5-Class-Singleton/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: Class-Singleton
+# Date created: Sun Jan 14 00:56:46 2001
+# Whom: will
+#
+# $FreeBSD$
+#
+
+PORTNAME= Class-Singleton
+PORTVERSION= 1.03
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Class
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= ports@FreeBSD.org
+
+SITE_PERL= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}
+USE_PERL5= yes
+PERL_CONFIGURE= yes
+
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= Class::Singleton.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Class-Singleton/distinfo b/devel/p5-Class-Singleton/distinfo
new file mode 100644
index 000000000000..cbfbc4a3fd73
--- /dev/null
+++ b/devel/p5-Class-Singleton/distinfo
@@ -0,0 +1 @@
+MD5 (Class-Singleton-1.03.tar.gz) = 80202a57411cb3e939fec327a87564bf
diff --git a/devel/p5-Class-Singleton/pkg-comment b/devel/p5-Class-Singleton/pkg-comment
new file mode 100644
index 000000000000..9b9fab2491e3
--- /dev/null
+++ b/devel/p5-Class-Singleton/pkg-comment
@@ -0,0 +1 @@
+Perl module that describes a singular object class
diff --git a/devel/p5-Class-Singleton/pkg-descr b/devel/p5-Class-Singleton/pkg-descr
new file mode 100644
index 000000000000..63c06c82422f
--- /dev/null
+++ b/devel/p5-Class-Singleton/pkg-descr
@@ -0,0 +1,13 @@
+This is the Class::Singleton module. A Singleton describes an
+object class that can have only one instance in any system. An
+example of a Singleton might be a print spooler or system
+registry. This module implements a Singleton class from which
+other classes can be derived. By itself, the Class::Singleton
+module does very little other than manage the instantiation of a
+single object. In deriving a class from Class::Singleton, your
+module will inherit the Singleton instantiation method and can
+implement whatever specific functionality is required.
+
+Author: Andy Wardley <abw@cre.canon.co.uk>
+
+--will
diff --git a/devel/p5-Class-Singleton/pkg-plist b/devel/p5-Class-Singleton/pkg-plist
new file mode 100644
index 000000000000..c42ef3e5a0cb
--- /dev/null
+++ b/devel/p5-Class-Singleton/pkg-plist
@@ -0,0 +1,3 @@
+lib/perl5/site_perl/%%PERL_VER%%/Class/Singleton.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Class/Singleton/.packlist
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Class/Singleton