aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2018-12-24 23:25:32 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2018-12-24 23:25:32 +0000
commite243e33b8a1ea816730a1d40d2950c5d761752f3 (patch)
tree6e543c78d6cb76541bf03e0d6912a40ab6d21fd7 /devel
parent13791ed2eac49b243f10de08355dec9e93b54820 (diff)
downloadports-e243e33b8a1ea816730a1d40d2950c5d761752f3.tar.gz
ports-e243e33b8a1ea816730a1d40d2950c5d761752f3.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-aiorpcX/Makefile23
-rw-r--r--devel/py-aiorpcX/distinfo3
-rw-r--r--devel/py-aiorpcX/pkg-descr4
4 files changed, 31 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index d8d1cbc57b77..d2c82eccd703 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4349,6 +4349,7 @@
SUBDIR += py-ZopeUndo
SUBDIR += py-adb
SUBDIR += py-aioice
+ SUBDIR += py-aiorpcX
SUBDIR += py-aiortc
SUBDIR += py-akismet
SUBDIR += py-amalgamate
diff --git a/devel/py-aiorpcX/Makefile b/devel/py-aiorpcX/Makefile
new file mode 100644
index 000000000000..16a701ce4100
--- /dev/null
+++ b/devel/py-aiorpcX/Makefile
@@ -0,0 +1,23 @@
+# Created by: Emanuel Haupt <ehaupt@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= aiorpcX
+PORTVERSION= 0.10.1
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= ehaupt@FreeBSD.org
+COMMENT= Generic async RPC implementation, including JSON-RPC
+
+LICENSE= MIT
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}attrs>=0:devel/py-attrs@${PY_FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}attrs>=0:devel/py-attrs@${PY_FLAVOR}
+
+USES= python:3.6+
+USE_PYTHON= distutils autoplist
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/devel/py-aiorpcX/distinfo b/devel/py-aiorpcX/distinfo
new file mode 100644
index 000000000000..8897a40d582c
--- /dev/null
+++ b/devel/py-aiorpcX/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1545590184
+SHA256 (aiorpcX-0.10.1.tar.gz) = 0c0a3342a43d939f00af84684fd08c0c5e7de4fa3eb21740063bea98f6070798
+SIZE (aiorpcX-0.10.1.tar.gz) = 23250
diff --git a/devel/py-aiorpcX/pkg-descr b/devel/py-aiorpcX/pkg-descr
new file mode 100644
index 000000000000..74eaada27448
--- /dev/null
+++ b/devel/py-aiorpcX/pkg-descr
@@ -0,0 +1,4 @@
+A generic asyncio library implementation of RPC suitable for an application that
+is a client, server or both.
+
+WWW: https://pypi.org/project/aiorpcX/